Apache is not starting

Hi All,

I have configured rt. Apache is working but it is redirecting me on
http://bestpractical.com/rt/rt-broken-install.html.

I  have configured apache2 with modperl.

I follow the README file from /usr/local/rt3/share/doc

make testdebs shows that every thing is found

I tried web interface (Apache2) with mod_perl

put the following lines in /etc/apache2/apache.conf

ServerName your.rt.server.hostname DocumentRoot /opt/rt3/share/html AddDefaultCharset UTF-8 PerlModule Apache::DBI PerlRequire /opt/rt3/bin/webmux.pl SetHandler perl-script PerlHandler RT::Mason

replacing ip address, hostname and Document root ie usr/local.rt3/share/html
ip:- 10.2.1.142
hostname :- test.india.campuseai.org
document root :- usr/local.rt3/share/html
it looks alike following

<VirtualHost 10.2.1.142 >
ServerName test.india.campuseai.org
DocumentRoot /usr/local/rt3/share/html
AddDefaultCharset UTF-8
#PerlModule Apache::DBI
#PerlRequire /usr/local/rt3/bin/webmux.pl

SetHandler perl-script

PerlHandler RT::Mason

but i have to comment 5,6,9th lines otherwise server is not restarting.

I follow the insttructions and install perl -MCPAN -e’install Apache::DBI’
but still if i uncomment these lines it returns error.

Saying following

test:/usr/local/rt3/share/doc# /etc/init.d/apache2 restart
Forcing reload of web server: Apache2Syntax error on line 403 of
/etc/apache2/apache2.conf:
Invalid command ‘PerlModule’, perhaps mis-spelled or defined by a
module not included in the server >configuration

Suggest me in this regard.
Thanks for your suggestion in advance.

Stay in the know. Pulse on the new Yahoo.com. Check it out.

I tried web interface (Apache2) with mod_perl

Saying following

test:/usr/local/rt3/share/doc# /etc/init.d/apache2 restart
Forcing reload of web server: Apache2Syntax error on line 403 of
/etc/apache2/apache2.conf:
Invalid command ‘PerlModule’, perhaps mis-spelled or defined by a
module not included in the server >configuration

Abhisheh,
Thes suggests that you didn’t actually build or install mod_perl2 or
that you didn’t configure apache to use it correctly.

Best,
Jesse

I am very new in linux, I found a lots of documents and follow them to install mod perl but i i think, I am wrong at any point.
I am using Debian as os.
I download a lots of tarballs from different locations, but unable to find out which one is perfect
I have tried apache 2 with Fact CGI also but facing some problem
Can u send me the steps to upgrade the Apache2 with either Fast CGI or Mod perl
and the location from where i can download Apache and Fact_Cgi/Mod+perl
so that i can rebuild Apache
I will be thankful to you

Regards
Abhishek

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Can i get any update on it?

I am very new in linux, I found a lots of documents and follow them to install mod perl but i i think, I am wrong at any point.
I am using Debian as os.
I download a lots of tarballs from different locations, but unable to find out which one is perfect
I have tried apache 2 with Fact CGI also but facing some problem
Can u send me the steps to upgrade the Apache2 with either Fast CGI or Mod perl
and the location from where i can download Apache and Fact_Cgi/Mod+perl
so that i can rebuild Apache
I will be thankful to you

Regards
Abhishek

All-new Yahoo! Mail - Fire up a more powerful email and get things done faster.

Well this is not a step by step thing …it all depends on your linux
flavour etc … once you setup apache the RT list will help in setting rt
http://www.apache.org/ + google have all the answers you need …

Good luck
Roy

abhishek bhardwaj wrote:

Hi,
I follow the document which is available on http://wiki.bestpractical.com/index.cgi?DebianStableInstallGuide
I edit the Edit /usr/local/rt3/etc/RT_SiteConfig.pm: file and make following entries
Set($rtname, ‘rt.eai.india.campuseai.org’);
Set($Organization , “eai.india.campuseai.org”);
Set($MinimumPasswordLength , “8”);
Set($Timezone , ‘Europe/Foo’);
Set($DatabaseType , ‘mysql’);
Set($DatabasePassword , ‘rt_pass’);
Set($MaxAttachmentSize , 50000000);
Set($CorrespondAddress , ‘RT_CorrespondAddressNotSet’);
Set($CommentAddress , ‘RT_CommentAddressNotSet’);
Set($WebBaseURL , ‘https://rt.eai.india.campuseai.org’);
Set($WebPath , ‘/rt’);
#Set($WebDefaultStylesheet, ‘3.4-compat’);
Set($WebDefaultStylesheet, ‘3.5-default’);
1;

where    
eai  is the host name of the server where i m configuring RT and   eai.india.campuseai.org is the fqdn of this server.


And  following entries i made in the /etc/apache-ssl/httpd.conf:  


<VirtualHost  10.2.1.136 >
ServerName  eai.india.campuseai.org
Alias  /rt "/usr/local/rt3/share/html"
PerlModule  Apache::DBI
PerlRequire  /usr/local/rt3/bin/webmux.pl
<Directory  /usr/local/rt3/share/html>
  AllowOverride All
  Options ExecCGI +FollowSymLinks
</Directory>


<Location  /rt>
   RewriteEngine On
   AddDefaultCharset UTF-8
   SetHandler perl-script
   PerlHandler RT::Mason
</Location>
</VirtualHost>




When  i restart the httpd server it is saying as follows


eai:~#  apache-sslctl restart
/usr/sbin/apache-sslctl  restart: httpsd not running, trying to start
Reading  key for server localhost:443
/usr/sbin/apache-sslctl  restart: httpsd could not be started




I  checked the logs but not get any reasion for not starting httpd   


logs  are following


eai:/var/log/apache-ssl#  tail error.log
[Wed  Sep  6 22:16:32 2006] [crit] Attempt to reinitialise SSL for  server eai.india.campuseai.org
[Wed  Sep  6 22:17:18 2006] [crit] Attempt to reinitialise SSL for  server eai.india.campuseai.org
[Wed  Sep  6 22:26:21 2006] [crit] Attempt to reinitialise SSL for  server eai.india.campuseai.org
[Wed  Sep  6 22:26:41 2006] [crit] Attempt to reinitialise SSL for  server eai.india.campuseai.org
[Wed  Sep  6 22:26:47 2006] [crit] Attempt to reinitialise SSL for  server eai.india.campuseai.org


Please  advise me in this regard.
Thanks  for your suggestion in advance

  Regards
Abhishek

Stay in the know. Pulse on the new Yahoo.com. Check it out.