Apache error messages with FastCGI

I have Apache configured to run RT using FastCGI and I keep getting
the following errors at the Apache startup. RT 2.0.11 is installed on a
Xserve OSX 10.2 with Apache 1.3.27

Can somebody help ?

Thanks in advance,

Pierre

Nov 12 11:24:00 2002] [notice] FastCGI: process manager initialized (pid
12538)
[Tue Nov 12 11:24:00 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" started (pid 12539)
[Tue Nov 12 11:24:00 2002] [notice] Apache/1.3.27 (Darwin)
mod_fastcgi/2.2.12 mod_ssl/2.8.12 OpenSSL/0.9.6g configured – res
uming normal operations
[Tue Nov 12 11:24:00 2002] [info] Server built: 11/08/02 14:04:31
[Tue Nov 12 11:24:00 2002] [notice] Accept mutex: flock (Default: flock)
YOU HAVEN’T DISABLED SET-ID SCRIPTS IN THE KERNEL YET!
FIX YOUR KERNEL, PUT A C WRAPPER AROUND THIS SCRIPT, OR USE -u AND UNDUMP!
[Tue Nov 12 11:24:00 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" (pid 12539) terminated by calling exit
wi
th status ‘255’
[Tue Nov 12 11:24:05 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" restarted (pid 12541)
YOU HAVEN’T DISABLED SET-ID SCRIPTS IN THE KERNEL YET!
FIX YOUR KERNEL, PUT A C WRAPPER AROUND THIS SCRIPT, OR USE -u AND UNDUMP!
[Tue Nov 12 11:24:05 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" (pid 12541) terminated by calling exit
wi
th status ‘255’
[Tue Nov 12 11:24:10 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" restarted (pid 12544)
YOU HAVEN’T DISABLED SET-ID SCRIPTS IN THE KERNEL YET!
FIX YOUR KERNEL, PUT A C WRAPPER AROUND THIS SCRIPT, OR USE -u AND UNDUMP!
[Tue Nov 12 11:24:10 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" (pid 12544) terminated by calling exit
wi
th status ‘255’

I have Apache configured to run RT using FastCGI and I keep getting
the following errors at the Apache startup. RT 2.0.11 is installed on a
Xserve OSX 10.2 with Apache 1.3.27

Can somebody help ?

Thanks in advance,

Pierre

Nov 12 11:24:00 2002] [notice] FastCGI: process manager initialized (pid
12538)
[Tue Nov 12 11:24:00 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" started (pid 12539)
[Tue Nov 12 11:24:00 2002] [notice] Apache/1.3.27 (Darwin)
mod_fastcgi/2.2.12 mod_ssl/2.8.12 OpenSSL/0.9.6g configured – res
uming normal operations
[Tue Nov 12 11:24:00 2002] [info] Server built: 11/08/02 14:04:31
[Tue Nov 12 11:24:00 2002] [notice] Accept mutex: flock (Default: flock)
YOU HAVEN’T DISABLED SET-ID SCRIPTS IN THE KERNEL YET!
FIX YOUR KERNEL, PUT A C WRAPPER AROUND THIS SCRIPT, OR USE -u AND UNDUMP!
[Tue Nov 12 11:24:00 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" (pid 12539) terminated by calling exit
wi
th status ‘255’
[Tue Nov 12 11:24:05 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" restarted (pid 12541)
YOU HAVEN’T DISABLED SET-ID SCRIPTS IN THE KERNEL YET!
FIX YOUR KERNEL, PUT A C WRAPPER AROUND THIS SCRIPT, OR USE -u AND UNDUMP!
[Tue Nov 12 11:24:05 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" (pid 12541) terminated by calling exit
wi
th status ‘255’
[Tue Nov 12 11:24:10 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" restarted (pid 12544)
YOU HAVEN’T DISABLED SET-ID SCRIPTS IN THE KERNEL YET!
FIX YOUR KERNEL, PUT A C WRAPPER AROUND THIS SCRIPT, OR USE -u AND UNDUMP!
[Tue Nov 12 11:24:10 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" (pid 12544) terminated by calling exit
wi
th status ‘255’

I have Apache configured to run RT using FastCGI and I keep getting
the following errors at the Apache startup. RT 2.0.11 is installed on a
Xserve OSX 10.2 with Apache 1.3.27

Can somebody help ?

YOU HAVEN’T DISABLED SET-ID SCRIPTS IN THE KERNEL YET!
FIX YOUR KERNEL, PUT A C WRAPPER AROUND THIS SCRIPT, OR USE -u AND UNDUMP!

This is a perl issue, not an RT one. Searching the net using
google.com get’s plenty of information about it.

seph

Thanks for the information, I modified the mason_handler.fcgi file and
added the “-u” option:

#!/usr/sbin/perl -u

Now I have a “terminated due to uncaught signal ‘6’ (Abort)” error
message. I couldn’t find any reference on the net for that one.

Any idea?

Thanks,

Pierre

[Tue Nov 12 11:36:40 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" (pid 12700) terminated by calling exit
with status ‘255’
[Tue Nov 12 11:36:43 2002] [info] removed PID file
/private/var/run/httpd.pid (pid=12537)
[Tue Nov 12 11:36:43 2002] [notice] caught SIGTERM, shutting down
[Tue Nov 12 15:37:35 2002] [notice] Apache/1.3.27 (Darwin)
mod_fastcgi/2.2.12 mod_ssl/2.8.12 OpenSSL/0.9.6g configured – res
uming normal operations
[Tue Nov 12 15:37:35 2002] [info] Server built: 11/08/02 14:04:31
[Tue Nov 12 15:37:35 2002] [notice] Accept mutex: flock (Default: flock)
[Tue Nov 12 15:37:35 2002] [notice] FastCGI: process manager initialized
(pid 12784)
[Tue Nov 12 15:37:35 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" started (pid 12786)
[Tue Nov 12 15:37:37 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" (pid 12786) terminated due to uncaught
signal ‘6’ (Abort)
[Tue Nov 12 15:37:40 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" restarted (pid 12787)
[Tue Nov 12 15:37:40 2002] [warn] FastCGI: server
"/opt/rt2/bin/mason_handler.fcgi" (pid 12787) terminated due to uncaught
signal ‘6’ (Abort)On 12 Nov 2002, seph wrote:

I have Apache configured to run RT using FastCGI and I keep getting
the following errors at the Apache startup. RT 2.0.11 is installed on a
Xserve OSX 10.2 with Apache 1.3.27

Can somebody help ?

YOU HAVEN’T DISABLED SET-ID SCRIPTS IN THE KERNEL YET!
FIX YOUR KERNEL, PUT A C WRAPPER AROUND THIS SCRIPT, OR USE -u AND UNDUMP!

This is a perl issue, not an RT one. Searching the net using
google.com get’s plenty of information about it.

seph