Apache directoryindex errors

Ive installed RT3 and the web interface fails on the directory links
with
/Admin/
giving a 403 error which can be fixed by typing in
/Admin/index.html
The rest of the web folders work fine, so after trying to liberally put
DirectoryIndex here and there Im stuck.
Heres the relevant part of httpd.conf that Ive added.

Alias /rt "/usr/local/rt3/share/html"
PerlRequire /usr/local/rt3/bin/webmux.pl
<Location /rt>
DirectoryIndex index.html
SetHandler perl-script
PerlHandler RT::Mason

<Directory “/usr/local/rt3/share/html”>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
DirectoryIndex index.html

I’m guessing you’re using Apache2 ? If so, add the following line to your
conf and you should be good:

RedirectMatch permanent (.*)/$ $1/index.html

This redirects directory urls to the index.html, ‘DirectoryIndex’ should do
this but doesn’t, I don’t know why…

Ive installed RT3 and the web interface fails on the directory links
with
/Admin/
giving a 403 error which can be fixed by typing in
/Admin/index.html
The rest of the web folders work fine, so after trying to liberally put
DirectoryIndex here and there Im stuck.
Heres the relevant part of httpd.conf that Ive added.


Alias /rt "/usr/local/rt3/share/html"
PerlRequire /usr/local/rt3/bin/webmux.pl
<Location /rt>
DirectoryIndex index.html
SetHandler perl-script
PerlHandler RT::Mason

<Directory “/usr/local/rt3/share/html”>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
DirectoryIndex index.html

MSN 8 helps eliminate e-mail viruses. Get 2 months FREE*.
http://join.msn.com/?page=features/virus

Is that Apache2? If that’s the case, you have to use the
and tags instead of or
as stated in the docs.

cvDate: Wed, 30 Jul 2003 11:52:57 +0100
From: Chris Hall chris@filmlight.ltd.uk
Organization: FilmLight Ltd
To: rt-users@lists.fsck.com
Subject: [rt-users] apache directoryindex errors

Ive installed RT3 and the web interface fails on the directory links
with
/Admin/
giving a 403 error which can be fixed by typing in
/Admin/index.html
The rest of the web folders work fine, so after trying to liberally put
DirectoryIndex here and there Im stuck.
Heres the relevant part of httpd.conf that Ive added.

Alias /rt "/usr/local/rt3/share/html"
PerlRequire /usr/local/rt3/bin/webmux.pl
<Location /rt>
DirectoryIndex index.html
SetHandler perl-script
PerlHandler RT::Mason

<Directory “/usr/local/rt3/share/html”>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
DirectoryIndex index.html

Thanks - that was indeed the line.
I think directoryindex must get confused because of the perl/mason parsing,
but Im just guessing.

J Schdy wrote:

I’m guessing you’re using Apache2 ? If so, add the following line to your
conf and you should be good:

RedirectMatch permanent (.*)/$ $1/index.html

This redirects directory urls to the index.html, ‘DirectoryIndex’ should do
this but doesn’t, I don’t know why…

Ive installed RT3 and the web interface fails on the directory links
with
/Admin/
giving a 403 error which can be fixed by typing in
/Admin/index.html
The rest of the web folders work fine, so after trying to liberally put
DirectoryIndex here and there Im stuck.
Heres the relevant part of httpd.conf that Ive added.


Alias /rt "/usr/local/rt3/share/html"
PerlRequire /usr/local/rt3/bin/webmux.pl
<Location /rt>
DirectoryIndex index.html
SetHandler perl-script
PerlHandler RT::Mason

<Directory “/usr/local/rt3/share/html”>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
DirectoryIndex index.html


MSN 8 helps eliminate e-mail viruses. Get 2 months FREE*.
http://join.msn.com/?page=features/virus

chris@filmlight.ltd.uk
38 Bedford Square
WC1B 3EL
+44 (0)20 7631 4905