Apache 2 Instructions?

I have a system running Apache 1.3 and RT 3.4.2. For some reason NTLM
authentication died, and I want to switch to LDAP anyways. I am unable
to get LDAP to compile into my Apache configuration.

Does anyone have directions for compiling Apache 2 w/ LDAP support from
source?

Here are my 1.3 instructions (self made):

Extract Software
tar zxvf mod_perl-1.0-current.tar.gz
tar zxvf apache_1.3.33.tar.gz
tar zxvf rt-3.4.2.tar.gz
tar zxvf stable.tar.gz

cd perl-5.8.6
./Configure

Installed to: /home/rt/local-perl

make install

Run CPAN
~/local-perl/bin/perl -MCPAN -e shell

All Defaults but:
Your choice: [] PREFIX=~/local-perl
Servers 1,4,5

Update CPAN
install Bundle::CPAN

Configure mod_perl

perl Makefile.PL PREFIX=/home/rt APACHE_PREFIX=/home/rt/apache
APACHE_SRC=…/apache_1.3.33/src/ DO_HTTPD=1 USE_APACI=1 EVERYTHING=1
make
make install

Install apache
configure --enable-module=unique_id --enable-module=rewrite
–enable-module=speling --enable-module=expires --enable-module=info
–enable-module=log_agent --enable-module=log_referer
–enable-module=usertrack --enable-module=proxy --enable-module=userdir
–enable-module=so --activate-module=src/modules/perl/libperl.a
–enable-module=perl --prefix=/home/rt/apache
make
make install

export PERL=/home/rt/local-perl/bin/perl

Configure RT:
./configure --prefix=/home/rt/rt --with-db-dba=root --with-bin-owner=rt
–with-rt-group=rt --with-libs-owner=rt --with-libs-group=rt
–with-web-user=rt --with-web-group=rt --with-db-rt-user=rt
–with-db-rt-pass=XXXXXXX

For LDAP I did this;
wget
http://www.muquit.com/muquit/software/mod_auth_ldap/mod_auth_ldap3.05.tar.gz
tar zxvf mod_auth_ldap3.05.tar.gz
cd mod_auth_ldap3.05

cd apache_1.3.33
mv …/mod_auth_ldap3.05 ./src/modules/ldap

configure --enable-module=unique_id --enable-module=rewrite
–enable-module=speling --enable-module=expires --enable-module=info
–enable-module=log_agent --enable-module=log_referer
–enable-module=usertrack --enable-module=proxy --enable-module=userdir
–enable-module=so --activate-module=src/modules/perl/libperl.a
–enable-module=perl --prefix=/home/rt/apache
–activate-module=src/modules/ldap/mod_auth_ldap.c

But it doesnt seem to work.

I would appreciate any help getting either solution working!

Thanks
Stan