Anyone successfully using rt-mailgate and Postfix v2?

I’ve banged my head on this one for a few days, and I can’t seem to get it
right. I know there is a permissions problem somewhere, but I can’t seem to
nail it down. Postfix is VERY restrictive about aliases and external
programs. I can get it to work from the command-line as the postfix user,
but the actual alias pipe is setuid, and I can’t seem to wrap my head
around the problem.

Any suggestions would be greatly appreciated.

Thanks
Tom

I’ve banged my head on this one for a few days, and I can’t seem to get it
right. I know there is a permissions problem somewhere, but I can’t seem to
nail it down. Postfix is VERY restrictive about aliases and external
programs. I can get it to work from the command-line as the postfix user,
but the actual alias pipe is setuid, and I can’t seem to wrap my head
around the problem.

With postfix 1.1 you needed to move the pipe commands to the aliases
file instead of being able to use the virtual file.

Did this mechanism change with the new postfix?

Jeroen Ruigrok van der Werven <asmodai(at)wxs.nl> / asmodai / a capoeirista
PGP fingerprint: 2D92 980E 45FE 2C28 9DB7 9D88 97E6 839B 2EAC 625B
http://www.tendra.org/ | http://www.in-nomine.org/~asmodai/diary/
But the time has come when all good things shall pass…

I’ve banged my head on this one for a few days, and I can’t seem to get
it right. I know there is a permissions problem somewhere, but I can’t
seem to nail it down. Postfix is VERY restrictive about aliases and
external programs. I can get it to work from the command-line as the
postfix user, but the actual alias pipe is setuid, and I can’t seem to
wrap my head around the problem.

With postfix 1.1 you needed to move the pipe commands to the aliases
file instead of being able to use the virtual file.

Did this mechanism change with the new postfix?

No, the pipe is still in the aliases file, it just refuses to run. I have
tried various combinations of adding the postfix user to the rt group, and
copying the file and changing the permissions, etc, but I just can’t seem
to crack this nut.

At first I was getting this message in the maillog:
Mar 4 16:10:43 xxxserver postfix/local[9823]: 766DE1B003:
to=tickets-comments@xxx.com, relay=local, delay=0, status=bounced
(Command died with status 2: " /etc/smrsh/rt-mailgate --action comment".
Command output: Can’t do setuid )

Now I’m getting this:
Mar 4 16:54:27 xxxserver postfix/local[10044]: 9A1BB1B003:
to=tickets-comments@xxx.com, relay=local, delay=1, status=bounced
(Command died with status 2: " /etc/smrsh/rt-mailgate --action comment".
Command output: Can’t locate config.pm in @INC (@INC contains:
/usr/local/rt2/etc /usr/local/rt2/lib
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
/usr/local/rt2/lib/RT/Interface/Email.pm line 107. BEGIN
failed–compilation aborted at /usr/local/rt2/lib/RT/Interface/Email.pm
line 107. Compilation failed in require at /etc/smrsh/rt-mailgate line 18.
BEGIN failed–compilation aborted at /etc/smrsh/rt-mailgate line 30. )

Any thoughts?

Thanks
Tom

At 08:52 PM 3/4/2003 -0500, you wrote:

At first I was getting this message in the maillog:
Mar 4 16:10:43 xxxserver postfix/local[9823]: 766DE1B003:
to=tickets-comments@xxx.com, relay=local, delay=0, status=bounced
(Command died with status 2: " /etc/smrsh/rt-mailgate --action comment".
Command output: Can’t do setuid )

Now I’m getting this:
Mar 4 16:54:27 xxxserver postfix/local[10044]: 9A1BB1B003:
to=tickets-comments@xxx.com, relay=local, delay=1, status=bounced
(Command died with status 2: " /etc/smrsh/rt-mailgate --action comment".
Command output: Can’t locate config.pm in @INC (@INC contains:
/usr/local/rt2/etc /usr/local/rt2/lib
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
/usr/local/rt2/lib/RT/Interface/Email.pm line 107. BEGIN
failed–compilation aborted at /usr/local/rt2/lib/RT/Interface/Email.pm
line 107. Compilation failed in require at /etc/smrsh/rt-mailgate line 18.
BEGIN failed–compilation aborted at /etc/smrsh/rt-mailgate line 30. )

Any thoughts?

Here’s what I have for an alias in my rt/postfix installation:

rt-support: |"/usr/local/rt2/bin/rt-mailgate --queue support --action
correspond"

Now, this works.

What it looks like to me is that you can’t find config.pm. What are the
perms on that? Try setting them to everyone can read to see if that helps.

Russ

That did it. World read on config.pm fixed it right up.

Many thanks!

Tom–On Tuesday, March 04, 2003 6:42 PM -0800 Russ Johnson russj@dimstar.net wrote:

At 08:52 PM 3/4/2003 -0500, you wrote:

At first I was getting this message in the maillog:
Mar 4 16:10:43 xxxserver postfix/local[9823]: 766DE1B003:
to=tickets-comments@xxx.com, relay=local, delay=0, status=bounced
(Command died with status 2: " /etc/smrsh/rt-mailgate --action comment".
Command output: Can’t do setuid )

Now I’m getting this:
Mar 4 16:54:27 xxxserver postfix/local[10044]: 9A1BB1B003:
to=tickets-comments@xxx.com, relay=local, delay=1, status=bounced
(Command died with status 2: " /etc/smrsh/rt-mailgate --action comment".
Command output: Can’t locate config.pm in @INC (@INC contains:
/usr/local/rt2/etc /usr/local/rt2/lib
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
/usr/local/rt2/lib/RT/Interface/Email.pm line 107. BEGIN
failed–compilation aborted at /usr/local/rt2/lib/RT/Interface/Email.pm
line 107. Compilation failed in require at /etc/smrsh/rt-mailgate line
18. BEGIN failed–compilation aborted at /etc/smrsh/rt-mailgate line
30. )

Any thoughts?

Here’s what I have for an alias in my rt/postfix installation:

rt-support: |"/usr/local/rt2/bin/rt-mailgate --queue support --action
correspond"

Now, this works.

What it looks like to me is that you can’t find config.pm. What are the
perms on that? Try setting them to everyone can read to see if that helps.

Russ


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Tom Lichti wrote:

That did it. World read on config.pm fixed it right up.

That’s ok, if your value of “fixed” includes “lets anyone
read your mysql passwords”. The real fix is to work out
why

(Command died with status 2: " /etc/smrsh/rt-mailgate --action comment".
Command output: Can’t locate config.pm in @INC (@INC contains:

happens. It’s usually caused by rt-mailgate running with the wrong
id. It’s supposed to be setgid rt, and you’re supposed to have a
suidperl that works. One of these is probably your problem.

�|� http://www.bestpractical.com/rt – Trouble Ticketing. Free.