Almost there... Some progress... maybe

Several people have sent me emails directly have have been quite
helpful. I appolgize if I haven’t replied personally.

The advice I’ve gotten has certainly made some progress… Though I’m
still looking at the same page as a result. Please bare with me while I
paste in cfg’s and error messages.

httpd.conf

Begin RT Host

<VirtualHost 192.168.51.48:80>
ServerName 192.168.51.48
ServerAdmin ben@NOSPAM.com
DocumentRoot /opt/rt3/share/html

PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt34/share/html>
Order allow,deny
Allow from all
SetHandler perl-script
PerlResponseHandler RT::Mason

RT_Siteconfig: (NOTE: server is currently setup only for internal use,
no DNS A or CNAME)
Set($rtname , “rt.computerhelpme.com”);
Set($Organization , “computerhelpme.com”);
Set($DatabaseType , ‘mysql’);
Set($DatabaseHost , ‘’);
Set($DatabaseRTHost , ‘’);
Set($DatabasePort , ‘’);
Set($DatabaseUser , ‘rt’);
Set($DatabasePassword , ‘nottelling’);
Set($DatabaseName , ‘rt3’);
Here’s what I had/have/have done:
From /var/log/httpd/error_log earlier today:
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access
denied for user ‘rt_user’@‘localhost’ (using password: YES) at
/usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Tue Aug 29 10:05:59 2006] [error] [client 192.168.51.72] Connect Failed
Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at
/opt/rt3/lib/RT.pm line 176\n

Reset my password for the rt user, and made sure all the RT config
settings were sane (a couple of them were originally incorrect), I’m no
longer getting those errors…

From /var/log/httpd/error_log, now:
[Tue Aug 29 13:01:54 2006] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Tue Aug 29 13:01:57 2006] [notice] Digest: generating secret for digest
authentication …
[Tue Aug 29 13:01:57 2006] [notice] Digest: done
[Tue Aug 29 13:01:57 2006] [notice] FastCGI: process manager initialized
(pid 13358)
[Tue Aug 29 13:01:57 2006] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Tue Aug 29 13:01:57 2006] [notice] Apache/2 configured – resuming
normal operations

Everything looks Ok to me here (please correct me if I’m wrong).

I went and made sure that the rt user for mysql had full access to the
rt3 database.

Not sure if there is anything else that would be helpful in
troubleshooting this… I’m thinking it’s a DBase permission issue, but
I’m no longer gettig any errors regarding that… Suggestions? Other
logfiles I should be looking at?

Thanks again,
Ben

Ben -

    If this is a cut/paste, looks like there's still a tyop [sic] in

your httpd.conf – you’re specifying /opt/rt3/ everywhere except the
container where the handlers are defined. That
container is for /opt/rt34/share/html, rather than /opt/rt3/share/html.

Or was this a cosmetic error introduced while emailing

No, that was a typo in my config I thought I’d fixed this morning, but
apparently hadn’t…

Originally, when I went with /opt/rt3 instead of rt34, it would just
bomb out with a 500 error… This time I’m getting:

error: RT couldn’t store your session.
This may mean that that the directory ‘/opt/rt3/var/session_data’ isn’t
writable or a database table is missing or corrupt.

context:

86: };
87: undef $cookies{$cookiename};
88: }
89: else {
90: die loc(“RT couldn’t store your session.”) . "\n"
91: . loc(
92: “This may mean that that the directory ‘[_1]’ isn’t writable or
a database table is missing or corrupt.”,
93: $RT::MasonSessionDir
94: )

code stack: /opt/rt3/share/html/Elements/SetupSessionCookie:90
/opt/rt3/share/html/autohandler:73

Raw Error:

RT couldn’t store your session.
This may mean that that the directory ‘/opt/rt3/var/session_data’ isn’t writable or a database table is missing or corrupt.

Trace begun at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Exceptions.pm line 129
HTML::Mason::Exceptions::rethrow_exception(‘RT couldn’t store your session.^JThis may mean that that the directory ‘/opt/rt3/var/session_data’ isn’t writable or a database table is missing or corrupt.^J^J’) called at /opt/rt3/share/html/Elements/SetupSessionCookie line 90
HTML::Mason::Commands::ANON at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0xbbb4058)’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 1256
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 1250
HTML::Mason::Request::comp(undef, undef) called at /opt/rt3/share/html/autohandler line 73
HTML::Mason::Commands::ANON at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0xbba7188)’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 1251
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 1250
HTML::Mason::Request::comp(undef, undef, undef) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 460
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 460
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 412
HTML::Mason::Request::exec(‘HTML::Mason::Request::ApacheHandler=HASH(0xbb25344)’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 168
HTML::Mason::Request::ApacheHandler::exec(‘HTML::Mason::Request::ApacheHandler=HASH(0xbb25344)’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 826
HTML::Mason::ApacheHandler::handle_request(‘HTML::Mason::ApacheHandler=HASH(0xad0c3ac)’, ‘Apache2::RequestRec=SCALAR(0xafa5d30)’) called at /opt/rt3/bin/webmux.pl line 123
eval {…} at /opt/rt3/bin/webmux.pl line 123
RT::Mason::handler(‘Apache2::RequestRec=SCALAR(0xafa5d30)’) called at /usr/lib/perl5/site_perl/5.8.8/Apache/Session/MySQL.pm line 0
eval {…} at /usr/lib/perl5/site_perl/5.8.8/Apache/Session/MySQL.pm line 0

/opt/rt3/var/session_data is RWX for owner and group, none for Other

Database issue perhaps???

I went into Webmin and looked at the SQL DBase (my MySQL skills are very
limited…), and that database apparently has no tables in it at all.

Did my DBase not initialize properly during install? I wouldn’t be
surprised, since I’ve had to adjust settings today to make everything
sane as far as users/passwords go, and I just didn’t notice it at that time.

Is there anyway to fix this after the fact, short of a fresh re-install?

I went into Webmin and looked at the SQL DBase (my MySQL skills are very
limited…), and that database apparently has no tables in it at all.

Did my DBase not initialize properly during install? I wouldn’t be
surprised, since I’ve had to adjust settings today to make everything
sane as far as users/passwords go, and I just didn’t notice it at that
time.

Is there anyway to fix this after the fact, short of a fresh re-install?

If you know where your binaries are and your config directory. You’ll
probably find the rt-setup-database in:

/opt/rt3/sbin/rt-setup-database

Off the top of my noggin:
sudo /opt/rt3/sbin/rt-setup-database --action init --datadir /opt/rt3/etc
–dba sql_admin_username --dba-password sql_admin_password

It needs to be run as a user with access to read your config files (i.e.
root/sudo)

Andrew

I went into Webmin and looked at the SQL DBase (my MySQL skills are very
limited…), and that database apparently has no tables in it at all.

Did my DBase not initialize properly during install? I wouldn’t be
surprised, since I’ve had to adjust settings today to make everything
sane as far as users/passwords go, and I just didn’t notice it at that time.

Is there anyway to fix this after the fact, short of a fresh re-install?

If you still have the install directory around, you can just do
make initialize-database

Michael
Michael S. Liebman m-liebman@northwestern.edu
http://msl521.freeshell.org/
“I have vision and the rest of the world wears bifocals.”
-Paul Newman in “Butch Cassidy & the Sundance Kid”

Thank you everyone for your help…

I now have a login screen, and the abililty to log in (colors are screwy
and the pics are broken, but I’m happy to have gotten this far).

You’ll probably hear from me again as I try to finalize and tweak
things, but you’ve proven the most helpful mailing-list group I have
found in a long time.

Thanks a bunch,
Ben

Thank you everyone for your help…

I now have a login screen, and the abililty to log in (colors are screwy
and the pics are broken, but I’m happy to have gotten this far).

See http://wiki.bestpractical.com/index.cgi?ApacheConfig for advice on this
one.
The broken pics and missing style sheet are typically because of either:

  1. because mason is trying to parse /NoAuth/images

  2. you’re missing a trailing slash somewhere in your apache config.

  3. will only affect images

  4. will affect both images and css. Also you’ll probably find you’re unable
    to submit some forms I think. I can’t quite recall though

Have a look at your apache error log and look out for lines moaning about
not being able to find htmlNoAuth instead of html/NoAuth

I’m not totally sure how it works in Apache2 because I’m using Apache
1.33and the config is different,

Andrew