Almost there but still a small problem with installation

Hi.
It seems like i got the installation running, Apache is starting and
fastCGI is loaded.

Apache is run under the user wwwrun and the group www.
Settings in the httpd.conf looks like this:
<VirtualHost 1.2.3.4>
ServerName x.domain.se

    Alias /rt "/opt/rt/share/html"
    #PerlModule Apache2 Apache::compat
    #PerlModule Apache::DBI
    #PerlRequire /opt/rt/bin/webmux.pl

    <Directory /opt/rt/share/html>
            AllowOverride All
            Options ExecCGI FollowSymLinks
            RewriteEngine On
            RedirectMatch permanent (.*)/$ $1/index.html
            AddDefaultCharset UTF-8
            Sethandler perl-script
    </Directory>

for the directory i have set the following persmissions
chwon -R wwwrun:www /opt/rt
chmod -R 755 /opt/rt

when i restart apache2 the error_log shows:
[Tue Sep 27 11:24:19 2005] [notice] caught SIGTERM, shutting down
[Tue Sep 27 11:24:19 2005] [warn] Init: Session Cache is not configured
[hint: SS
LSessionCache]
[Tue Sep 27 11:24:19 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/
suexec2)
[Tue Sep 27 11:24:20 2005] [notice] FastCGI: process manager initialized
(pid 268
36)
[Tue Sep 27 11:24:20 2005] [notice] Apache/2.0.53 (Linux/SUSE)
configured – resu
ming normal operations

when i try to access http://mysite.domain.xx/rt i get Access denid.
apache error_log says:
[Tue Sep 27 11:20:41 2005] [error] [client 1.2.3.4] client denied by
server configuration: /opt/rt/share/html/index.html

i think this is an easy case to resolve, probably some permission settings.
i run the entire setup on suse 9.3 with postgresql 8.0.3.
i would be most thatnkful for any help.

/konrad

Hi.
It seems like i got the installation running, Apache is starting and
fastCGI is loaded.

Apache is run under the user wwwrun and the group www.
Settings in the httpd.conf looks like this:
<VirtualHost 1.2.3.4>
ServerName x.domain.se

    Alias /rt "/opt/rt/share/html"
    #PerlModule Apache2 Apache::compat
    #PerlModule Apache::DBI
    #PerlRequire /opt/rt/bin/webmux.pl

    <Directory /opt/rt/share/html>
            AllowOverride All
            Options ExecCGI FollowSymLinks
            RewriteEngine On
            RedirectMatch permanent (.*)/$ $1/index.html
            AddDefaultCharset UTF-8
            Sethandler perl-script
    </Directory>

for the directory i have set the following persmissions
chwon -R wwwrun:www /opt/rt
chmod -R 755 /opt/rt

when i restart apache2 the error_log shows:
[Tue Sep 27 11:24:19 2005] [notice] caught SIGTERM, shutting down
[Tue Sep 27 11:24:19 2005] [warn] Init: Session Cache is not configured
[hint: SS
LSessionCache]
[Tue Sep 27 11:24:19 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/
suexec2)
[Tue Sep 27 11:24:20 2005] [notice] FastCGI: process manager initialized
(pid 268
36)
[Tue Sep 27 11:24:20 2005] [notice] Apache/2.0.53 (Linux/SUSE)
configured – resu
ming normal operations

when i try to access http://mysite.domain.xx/rt i get Access denid.
apache error_log says:
[Tue Sep 27 11:20:41 2005] [error] [client 1.2.3.4] client denied by
server configuration: /opt/rt/share/html/index.html

  1. Search engines are your friends
    http://marc.theaimsgroup.com/?l=rt-users&w=2&r=1&s=client+denied+by server+configuration&q=b

  2. Your config is for mod_perl still even with commeted strings, check
    wiki to find example configs for FCGI.

i think this is an easy case to resolve, probably some permission settings.
i run the entire setup on suse 9.3 with postgresql 8.0.3.
i would be most thatnkful for any help.

/konrad


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Best regards, Ruslan.