Adding Custom Fields to User Information


I’m having and issue that I’m hoping someone can help me solve. I’m trying to display some user custom fields in the user information section. On our development system running 5.0.0 I’m able to add the custom fields to the UserSummaryExtraInfo section just fine through the web interface. On our test system running 5.0.1 I get the following error, Couldn’t decode UserSummaryExtraInfo JSON. I have noticed that on the 5.0.0 system the syntax has single quotes but on our 5.0.1 system it doesn’t. I’ve tried copying the line of text from the 5.0.0 system over to the 5.0.1 system keeping the single quote and I still get the same error.

Anyone have any thoughts or ideas? Unfortunately I don’t have access to the server to just change the config file.

Thanks in advance.

Just a thought, but do both your dev & test systems have the same custom fields?

Thanks for the reply.
Yeah the custom fields are there, I can see them. I’ve even tried different case spellings to see if that is what is causing the issue.
I just tried today to see if I could remove an already in there item and it gave me the same error.

Is your config valid JSON?

Thanks for the reply.

I would assume so, I’d just following what is already there. Somewhere in our installation someone did get a custom field added. It may have been done by someone with server access. So I’m just trying to add another custom field following the same syntax.
This is what is already there, RealName, EmailAddress, Name, WorkPhone, Address1, CF.employeeType
This is what I change it to and get an error, RealName, EmailAddress, Name, WorkPhone, Address1, CF.employeeType, CF.WIUID
Both employeeType and WIUID are global custom fields for users,


I will add that those of us who are working on building our RT system believe this might be a bug that showed up between 5.0.0 and 5.0.1. I’m just trying to see if anyone else has noticed this and it is a bug or is it something I’m doing wrong.

Yeah seems like a bug to me