You sort of use ‘serial’ ‘transaction’ ‘request’ number interchangibly.
It would be nice if it was called one thing.
I like transaction number instead of serial number as is displayed
in the interface. It might make ‘merging’ a little clearer.
PS- Great package.