A couple of minor 2.0.1 issues

I’m finally playing with setting up RT myself, after lurking here for
a couple of weeks.

Anyhow, I wanted to do the install as non-root user. This fails
because rt2/etc directory is chmod’d to 555, which makes little
sense. The directory should at least be 755. If the install is owned
by root, then 755 doesn’t let anyone else write to it anyhow, but if
the install is non-root, 555 prevents the install from completing,
since the owner can’t write to the directory. The change is just to
the Makefile:

— #Makefile~ Wed Jul 18 13:55:27 2001
+++ Makefile Wed Jul 18 13:55:27 2001
@@ -206,7 +206,7 @@
chmod $(RT_READABLE_DIR_MODE) $(RT_BIN_PATH)
chmod $(RT_READABLE_DIR_MODE) $(RT_BIN_PATH)

  • chmod 0555 $(RT_ETC_PATH)
  • chmod 0755 $(RT_ETC_PATH)
    chmod 0500 $(RT_ETC_PATH)/*

    #TODO: the config file should probably be able to have its

So now I’ve got it running, and am testing out some Scrips. I notice
that sometimes the mail messages contain extra CTRL-M characters at
the end of the lines. This comes from the TEXTAREA form fields.

Browsers send these form elements with CR/NL end of line. This needs
to be normalized to just NL end of line for use inside unix. I’ve not
looked into where exactly this needs fixing, but the fix is more or
less something like this:

$data =~ s/\r\n/\n/g;

in Perl.

Also, the comment in config.pm about leaving hostname blank for
fastest connection to the database is false for Postgres. It causes
an error on connect if you do that.

Finally, a qustion: how do I make the “resolve” scrip template include
the content of the resolution response? That is, I click "resolve"
and enter a message. How does that get sent to the requestor also?
Right now I just get the stock template text. I tried adding
{$Transaction->Content()} to the template, but that came up empty. I
also tried switching the response type from comment to normal response
and that ended up sending two replies, one the normal message with the
response content, and one the resolved message.

I’m finally playing with setting up RT myself, after lurking here for
a couple of weeks.

Anyhow, I wanted to do the install as non-root user. This fails
because rt2/etc directory is chmod’d to 555, which makes little
sense. The directory should at least be 755. If the install is owned
by root, then 755 doesn’t let anyone else write to it anyhow, but if
the install is non-root, 555 prevents the install from completing,
since the owner can’t write to the directory. The change is just to
the Makefile:

Thanks, this will get into 2.0.2 or 2.0.3.

So now I’ve got it running, and am testing out some Scrips. I notice
that sometimes the mail messages contain extra CTRL-M characters at
the end of the lines. This comes from the TEXTAREA form fields.

I actually thought we were already doing this. which textareas are
not getting properly handled?

Also, the comment in config.pm about leaving hostname blank for
fastest connection to the database is false for Postgres. It causes
an error on connect if you do that.

Thanks, that’ll get noted in 2.0.2 or 2.0.3

Finally, a qustion: how do I make the “resolve” scrip template include
the content of the resolution response? That is, I click "resolve"
and enter a message. How does that get sent to the requestor also?
Right now I just get the stock template text. I tried adding
{$Transaction->Content()} to the template, but that came up empty. I
also tried switching the response type from comment to normal response
and that ended up sending two replies, one the normal message with the
response content, and one the resolved message.

That’s somewhat tricky, as the resolve and the comment are technically
seperate transactions. There’s probably a way to hack around it by grabbing
a transaction of type ‘correspond’ or ‘comment’ with the same actor
and timestamp in the template. Longer term, this is a design change
that needs to happen.


Rt-devel mailing list
Rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

And I’m told we do share some common rituals. Our “flame war” is apparently
held in person in their land and called “project meeting”.
-Alan Cox [on “Suits”]

“j” == jesse jesse@fsck.com writes:

the end of the lines. This comes from the TEXTAREA form fields.

j> I actually thought we were already doing this. which textareas are
j> not getting properly handled?

Thanks for your responses. What I did was email in a ticket. I went
in via the web interface, clicked on “Reply” at the top right corner,
entered some text, and hit “submit”. The resulting email had ^M’s in
it. This was using Konquerer as the browser from KDE 2.1.1.

I tried using the UI from Opera also, but it caches pages funny and
doesn’t let you log out properly.