4.4.2: Problem when checking One-Time CCs recipients

Hello,

Apologies in advance if this is not the proper place to report issues.

I have recently upgraded from RT 4.4.0 to 4.4.2 and noticed a change in behavior that might be considered a problem. I suspect it might be related to the newly added “All recipients” checkbox in the One Time CC/BCC checkbox areas, when Replying/Commenting on a ticket.

When checking a One Time CC address at the top of the Correspond form on an existing ticket, the “Scrips & Recipients” list of address (at the bottom of the form) is refreshed. Often (especially when text has been entered in the Body text field) all of the checkboxes in the “Scrips & Recipients” area go from checked to unchecked shortly after this refresh.

I seem to be able to reproduce this on a fresh install, but if configuration data from my install will help, I can provide that.

Thanks!

1 Like

Confirmed: after upgrading from 4.4.1 to 4.4.2 the checkboxes in the “Scrips & Recipients” sections are sometimes disabled.

I’ve already opened a bug report with BP (tk#33027 RT 4.4.2 : IMPORTANT checkboxes in “Scrips and Recipients” sometimes wind up disabled) but so far got no replies.

This is IMPORTANT: we already missed a few notifications because of this bug.

I am too able to reproduce, and I can confirm that the problem persists even after I removed all my customizations (local) and disabled all Plugins (except for PriorityAsString and Tags).

Thank you
Maurizio

I’m seeing the same thing sporadically. It seems to happen more often when using the Tab key to move to another input field, not when just clicking between input fields with the cursor. In the PreviewScrips call, I noticed that the TxnSendMailToAll and TxnSendMailTo parameters are missing when the checkboxes become incorrectly unchecked.

1 Like

Confirmed on
Firefox 38.0.5 on win7 pro
Chrome 59.0.3071.115 on win7 pro
IE 11.0.9600.18737 on win7 pro

How to reproduce.

  • Load the “update.html” page (comment or reply).
  • click on the one-time-bcc field
  • start entering the first few letters of a user you know it exists
  • the autocompletion box appears
  • press the arrow down to select the name (moving up/down on the list, if it contains more than one entry, does not make any difference)
  • press TAB to accept the entry and move the focus to the next control (which happens to be the “All recipients” checkbox below the one-time-bcc text box)

You’ll notice that the “Scrips and Recipients” area is refreshed twice, and the second time all checkboxes are cleared.

It seems that for some reason ProcessTransactionSquelching (lib/RT/Interface/Web.pm) sometimes squelches all addresses.

From 4.4.0 to 4.4.1 that function changed as a result of the merge of the “4.4/exclude-one-time-cc-in-txn-squelch” branch into 4.4-trunk, but even if I comment out that extra chunk the issue remains. And this is consistent with the fact that the issue emerged when I upgraded from 4.4.1 to 4.4.2.

I noticed that in share/html/Helpers/PreviewScrips the “All recipients” checkbox (name=“TxnSendMailToAll”) changed form 4.4.1 to 4.4.2, but even if I revert the change I can trigger unwanted squelching of all recipients.

The “TxnRecipients” hidden tag is correctly updated (the one-time-bcc is added to the list of existing addresses) but for some reason the end result is that the existing recipients are squashed.

Hi all. Sorry about this bug. We’re still working on the best fix, but I have an update. If you comment out these two lines, 248 and 249, in share/html/Ticket/Update.html,

   jQuery("#recipients input[name=TxnSendMailToAll], #recipients input[name=TxnSendMailTo]").attr('disabled', true);
   jQuery("#previewscrips input[name=TxnSendMailToAll], #previewscrips input[name=TxnSendMailTo]").attr('disabled', true);

then that should avoid the problem by restoring the 4.4.1-and-previous behavior of never disabling these checkboxes.

The goal of the original commits, listed below, was to fix a different issue with the scrips and recipients panel, where under certain circumstances, checking or unchecking a recipient would be ignored.


1 Like

Hello Shawn

Commenting out the two lines as suggested seems to work for me.

Looking forward to a more permanent fix.

Thank you
Maurizio