3.6 continual re-login issue

Hello all,

I got fed up with trying to make my previous RT install work and removed it,
and now I’m running 3.6. The problems I was having with 3.4 are gone, but
there’s a new problem.

Every time I click on anything, I have to log in again. It saves my 'state’
as I go – logging in again gives me the ‘result’ of my click. Click, log in,
see confirmation screen, click, log in, see next menu, etc. Apache logs don’t
reveal any problems, and RT isn’t logging any errors to its logfile.

I searched the archives and corresponded with Shawn Plummer of CIT SUNY
Geneseo, who reported the same (or similar) issue to the list back when 3.6
came out, and neither of us have come to any resolution.

Has anyone found a fix for this problem? I’m running gentoo, mysql, apache2,
mod_perl – a combination which worked under 3.4 right up until I broke it by
updating my perl modules. Maybe it is still a perl module versioning issue,
but I don’t know which module to blame :confused:

Thanks,
Kaylea
Kaylea Hascall (773) 834-4117 or khascall@uchicago.edu
Technology & Scholarly Computing http://nsit.uchicago.edu/academic
Assistant Director: Academic Technologies NSIT, University of Chicago

Check your apache logs are you getting any out of memory errors …if
yes its the version of DBD-mysql you are using …
I had similar problems (gentoo/mysql/apache2/mod_perl2) was fixed by
changing the version of dbd-mysql to 3.0002
Regards;
Roy

Kaylea Hascall wrote:

Hello all,

I got fed up with trying to make my previous RT install work and removed it,
and now I’m running 3.6. The problems I was having with 3.4 are gone, but
there’s a new problem.

Every time I click on anything, I have to log in again. It saves my 'state’
as I go – logging in again gives me the ‘result’ of my click. Click, log in,
see confirmation screen, click, log in, see next menu, etc. Apache logs don’t
reveal any problems, and RT isn’t logging any errors to its logfile.

I searched the archives and corresponded with Shawn Plummer of CIT SUNY
Geneseo, who reported the same (or similar) issue to the list back when 3.6
came out, and neither of us have come to any resolution.

Has anyone found a fix for this problem? I’m running gentoo, mysql, apache2,
mod_perl – a combination which worked under 3.4 right up until I broke it by
updating my perl modules. Maybe it is still a perl module versioning issue,
but I don’t know which module to blame :confused:

Me neither. I have had this problem for several months. I’m using
dev-perl/DBD-mysql-3.0004, perl 5.8.8, Mysql 5.0.19, FastCGI, apache 2.0.58.
My workaround is to use Apache auth instead:

Set($WebExternalAuth , ‘1’);
Set($WebFallbackToInternalAuth , ‘1’);
Set($WebExternalGecos , undef);
Set($WebExternalAuto , ‘1’);

It would be nice to fix the problem (it’s cookie-related) but I haven’t
been able to so far.

Chris Covington
IT
Plus One Health Management
75 Maiden Lane Suite 801
NY, NY 10038
646-312-6269
http://www.plusoneactive.com

Thank you everyone who has e-mailed me off-list about this. The problem in my
case seemed to lie between mysql, mason, and RT. Changing the character set
seems to resolve it [credit here goes to Freman – thanks!!]. I’m CC’ing the
other people I’ve seen report this recently, too.

Here’s the SQL Freman sent me, which solved my problem:

ALTER TABLE sessions CHANGE a_session a_session LONGBLOB;
ALTER TABLE ACL CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci;
ALTER TABLE Attachments CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE Attributes CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE CachedGroupMembers CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE CustomFieldValues CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE CustomFields CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE GroupMembers CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE Groups CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci;
ALTER TABLE Links CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci;
ALTER TABLE ObjectCustomFieldValues CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE ObjectCustomFields CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE Principals CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE Queues CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci;
ALTER TABLE ScripActions CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE ScripConditions CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE Scrips CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci;
ALTER TABLE Templates CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE Tickets CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci;
ALTER TABLE Transactions CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci;
ALTER TABLE Users CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci;
ALTER TABLE sessions CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci;
delete from sessions;

The suggestions I got also included updating my DBD-mysql driver (which may
have been necessary, but wasn’t sufficient to solve my problem).

-Kaylea
Kaylea Hascall (773) 834-4117 or khascall@uchicago.edu
Technology & Scholarly Computing http://nsit.uchicago.edu/academic
Assistant Director: Academic Technologies NSIT, University of Chicago

Thank you everyone who has e-mailed me off-list about this. The
problem in my
case seemed to lie between mysql, mason, and RT. Changing the
character set
seems to resolve it [credit here goes to Freman – thanks!!]. I’m
CC’ing the
other people I’ve seen report this recently, too.

Here’s the SQL Freman sent me, which solved my problem:

I believe that only this statement should be necessary if the issue
is what I now believe it to be.

ALTER TABLE sessions CHANGE a_session a_session LONGBLOB;

I’d worry a lot about these changes. Setting your characterset to
latin1 with swedish collation isn’t going to fix things properly, but
may mask a number of other issues.
We’ve got a branch of 3.6 with a “proper” fix for these issues (which
I presume only manifest on MySQL 5. Would anyone like to confirm or
deny that?)

Best,

JEsse

Thank you everyone who has e-mailed me off-list about this. The
problem in my
case seemed to lie between mysql, mason, and RT. Changing the
character set
seems to resolve it [credit here goes to Freman – thanks!!]. I’m
CC’ing the
other people I’ve seen report this recently, too.

Here’s the SQL Freman sent me, which solved my problem:

I believe that only this statement should be necessary if the issue
is what I now believe it to be.

ALTER TABLE sessions CHANGE a_session a_session LONGBLOB;

I’d worry a lot about these changes. Setting your characterset to
latin1 with swedish collation isn’t going to fix things properly, but
may mask a number of other issues.
We’ve got a branch of 3.6 with a “proper” fix for these issues (which
I presume only manifest on MySQL 5. Would anyone like to confirm or
deny that?)

No, it happens with MySQL 4.1.19 also. I was hoping that upgrading to 5
would help but it didn’t.

I wonder if is at all related or similar to the binary attachment
corruption I’ve been having for the last few months as well? I’ve tried
forcing binary character sets, etc. and that didn’t seem to help.

Chris Covington
IT
Plus One Health Management
75 Maiden Lane Suite 801
NY, NY 10038
646-312-6269
http://www.plusoneactive.com

Thank you everyone who has e-mailed me off-list about this. The
problem in my
case seemed to lie between mysql, mason, and RT. Changing the
character set
seems to resolve it [credit here goes to Freman – thanks!!]. I’m
CC’ing the
other people I’ve seen report this recently, too.

Here’s the SQL Freman sent me, which solved my problem:

I believe that only this statement should be necessary if the issue
is what I now believe it to be.

ALTER TABLE sessions CHANGE a_session a_session LONGBLOB;

ps - the SQL above doesn’t fix the problem ;<

Chris Covington
IT
Plus One Health Management
75 Maiden Lane Suite 801
NY, NY 10038
646-312-6269
http://www.plusoneactive.com

Jesse;
my dev system rt-3.6 ,perl, v5.8.8 , apache 2.0.58, dbix 1.43, mysql
5.0.19 on gentoo system , I had this/similar problem with DBD-mysql
3.0003, fixed with moving to DBD-mysql 3.0002 … no sign of this problem
since…
Roy

Jesse Vincent wrote:

Same problem here with 3.6 with mysql 4.1.X (and binary corruption also!)

Ted Serreyn Phone: 262-432-0260 Fax: 262-432-0232
Serreyn Network Services, LLC http://www.serreyn.com/

I set up an instance of rt 3.4.5 and upgraded it to 3.6 using mysql for
the database and it worked just fine… When I tried upgrading another
test rt system from 3.4.5 using oracle database to 3.6, it had the
continual login issue… I haven’t talked to the DBA about this change
to see if it clears things up…

BTW, the mysql rt is running on Fedora Core 5, kernel 2.6.16-1.2115_FC4,
the oracle rt is running on Solaris 8…From: Jesse Vincent [mailto:jesse@bestpractical.com]
Sent: July 12, 2006 10:22 AM
To: Kaylea Hascall
Cc: rt-users@lists.bestpractical.com; Don Beethe; egunnett@qualcomm.com
Subject: Re: [rt-users] 3.6 continual re-login issue [A Fix!]

Thank you everyone who has e-mailed me off-list about this. The
problem in my case seemed to lie between mysql, mason, and RT.
Changing the character set seems to resolve it [credit here goes to
Freman – thanks!!]. I’m CC’ing the other people I’ve seen report this

recently, too.

Here’s the SQL Freman sent me, which solved my problem:

I believe that only this statement should be necessary if the issue is
what I now believe it to be.

ALTER TABLE sessions CHANGE a_session a_session LONGBLOB;

I’d worry a lot about these changes. Setting your characterset to
latin1 with swedish collation isn’t going to fix things properly, but
may mask a number of other issues.
We’ve got a branch of 3.6 with a “proper” fix for these issues (which I
presume only manifest on MySQL 5. Would anyone like to confirm or deny
that?)

Best,

JEsse

ALTER TABLE ACL CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci; ALTER TABLE Attachments CONVERT TO CHARACTER SET
latin1 COLLATE latin1_swedish_ci; ALTER TABLE Attributes CONVERT TO
CHARACTER SET latin1 COLLATE latin1_swedish_ci; ALTER TABLE
CachedGroupMembers CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci; ALTER TABLE CustomFieldValues CONVERT TO CHARACTER
SET latin1 COLLATE latin1_swedish_ci; ALTER TABLE CustomFields CONVERT

TO CHARACTER SET latin1 COLLATE latin1_swedish_ci; ALTER TABLE
GroupMembers CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci; ALTER TABLE Groups CONVERT TO CHARACTER SET latin1
COLLATE latin1_swedish_ci; ALTER TABLE Links CONVERT TO CHARACTER SET
latin1 COLLATE latin1_swedish_ci; ALTER TABLE ObjectCustomFieldValues
CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci; ALTER TABLE

ObjectCustomFields CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci; ALTER TABLE Principals CONVERT TO CHARACTER SET
latin1 COLLATE latin1_swedish_ci; ALTER TABLE Queues CONVERT TO
CHARACTER SET latin1 COLLATE latin1_swedish_ci; ALTER TABLE
ScripActions CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci; ALTER TABLE ScripConditions CONVERT TO CHARACTER
SET latin1 COLLATE latin1_swedish_ci; ALTER TABLE Scrips CONVERT TO
CHARACTER SET latin1 COLLATE latin1_swedish_ci; ALTER TABLE Templates
CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci; ALTER TABLE

Tickets CONVERT TO CHARACTER SET latin1 COLLATE latin1_swedish_ci;
ALTER TABLE Transactions CONVERT TO CHARACTER SET latin1 COLLATE
latin1_swedish_ci; ALTER TABLE Users CONVERT TO CHARACTER SET latin1
COLLATE latin1_swedish_ci; ALTER TABLE sessions CONVERT TO CHARACTER
SET latin1 COLLATE latin1_swedish_ci; delete from sessions;

The suggestions I got also included updating my DBD-mysql driver
(which may have been necessary, but wasn’t sufficient to solve my
problem).

-Kaylea

Kaylea Hascall (773) 834-4117 or
khascall@uchicago.edu
Technology & Scholarly Computing http://nsit.uchicago.edu/
academic
Assistant Director: Academic Technologies NSIT, University of
Chicago


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com Commercial support:
sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://
bestpractical.com/about/jobs.html

At Wednesday 7/12/2006 12:21 PM, Jesse Vincent wrote:

We’ve got a branch of 3.6 with a “proper” fix for these issues (which
I presume only manifest on MySQL 5. Would anyone like to confirm or
deny that?)

We have this problem with an Oracle 9 database. (RT 3.4.2, mod_perl,
Apache 1.3.26, SSL).

Steve

Jesse;
my dev system rt-3.6 ,perl, v5.8.8 , apache 2.0.58, dbix 1.43,
mysql 5.0.19 on gentoo system , I had this/similar problem with DBD-
mysql 3.0003, fixed with moving to DBD-mysql 3.0002 … no sign of
this problem since…
Roy

Can you tell me if this still happens with 3.0006?

At Wednesday 7/12/2006 12:21 PM, Jesse Vincent wrote:

We’ve got a branch of 3.6 with a “proper” fix for these issues (which
I presume only manifest on MySQL 5. Would anyone like to confirm or
deny that?)

We have this problem with an Oracle 9 database. (RT 3.4.2,
mod_perl, Apache 1.3.26, SSL).

Steve

We have this problem with oracle10gR2 (CentOS 4.3 running, Apache
2.0.52, fastcgi)

Shawn Plummer
Systems Manager
CIT SUNY Geneseo
"The mind can make substance, and people planets of its own with
beings brighter than have been, and give a breath to forms which can
outlive all flesh." -Lord Byron

I have been running 3.6 in a test mode trying to figure out what is
causing this. I suspected it may have been due to customizations we have
done to link in our corporate LDAP, but after taking the share/html
files and modifying them with our custom lines, it still fails.
Have stumbled on the condition where on the “RT at a glance” page, if I
click the edit option to change what is displayed, and just click the
save for summary rows, and return to the home page, I don’t get stuck in
the login loop.

Don’t know if this helps track down where this is coming from, but…

We have the same problem with rt (both 3.6 & 3.4.X) on Gentoo. Perl 5.8.8, mysql (both 4.1 & 5.0), latest dbd-mysql, fastcgi, apache 2.0.59. None of these suggested fixes have resolved the problem, and we have been experiencing the problem for about 2 months.

Chris Covington
IT
Plus One Health Management
75 Maiden Lane Suite 801
NY, NY 10038
646-312-6269
http://www.plusoneactive.com

Sorry for the delay (upgrading packages on gentoo is not straight
forward)… but I tried 3.0004 and 3.0006 and the problem did n’t
reappear …
Just a thought for many that have this issue …do they have ssl
enabled?? My colleague suggested its a certain combination of mod_ssl
and dbd-mysql that maybe causing this issue…
Roy

Jesse Vincent wrote:

No I don’t have ssl enabled. Also not using dbd-mysql, since our
database is oracle.
Haven’t seen this problem on 3.4.5, only 3.6.0From: Roy El-Hames [mailto:rfh@pipex.net]
Sent: July 19, 2006 3:17 AM
To: Jesse Vincent
Cc: Kaylea Hascall; Don Beethe; rt-users@lists.bestpractical.com;
egunnett@qualcomm.com
Subject: Re: [rt-users] 3.6 continual re-login issue [A Fix!]

Sorry for the delay (upgrading packages on gentoo is not straight
forward)… but I tried 3.0004 and 3.0006 and the problem did n’t
reappear …
Just a thought for many that have this issue …do they have ssl
enabled?? My colleague suggested its a certain combination of mod_ssl
and dbd-mysql that maybe causing this issue…
Roy

Jesse Vincent wrote:

Jesse;
my dev system rt-3.6 ,perl, v5.8.8 , apache 2.0.58, dbix 1.43, mysql
5.0.19 on gentoo system , I had this/similar problem with DBD-mysql
3.0003, fixed with moving to DBD-mysql 3.0002 … no sign of this
problem since…
Roy

Can you tell me if this still happens with 3.0006?

At Wednesday 7/19/2006 05:17 AM, Roy El-Hames wrote:

Just a thought for many that have this issue …do they have ssl
enabled?? My colleague suggested its a certain combination of
mod_ssl and dbd-mysql that maybe causing this issue…
Roy

We are using SSL - haven’t tested it with a non-SSL setup. (We are
also using Solaris, Oracle 9i, fastcgi, RT 3.4.2, Apache 1.3.26).

One work-around that seems to work - if I specify the username and
password as part of the URL, the problem seems to go away. I’d be
interested to hear if others have the same result.

https://our.rt/?user=myusername&pass=mypassword

I had thought I could modify the login dialog to use an HTTP GET
rather than a POST to emulate this - however this doesn’t seem to
work. I’m trying to figure out the difference between the request
the URL, but unfortunately I can’t peek at the network packets,
because they’re encrypted. Does anyone know of a Firefox add-on or
feature that allows display of SSL HTTP requests as they’re sent out?

Other information about my experience of this problem:

Does not occur at all with Opera. It happens with MSIE, Firefox
(WIndows) and Safari (Mac).

Does not occur at all on our ‘development’ box. This is a Linux,
Oracle 9i, mod_perl, RT 3.4.2, Apache 1.3.33 setup.

Thanks,
Steve

Hello all,

I got fed up with trying to make my previous RT install work and removed it,
and now I’m running 3.6. The problems I was having with 3.4 are gone, but
there’s a new problem.

Every time I click on anything, I have to log in again. It saves my 'state’
as I go – logging in again gives me the ‘result’ of my click. Click, log in,
see confirmation screen, click, log in, see next menu, etc. Apache logs don’t
reveal any problems, and RT isn’t logging any errors to its logfile.

I searched the archives and corresponded with Shawn Plummer of CIT SUNY
Geneseo, who reported the same (or similar) issue to the list back when 3.6
came out, and neither of us have come to any resolution.

Has anyone found a fix for this problem? I’m running gentoo, mysql, apache2,
mod_perl – a combination which worked under 3.4 right up until I broke it by
updating my perl modules. Maybe it is still a perl module versioning issue,
but I don’t know which module to blame :confused:

Me neither. I have had this problem for several months. I’m using
dev-perl/DBD-mysql-3.0004, perl 5.8.8, Mysql 5.0.19, FastCGI, apache 2.0.58.
My workaround is to use Apache auth instead:

Set($WebExternalAuth , ‘1’);
Set($WebFallbackToInternalAuth , ‘1’);
Set($WebExternalGecos , undef);
Set($WebExternalAuto , ‘1’);

It would be nice to fix the problem (it’s cookie-related) but I haven’t
been able to so far.

I had the exact same problem and it turned out to be PEBKAC. :slight_smile:
I was (of course) using Firefox to access the machine, and under the
"cookies" tab of Firefox’s preferences I had the “unless I have removed
cookies set by the site” flag checked.

At some point I was testing logins for different pieces of RT, and I
removed RT’s cookies. (In fact, at the moment I can’t recall whether I
specifically removed RT’s cookies, or if I just clicked the “clear all
cookies” button.) In any case, after that I had exactly the problem
Kaylea describes above, because Firefox saw that I had removed cookies
set by my RT site, and was thus dutifully discarding RT’s authentication
cookie – so my login credentials only lasted for one click.

/Ole Craig
Security Engineer

303-381-3802 (main support hotline)
303-381-3824 (my direct line)
303-381-3801 (fax)

www.stillsecure.com
. . .

Sorry for the delay (upgrading packages on gentoo is not straight
forward)… but I tried 3.0004 and 3.0006 and the problem did n’t
reappear …
Just a thought for many that have this issue …do they have ssl
enabled?? My colleague suggested its a certain combination of
mod_ssl and dbd-mysql that maybe causing this issue…

I suspect that the reason you’re not seeing it (see my message of
last night) is that DBD::mysql now allows server-side prepared
statements. optionally using or not using likely causes things to fail.

-j

PGP.sig (186 Bytes)