1st Install, Web Interface broke, can't begin to a dmin

Michael,

Did you modify the default setting of the $WebPath variable in RT’s
config.pm?

<–from /opt/rt2/etc/config.pm–>

If you’re putting the web ui somewhere other than at the root of

your server

$WebPath requires a leading / but no trailing /

$WebPath = “”;
<–end–>

Did you try to access the system with http://hostname only?

GeorgeFrom: Michael F Kukla [mailto:kukla@acsu.buffalo.edu]
Sent: Friday, February 15, 2002 11:50 AM
To: rt-users@lists.fsck.com
Cc: Martin Camacho
Subject: [rt-users] 1st Install, Web Interface broke, can’t begin to
admin

We are new to rt. We've just installed rt2.0.11 on a machine running

red
hat linux 7.2 and its pre-installed perl 5.6.0.

As I will detail below, everything seems to be installed and

configured
properly: mod-perl compiled statically with apache (as revealed by typing
httpd -l) and so on.

    However, when we try to get the web interface, typing either

    http://hostname/rt2

or
http://127.0.0.1/rt2

we get an abortive sort of web page which includes only the top RT banner
telling us we are “Not Logged in” along with a second banner with this
error message

    "You are not an authorized user"
    
    Below this is the centered table block with gray background where

one normally logs into RT, (or so I guess). However instead of getting
two text input fields and a submit button, the table block is devoid of
any html form elements and includes only RT’s copyright notice.

    We cannot get over this hurdle, and of course cannot configure

users, queues or anything else till we do.

Our Apache version is 1.3.23 and we have installed the latest

versions of
mod perl and mysql.

Mason and Apache::DBI were installed by hand, all the other

prerequisite
perl modules using make fixdeps.

We can log into the rt database without any problem via the

command line.

I.e.,

> mysql -u rt_user -p rt2

works just fine.

Please note that we are cognizant of the need to use apachetcl to

stop and start apache after making any attempts to fix this. But the problem
doesn’t seem to be with Apache. Apache’s error log doesn’t show any
complaints at all. All the same, the relevant parts of httpd.conf follow
below

Alias /rt2 "/opt/rt2/WebRT/html"
PerlRequire /opt/rt2/bin/webmux.pl
PerlModule Apache::DBI
PerlFreshRestart On
<Location /rt2>
SetHandler perl-script
PerlHandler RT::Mason

<Directory “/opt/rt2/WebRT/html”>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
Allow from all

Per the RT manual I have also tried the setup above without including

PerlModule Apache::DBI
PerlFreshRestart On

But this makes no difference

Any help with this problem would be greatly appreciated

Mike Kukla,
Erstwhile Web Developer
The College of Arts and Sciences, University at Buffalo
kukla@buffalo.edu

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

This email message may contain information that is confidential and
proprietary to Babcock & Brown or a third party. If you are not the
intended recipient, please contact the sender and destroy the original and
any copies of the original message. Babcock & Brown takes measures to
protect the content of its communications. However, Babcock & Brown cannot
guarantee that email messages will not be intercepted by third parties or
that email messages will be free of errors or viruses.