1.3.19 installation problems (LONG)


#1

Hello.

I am having some problems installing/running rt-1.3.19. I first
"uninstalled" 1.3.18 by deleting the install-directory and droping the db / deleting
the entries for rt_user in mysql. My System is Linux 2.2.17 (RH6.2), Apache
1.3.12, MySQL 3.22.32.

1st Problem:

‘make install’ gives me error-messages when it comes to creating the
database:

/usr/bin/perl tools/initdb ‘mysql’ ‘/usr/local’ ‘localhost’ ‘root’ ‘RT2’
'rt_user’
Use of uninitialized value at
/usr/lib/perl5/site_perl/5.005/DBIx/DBSchema/Column.pm line 66.

[ error message repeats about 12 times…]

Enter the mysql password for root:

Database creation parameters:

DB_TYPE = mysql
DB_HOME = /usr/local
DB_HOST = localhost
DB_DBA = root
DB_DBA_PASSWORD =
DB_DATABASE = RT2

About to drop mysql database RT2.

WARNING: This will erase all data in RT2.
If you have an existing RT 2.x installation, this will destory all your
data.
Proceed [y/N]:y

Dropping mysql database RT2.

Creating mysql database RT2.

Creating database schema.
Use of uninitialized value at
/usr/lib/perl5/site_perl/5.005/DBIx/DBSchema/Column.pm line 182, chunk 2.

[error-message repeats many many times…]

DBD::mysql::st execute failed: You have an error in your SQL syntax near
’AUTO_INCREMENT Name(NULL) NULL 16,
(varchar) NULL NULL,
64 NOT NULL ,
PR’ at line 3 at tools/initdb line 65, chunk 2.
You have an error in your SQL syntax near ‘AUTO_INCREMENT Name(NULL) NULL
16,
(varchar) NULL NULL,
64 NOT NULL ,
PR’ at line 3 at tools/initdb line 65, chunk 2.
Issuing rollback() for database handle being DESTROY’d without explicit
disconnect(), chunk 2.
make: *** [database] Error 255

I tried to get rid of this problem by running schema.mysql and acl.mysl
manually. The RT2 database and user-data/permissions seem fine after that.

Have I overlooked something or might this be a bug in the install-scripts?

2nd Problem:

Since updating to 1.3.19, I can’t get WebRT to work anymore.

In my httpd.conf I have the following lines to enable WebRT:

Alias /rt “/opt/rt2/WebRT/html”

<Location /rt>
PerlRequire /opt/rt2/bin/webmux.pl # this is line 876, see below…
SetHandler perl-script
PerlHandler RT::Mason

and in etc/config.pm. …

$WebPath = “/rt/”;

(Note: I had 1.3.18 running with these settings)

Now when I start apache, it dies with the following error-message:

[Fri Oct 13 08:51:25 2000] [error] BEGIN not safe after
errors–compilation aborted at /opt/rt2/bin/webmux.pl line 46.

Syntax error on line 876 of /etc/httpd/conf/httpd.conf:
BEGIN not safe after errors–compilation aborted at /opt/rt2/bin/webmux.pl
line 46.

Line 46 of webmux.pl is “use RT::Interface::Web;”.

Any advice here ?

Thanks,
Christian Henz.

Sent through GMX FreeMail - http://www.gmx.net


#2

Schema.mysql shouldn’t be there any more. it’s out of date and will
get whacked later today. What version of DBIx::DBSchema are you running,
Christian? Another possibility is that RT2 has never been tested on
any MySQL version older than 3.23.5.

Your second problem points to a broken installation and I suspect it
will clear up when we make the first problem go away.

    JesseOn Fri, Oct 13, 2000 at 04:25:22PM +0200, ChrHenz@gmx.de wrote:

Hello.

I am having some problems installing/running rt-1.3.19. I first
"uninstalled" 1.3.18 by deleting the install-directory and droping the db / deleting
the entries for rt_user in mysql. My System is Linux 2.2.17 (RH6.2), Apache
1.3.12, MySQL 3.22.32.

1st Problem:

‘make install’ gives me error-messages when it comes to creating the
database:

/usr/bin/perl tools/initdb ‘mysql’ ‘/usr/local’ ‘localhost’ ‘root’ ‘RT2’
'rt_user’
Use of uninitialized value at
/usr/lib/perl5/site_perl/5.005/DBIx/DBSchema/Column.pm line 66.

[ error message repeats about 12 times…]

Enter the mysql password for root:

Database creation parameters:

DB_TYPE = mysql
DB_HOME = /usr/local
DB_HOST = localhost
DB_DBA = root
DB_DBA_PASSWORD =
DB_DATABASE = RT2

About to drop mysql database RT2.

WARNING: This will erase all data in RT2.
If you have an existing RT 2.x installation, this will destory all your
data.
Proceed [y/N]:y

Dropping mysql database RT2.

Creating mysql database RT2.

Creating database schema.
Use of uninitialized value at
/usr/lib/perl5/site_perl/5.005/DBIx/DBSchema/Column.pm line 182, chunk 2.

[error-message repeats many many times…]

DBD::mysql::st execute failed: You have an error in your SQL syntax near
’AUTO_INCREMENT Name(NULL) NULL 16,
(varchar) NULL NULL,
64 NOT NULL ,
PR’ at line 3 at tools/initdb line 65, chunk 2.
You have an error in your SQL syntax near ‘AUTO_INCREMENT Name(NULL) NULL
16,
(varchar) NULL NULL,
64 NOT NULL ,
PR’ at line 3 at tools/initdb line 65, chunk 2.
Issuing rollback() for database handle being DESTROY’d without explicit
disconnect(), chunk 2.
make: *** [database] Error 255

I tried to get rid of this problem by running schema.mysql and acl.mysl
manually. The RT2 database and user-data/permissions seem fine after that.

Have I overlooked something or might this be a bug in the install-scripts?

2nd Problem:

Since updating to 1.3.19, I can’t get WebRT to work anymore.

In my httpd.conf I have the following lines to enable WebRT:

Alias /rt “/opt/rt2/WebRT/html”

<Location /rt>
PerlRequire /opt/rt2/bin/webmux.pl # this is line 876, see below…
SetHandler perl-script
PerlHandler RT::Mason

and in etc/config.pm. …

$WebPath = “/rt/”;

(Note: I had 1.3.18 running with these settings)

Now when I start apache, it dies with the following error-message:

[Fri Oct 13 08:51:25 2000] [error] BEGIN not safe after
errors–compilation aborted at /opt/rt2/bin/webmux.pl line 46.

Syntax error on line 876 of /etc/httpd/conf/httpd.conf:
BEGIN not safe after errors–compilation aborted at /opt/rt2/bin/webmux.pl
line 46.

Line 46 of webmux.pl is “use RT::Interface::Web;”.

Any advice here ?

Thanks,
Christian Henz.


Sent through GMX FreeMail - http://www.gmx.net


Rt-devel mailing list
Rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

jesse reed vincent — root@eruditorum.orgjesse@fsck.com
pgp keyprint: 50 41 9C 03 D0 BC BC C8 2C B9 77 26 6F E1 EB 91
’“As the company that brought users the Internet, Netscape is now inviting
the more than 60 million people who have used our client software to
’tune up’ and upgrade to Netscape Communicator,” said Mike Homer,
senior vice president of marketing at Netscape.’ Sometimes I wonder.