Session timeout and a default change

Hi all,

First question: is it possibile to configure a timeout webRT session? I
would like the Web RT page automatically logout after 10-15 minutes of
no web rt use.

Second question: when I click to Resolve a ticket I would like the rt
web page shows ‘Response to Requestors’ in the Update Type field as
default and not ‘Comment (Not sent to Requestors)’, which is the actual
default. I search into /rt3/share/html/Ticket/Update.html and
ModifyAll.html, /rt3/share/html/Search/Bulk.html but the changes made
don’t work fine.

I have rt 3.0.6 installed.

Thank you !!

Francesca Del Corso

Istituto Nazionale di Fisica Nucleare - Sez. Firenze
c/o Polo Scientifico e Tecnologico
via G. Sansone, 1 50019 Sesto Fiorentino (FI) Italy
phone: +39-055-4572112 fax: +39-055-229330
e-mail:delcorso@fi.infn.it

Francesca Del Corso wrote:

Hi all,

First question: is it possibile to configure a timeout webRT session? I
would like the Web RT page automatically logout after 10-15 minutes of
no web rt use.
I think you can do it.
You should modify SetupSessionCookie file.
Now there is ‘session cookie’ used, but you can add expration period(eg
Expires => ‘+10m’). But also you have to change this file in next way:
it must must update user’s cookie on every request even if user allready
has setuped cookie in other case user would be logged out after 15min
even if he was doing any request to RT during this period of time.

I hope this can help you. Ruslan.

Second question: when I click to Resolve a ticket I would like the rt
web page shows ‘Response to Requestors’ in the Update Type field as
default and not ‘Comment (Not sent to Requestors)’, which is the actual
default. I search into /rt3/share/html/Ticket/Update.html and
ModifyAll.html, /rt3/share/html/Search/Bulk.html but the changes made
don’t work fine.

You have to change rt3/share/html/Ticket/Elements/Tabs:136
Action=Comment to Action=Correspond
Or add your custom Tab, something like 'Resolve with Reply’
Good luck. Ruslan.

About setting the session timeout: In newer versions (i.e. RT 4.4.4) see my post in this forum thread: User session timeout