You don't have permission to access /rt on this server

Thank a lot. It works. I am really a newbie in this
field. I hope that I can learn very quickly.

I installed everything with root user and I got
error
message like below when I launched a browser. What
type of user did you use to install RT to have the
right access privilege?

Forbidden

You don’t have permission to access /rt on this
server.

cpan> install mod_perl2
mod_perl2 is up to date (2.000002).

It doesn’t work. mod_perl2 is up to date.
However,
I

still get the error information:

[root@osg-tg2 bin]# ./httpd -k start
Syntax error on line 426 of
/usr/local/apache2_rt/conf/httpd.conf:
Invalid command ‘PerlModule’, perhaps misspelled
or
defined by a module not included in the server
configuration

do you have this in the LoadModule section?

LoadModule perl_module modules/mod_perl.so

Did I miss anyother configuration process?

Done by skipping test. Thanks a lot and I hope
it

works.

— "Scott T. Hildreth"
shildreth@allantgroup.com

wrote:

scotth# cpan

cpan shell – CPAN exploration and modules
installation (v1.83)
ReadLine support enabled

cpan> i /mod_perl2/
CPAN: Storable loaded ok
Going to read
/usr/local/perl-5.8.8/cpan/Metadata

Database was generated on Fri, 17 Feb 2006
23:16:39 GMT
CPAN: LWP::UserAgent loaded ok
Fetching with LWP:

ftp://cpan.pair.com/pub/CPAN/authors/01mailrc.txt.gz

LWP failed with code[404] message[Can’t
chdir
to

pub]
Fetching with Net::FTP:

ftp://cpan.pair.com/pub/CPAN/authors/01mailrc.txt.gz

Going to read

/usr/local/perl-5.8.8/cpan/sources/authors/01mailrc.txt.gz

CPAN: Compress::Zlib loaded ok
Fetching with LWP:

ftp://cpan.pair.com/pub/CPAN/modules/02packages.details.txt.gz

LWP failed with code[404] message[Can’t
chdir
to

pub]
Fetching with Net::FTP:

ftp://cpan.pair.com/pub/CPAN/modules/02packages.details.txt.gz

Going to read

/usr/local/perl-5.8.8/cpan/sources/modules/02packages.details.txt.gz

Database was generated on Tue, 21 Feb 2006
23:17:00 GMT

There’s a new CPAN.pm version (v1.86)
available!

[Current version is v1.83]
You might want to try
install Bundle::CPAN
reload cpan
without quitting the current session. It
should

be

a seamless upgrade
while we are running…

Fetching with LWP:

ftp://cpan.pair.com/pub/CPAN/modules/03modlist.data.gz

LWP failed with code[404] message[Can’t
chdir
to

pub]
Fetching with Net::FTP:

ftp://cpan.pair.com/pub/CPAN/modules/03modlist.data.gz

Going to read

/usr/local/perl-5.8.8/cpan/sources/modules/03modlist.data.gz

Going to write
/usr/local/perl-5.8.8/cpan/Metadata

Module id = mod_perl2
CPAN_USERID PGOLLUCCI (Philip M.
Gollucci

pgollucci@p6m7g8.com)
CPAN_VERSION 2.000002
CPAN_FILE
P/PG/PGOLLUCCI/mod_perl-2.0.2.tar.gz
MANPAGE mod_perl - Embed a Perl
interpreter
in the Apache/2.x HTTP server
INST_FILE

/usr/local/perl-5.8.8/lib/site_perl/5.8.8/i386-freebsd/mod_perl2.pm

INST_VERSION 2.000002

cpan>

…then type in install mod_perl2, it will
prompt

you

for the location of apxs.
Mine is in /usr/local/apache2/bin, so I give
it

the

full path,

‘/usr/local/apache2/bin/apxs’

You might want to do a ‘which apxs’ before
you

start, so you know where it is.
I don’t use rpms or ports(I am running on
FreeBSD)

for Perl or Apache, I like
to compile myself. That way everything is
in

/usr/local/.

=== message truncated ===

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

zhou jian wrote:

Thank a lot. It works. I am really a newbie in this
field. I hope that I can learn very quickly.

I installed everything with root user and I got
error
message like below when I launched a browser. What
type of user did you use to install RT to have the
right access privilege?

Forbidden

You don’t have permission to access /rt on this
server.

grep user httpd.conf

who is the owner of /usr/local/rt now

I installed all the stuffs with root user. Actually I
installed RT in /opt/rt3 directory!— Chaim Rieger chaim.rieger@gmail.com wrote:

zhou jian wrote:

Thank a lot. It works. I am really a newbie in
this
field. I hope that I can learn very quickly.

I installed everything with root user and I got
error
message like below when I launched a browser.
What
type of user did you use to install RT to have
the
right access privilege?

Forbidden

You don’t have permission to access /rt on this
server.

grep user httpd.conf

who is the owner of /usr/local/rt now

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Hello,

Finally I got RT installed. However, I couldn’t access
the /rt because of the permission problem. The
httpd.conf was configured as below. I followed the
instruction from RT Essential. And everything was
installed under root. What’s wrong with this?

–Paul

<VirtualHost 128.255.163.105>
Alias /rt “/opt/rt3/share/html”
#Alias /rt “/usr/local/rt”

ServerName 128.255.163.105
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location /opt/rt3/share/html>
SetHandler perl-script
PerlHandler RT::Mason

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

I checked the log file of my httpd server.

[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:45 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:53:54 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 15:00:25 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html

However, I strictly followed the instruction of RT
Eessential. Any ideas?— zhou jian sunzhoujian@yahoo.com wrote:

Hello,

Finally I got RT installed. However, I couldn’t
access
the /rt because of the permission problem. The
httpd.conf was configured as below. I followed the
instruction from RT Essential. And everything was
installed under root. What’s wrong with this?

–Paul

<VirtualHost 128.255.163.105>
Alias /rt “/opt/rt3/share/html”
#Alias /rt “/usr/local/rt”

ServerName 128.255.163.105
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location /opt/rt3/share/html>
SetHandler perl-script
PerlHandler RT::Mason


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

zhou jian wrote:

<Location /opt/rt3/share/html>

Use
<Directory /opt/rt3/share/html>
or
<Location /rt>

Because Location directive always use when restricting objects in
webspace. And Directory directive use to restrict object in filessytem

Nadeem

What type of user privilege should I use to install RT
in my local machine. I used root. Is this the reason
that I couldn’t visit the content? If so, I can
reinstall the RT. Thanks in advance for your hints.— zhou jian sunzhoujian@yahoo.com wrote:

I checked the log file of my httpd server.

[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:45 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:53:54 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 15:00:25 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html

However, I strictly followed the instruction of RT
Eessential. Any ideas?

— zhou jian sunzhoujian@yahoo.com wrote:

Hello,

Finally I got RT installed. However, I couldn’t
access
the /rt because of the permission problem. The
httpd.conf was configured as below. I followed the
instruction from RT Essential. And everything was
installed under root. What’s wrong with this?

–Paul

<VirtualHost 128.255.163.105>
Alias /rt “/opt/rt3/share/html”
#Alias /rt “/usr/local/rt”

ServerName 128.255.163.105
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location /opt/rt3/share/html>
SetHandler perl-script
PerlHandler RT::Mason


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>

RewriteEngine On

RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

I used as you suggested. However, it still doesn’t
work. Is that because I installed RT with root user?

— Nadeem Shahbaz nadeem.shahbaz@prog.awpdc.com
wrote:

zhou jian wrote:

<Location /opt/rt3/share/html>

Use
<Directory /opt/rt3/share/html>
or
<Location /rt>

Because Location directive always use when
restricting objects in
webspace. And Directory directive use to restrict
object in filessytem

Nadeem

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

I looked at the RT Essential book again. The example
they were using is http://localhost:4711/

Do i have to specify the port for RT or just use the
standard 80 port?— zhou jian sunzhoujian@yahoo.com wrote:

What type of user privilege should I use to install
RT
in my local machine. I used root. Is this the reason
that I couldn’t visit the content? If so, I can
reinstall the RT. Thanks in advance for your hints.

— zhou jian sunzhoujian@yahoo.com wrote:

I checked the log file of my httpd server.

[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:45 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:53:54 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 15:00:25 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html

However, I strictly followed the instruction of RT
Eessential. Any ideas?

— zhou jian sunzhoujian@yahoo.com wrote:

Hello,

Finally I got RT installed. However, I couldn’t
access
the /rt because of the permission problem. The
httpd.conf was configured as below. I followed
the

instruction from RT Essential. And everything
was

installed under root. What’s wrong with this?

–Paul

<VirtualHost 128.255.163.105>
Alias /rt “/opt/rt3/share/html”
#Alias /rt “/usr/local/rt”

ServerName 128.255.163.105
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location /opt/rt3/share/html>
SetHandler perl-script
PerlHandler RT::Mason


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Could you guys give me an example of workable
configuration in httpd.conf for the VirtualHost part?

I used the example from the website. It doesn’t work
out.— zhou jian sunzhoujian@yahoo.com wrote:

I checked the log file of my httpd server.

[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:45 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:53:54 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 15:00:25 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html

However, I strictly followed the instruction of RT
Eessential. Any ideas?

— zhou jian sunzhoujian@yahoo.com wrote:

Hello,

Finally I got RT installed. However, I couldn’t
access
the /rt because of the permission problem. The
httpd.conf was configured as below. I followed the
instruction from RT Essential. And everything was
installed under root. What’s wrong with this?

–Paul

<VirtualHost 128.255.163.105>
Alias /rt “/opt/rt3/share/html”
#Alias /rt “/usr/local/rt”

ServerName 128.255.163.105
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location /opt/rt3/share/html>
SetHandler perl-script
PerlHandler RT::Mason


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Where do you guys put your rt directory? Do you guys
put it at the default /opt/rt3 or do you guys put it
under your httpd server /htdocs?— zhou jian sunzhoujian@yahoo.com wrote:

Could you guys give me an example of workable
configuration in httpd.conf for the VirtualHost
part?

I used the example from the website. It doesn’t work
out.

— zhou jian sunzhoujian@yahoo.com wrote:

I checked the log file of my httpd server.

[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:45 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:53:54 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 15:00:25 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html

However, I strictly followed the instruction of RT
Eessential. Any ideas?

— zhou jian sunzhoujian@yahoo.com wrote:

Hello,

Finally I got RT installed. However, I couldn’t
access
the /rt because of the permission problem. The
httpd.conf was configured as below. I followed
the

instruction from RT Essential. And everything
was

installed under root. What’s wrong with this?

–Paul

<VirtualHost 128.255.163.105>
Alias /rt “/opt/rt3/share/html”
#Alias /rt “/usr/local/rt”

ServerName 128.255.163.105
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location /opt/rt3/share/html>
SetHandler perl-script
PerlHandler RT::Mason


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Here are all the errors I got from the log file. If I
removed the rt configuration part from the httpd.conf
file, everything will function as least for the httpd
server. Can someone give me a hint and let me at least
to see the web interface of RT?

[Sat Feb 25 23:05:49 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Sat Feb 25 23:05:49 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Sat Feb 25 23:05:54 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html
[Sat Feb 25 23:38:43 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/
[Sat Feb 25 23:38:45 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/
[Sat Feb 25 23:38:46 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/
[Sat Feb 25 23:38:46 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/
[Sat Feb 25 23:38:46 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/— zhou jian sunzhoujian@yahoo.com wrote:

Where do you guys put your rt directory? Do you guys
put it at the default /opt/rt3 or do you guys put it
under your httpd server /htdocs?

— zhou jian sunzhoujian@yahoo.com wrote:

Could you guys give me an example of workable
configuration in httpd.conf for the VirtualHost
part?

I used the example from the website. It doesn’t
work
out.

— zhou jian sunzhoujian@yahoo.com wrote:

I checked the log file of my httpd server.

[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:20 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:51:45 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 14:53:54 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html
[Fri Feb 24 15:00:25 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html

However, I strictly followed the instruction of
RT

Eessential. Any ideas?

— zhou jian sunzhoujian@yahoo.com wrote:

Hello,

Finally I got RT installed. However, I
couldn’t

access
the /rt because of the permission problem. The
httpd.conf was configured as below. I followed
the

instruction from RT Essential. And everything
was

installed under root. What’s wrong with this?

–Paul

<VirtualHost 128.255.163.105>
Alias /rt “/opt/rt3/share/html”
#Alias /rt “/usr/local/rt”

ServerName 128.255.163.105
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location /opt/rt3/share/html>
SetHandler perl-script
PerlHandler RT::Mason


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Here are all the errors I got from the log file. If I
removed the rt configuration part from the httpd.conf
file, everything will function as least for the httpd
server. Can someone give me a hint and let me at least
to see the web interface of RT?

[Sat Feb 25 23:05:49 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html

This error doesn’t relate to anything you’ve posted
so far. Do you have a .htaccess file with a
’Limit’ statement or ‘Deny from all’?
Or is it prompting for a login which isn’t being
entered successfully?

Les Mikesell
les@futuresource.com

If I understand you correctly, I encountered this
problem when I tried to start the
httpd://myipaddress/rt. It hadn’t gone to the login
stage so far.
In my httpd.conf file, I used
"Allow from all".

It is my first time heard .htaccess. Where can I find
this file?— Les Mikesell les@futuresource.com wrote:

On Sat, 2006-02-25 at 23:49, zhou jian wrote:

Here are all the errors I got from the log file.
If I
removed the rt configuration part from the
httpd.conf
file, everything will function as least for the
httpd
server. Can someone give me a hint and let me at
least
to see the web interface of RT?

[Sat Feb 25 23:05:49 2006] [error] [client
128.255.163.105] client denied by server
configuration: /opt/rt3/share/html/index.html

This error doesn’t relate to anything you’ve posted
so far. Do you have a .htaccess file with a
’Limit’ statement or ‘Deny from all’?
Or is it prompting for a login which isn’t being
entered successfully?


Les Mikesell
les@futuresource.com

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

If I understand you correctly, I encountered this
problem when I tried to start the
httpd://myipaddress/rt. It hadn’t gone to the login
stage so far.

Note that when using named virtualhosts, the hostname
you use in the browser must match exactly what you
specify in ServerName or ServerAlias entries for that
vhost. Using the IP address won’t get the virtual
site unless it is the default.

In my httpd.conf file, I used
"Allow from all".

It is my first time heard .htaccess. Where can I find
this file?

If you Allowoverride on any options, apache will search
for a file named .htaccess in all directories where it
is allowed from the documentroot down to the location
of the files. The .htaccess file can contain additional
configuration settings like authentication requirements.

Somewhere you have a configuration setting that does
not permit your browser to access the server. It don’t
have much to do with any of the rt-specific settings.

Les Mikesell
les@futuresource.com

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1On Fri, 24 Feb 2006 at 09:13 (-0800), zhou jian wrote:

Finally I got RT installed. However, I couldn’t access the /rt because
of the permission problem. The httpd.conf was configured as below. I
followed the instruction from RT Essential. And everything was installed
under root. What’s wrong with this?

I had similar symptoms. It took me a while, but I finally found the
problem in my ‘global’ (default) apache configuration.

I had this directive in the main portion of httpd.conf (i.e., not part of
a virtual host definition):

AllowOverride None Order Deny,Allow Deny from all

Although in my virtual host definition, I had ‘Allow from all’, the ‘Deny
from all’ in the ‘global’ config was taking precedence, because of the
’Order Deny,Allow’.

When I commented out the ‘Deny from all’ above, the problem went away.

So, check your httpd.conf for a ‘Deny from all’ in conjunction with an
’Order Deny,Allow’. I believe this was the original setting in my Apache
config out of the box.

Of course, you may have a different problem, but the symptoms sure are the
same!

Mike

Mike Friedman System and Network Security
mikef@ack.Berkeley.EDU 2484 Shattuck Avenue
1-510-642-1410 University of California at Berkeley
http://ack.Berkeley.EDU/~mikef http://security.berkeley.edu

-----BEGIN PGP SIGNATURE-----
Version: PGP 6.5.8

iQA/AwUBRAYPnK0bf1iNr4mCEQJ1xQCaA3OK10wIDAQN4qLcTekZQUAhKrkAn35g
HQXY3wGuO+yKDenZuE5gwJV8
=EfHu
-----END PGP SIGNATURE-----