Why wont RT install?

Ive tried installing RT on Centos7 and Ubuntu Server 16.04 I cannot get all the dependencies to install.

I get the following error on the centos box:

CORE missing dependencies:
DateTime >= 0.44 …MISSING
DateTime::Locale >= 0.40 …MISSING
DateTime::Format::Natural >= 0.67 …MISSING
Date::Extract >= 0.02 …MISSING

And a similar error on the ubuntu box.

Im following the guide below:


Im using a minimal install and I cant get the dependencies to install. Ive ran the fixdeps script over and over and I get the same error. I see that the above article was updated as soon as the 12th of this months and Im wondering why this isnt working.

And RT only support md5?!? MD5 is no longer considered cryptographically secure, and should not be used for password encryption. Is there a way to set this to sha2?

Everything says that best practical has the best documented guides for installation but I have not had one of them work. A lot is VERY outdated.

To anyone reading this, my suggestion is to install RT on Ubuntu.

As an enterprise linux guy, it kills me to say it, but there is a lot more support/documentation on setting up RT on ubuntu.

I was able to get 4.4.2 running on Ubuntu 16.02 with relatively little pain.

Good luck and Gods speed.