Weird problem with exim and rt with double headers

Hi gang,

I just noticed something really odd on our RT system. Whenever it sends
out an email, in the headers, it shows every header twice. It doesn’t
do this from exim alone, only RT does this.

Anyone have any quick ideas off the top of their heads? It’s rt-2.0.13,
freebsd 4.5, exim 3.36.

Thanks in advance.

-Rob.

I’m having the same problem, but my mail system is qmail.

Thanks,
RichardOn Thu, Jun 20, 2002 at 02:02:24PM -0700, Rob Mitzel wrote:

Hi gang,

I just noticed something really odd on our RT system. Whenever it sends
out an email, in the headers, it shows every header twice. It doesn’t
do this from exim alone, only RT does this.

Anyone have any quick ideas off the top of their heads? It’s rt-2.0.13,
freebsd 4.5, exim 3.36.

Thanks in advance.

-Rob.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I just noticed something really odd on our RT system. Whenever it sends
out an email, in the headers, it shows every header twice. It doesn’t
do this from exim alone, only RT does this.

Anyone have any quick ideas off the top of their heads? It’s rt-2.0.13,
freebsd 4.5, exim 3.36.

How does your etc/config.pm look like? These settings work for me with exim:

$MailCommand = ‘sendmail’;

These options are good for most sendmail wrappers and workalikes

$SendmailArguments="-oi";

If you selected ‘sendmailpipe’ above, you MUST specify the path

to your sendmail binary in $SendmailPath.

!! If you did not # select ‘sendmailpipe’ above, this has no effect!!

$SendmailPath = “/usr/sbin/sendmail”;

Fabian

Perl is designed to give you several ways to do anything, so
consider picking the most readable one.
– Larry Wall in the perl man page

Akumiitti Ltd has automatically scanned this message for viruses.

Hi Tony,

Wow! That totally did the trick! Thanks for your help! :slight_smile:

(I cc’d this to the list so that everyone could see the absolutely correct
answer.)

-Rob.