Weird configuration problem with RT_SiteConfig.pm

Hello,
don’t know whether this is off-topic for this mailing list…
I’ve got a RT 3.0.3 installation (due to mod_perl trouble only running
since this earlier week), and RT does not seem to adopt some
configuration options in RT_SiteConfig.pm, such as $WebBaseURL etc.
By inserting debug statements in RT.pm, I see that the file is properly
read, and after LoadConfig the variable is set to the correct value, but
the Mason output still shows
http://RT::WebBaseURL.not.configured:80/NoAuth/images//bplogo.gif” for
the bestpractical logo…

Is that a known problem with RT 3.0.3?

Cheers,
Hans-Martin

don’t know whether this is off-topic for this mailing list…

this is a question for rt-users, not rt-devel.

I’ve got a RT 3.0.3 installation (due to mod_perl trouble only running
since this earlier week), and RT does not seem to adopt some
configuration options in RT_SiteConfig.pm, such as $WebBaseURL etc.

are you stopping and starting apache? apache needs a full stop and
start, not a restart to pick up changes. This is well documented.

seph

seph wrote:

don’t know whether this is off-topic for this mailing list…

this is a question for rt-users, not rt-devel.

That’s what I feared… thanks a lot for helping anyway!

I’ve got a RT 3.0.3 installation (due to mod_perl trouble only running
since this earlier week), and RT does not seem to adopt some
configuration options in RT_SiteConfig.pm, such as $WebBaseURL etc.

are you stopping and starting apache? apache needs a full stop and
start, not a restart to pick up changes. This is well documented.

I did stop and start apache, after upgrading to RT 3.0.9 btw…
And you’re right, it works now, and I should have read the docs more
closely :slight_smile:
Now I do have another problem with the mail gateway, but I’ll try
rt-users first for that one…

Cheers,
Hans-Martin