Web Interface Images

Hello Everyone.

I am running RT3.4 + Apache2 + FastCGI + Debian 3.1. I installed RT
from the debian package using apt-get. It installs fine and it will
work great if I want to use http://domain.com/rt/ but I rather just
use www.domain.com without having to go to a subdirectory. To see
what I mean if you go to http://tickets.stabletransit.com/ you still
notice that the images and other are not displayed correctly. This
also happens when I try to login to rt the side bar and the logout
button do not work properly.

Here is my current Apache 2 settings:

<VirtualHost 65.61.131.243>
ServerName tickets.stabletransit.com
DocumentRoot /usr/share/request-tracker3.4/html/
AddDefaultCharset UTF-8

Adding the following for RT (the ticket tracker)

      AddHandler fastcgi-script fcgi

<Directory “/usr/share/request-tracker3.4/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to for noauth

     Alias /NoAuth/ /usr/share/request-tracker3.4/html/NoAuth/

Alias NoAuth/images /usr/share/request-tracker3.4/html/NoAuth/

images
ScriptAlias / /usr/share/request-tracker3.4/libexec/
mason_handler.fcgi/

#FastCgiIpcDir /tmp
FastCgiServer /usr/share/request-tracker3.4/libexec/
mason_handler.fcgi -idle-timeout 120 -processes 4

THE WEBSERVER:

Set($WebBaseURL , “http://tickets.stabletransit.com”);
Set($WebPath , “/”);

I am not sure why it doesn’t work. I have tried many different
removing the / from Webpath and it appears that it works but when I
press a button inside of RT it gives a blank page. Anyone have any
ideas?

Thanks
-jason b.

After beating my head for 4 hours then responding to the list I
finally figured out why it didn’t work.

I had to add the following:

Set($WebBaseURL , “http://tickets.stabletransit.com”);
Set($WebPath , “”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);
Set($WebImagesURL , $WebURL . “NoAuth/images/”);

I though the last two didn’t have to be in there since it was already
in the RT_Config.pm

The images are there and everything fine though when I press the
logout button I recieve a box that refreshes to fast and goes to the
following:

http://tickets.stabletransit.com/NoAuth/<%$URL%>

This is in the browser:

Not Found

The requested URL /NoAuth/<%$URL%> was not found on this server.

This is what appears in my logs:

[Thu Oct 27 14:51:57 2005] [error] [client 64.39.0.38] File does not
exist: /usr/share/request-tracker3.4/html/NoAuth/<%$URL%>, referer:
http://tickets.stabletransit.com/NoAuth/Logout.html

The %URL% is from the Logout.html in the following lines:

$URL => $RT::WebPath."/"On Oct 27, 2005, at 1:29 PM, Jason B. wrote:

Hello Everyone.

I am running RT3.4 + Apache2 + FastCGI + Debian 3.1. I installed
RT from the debian package using apt-get. It installs fine and it
will work great if I want to use http://domain.com/rt/ but I rather
just use www.domain.com without having to go to a subdirectory. To
see what I mean if you go to http://tickets.stabletransit.com/ you
still notice that the images and other are not displayed
correctly. This also happens when I try to login to rt the side
bar and the logout button do not work properly.

Here is my current Apache 2 settings:

<VirtualHost 65.61.131.243>
ServerName tickets.stabletransit.com
DocumentRoot /usr/share/request-tracker3.4/html/
AddDefaultCharset UTF-8

Adding the following for RT (the ticket tracker)

     AddHandler fastcgi-script fcgi

<Directory “/usr/share/request-tracker3.4/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to for noauth

    Alias /NoAuth/ /usr/share/request-tracker3.4/html/NoAuth/

Alias NoAuth/images /usr/share/request-tracker3.4/html/

NoAuth/images
ScriptAlias / /usr/share/request-tracker3.4/libexec/
mason_handler.fcgi/

#FastCgiIpcDir /tmp
FastCgiServer /usr/share/request-tracker3.4/libexec/
mason_handler.fcgi -idle-timeout 120 -processes 4

THE WEBSERVER:

Set($WebBaseURL , “http://tickets.stabletransit.com”);
Set($WebPath , “/”);

I am not sure why it doesn’t work. I have tried many different
removing the / from Webpath and it appears that it works but when I
press a button inside of RT it gives a blank page. Anyone have any
ideas?

Thanks
-jason b.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!
Download a free sample chapter from http://rtbook.bestpractical.com

After beating my head for 4 hours then responding to the list I finally
figured out why it didn’t work.

I had to add the following:

Set($WebBaseURL , “http://tickets.stabletransit.com”);
Set($WebPath , “”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);
Set($WebImagesURL , $WebURL . “NoAuth/images/”);

I though the last two didn’t have to be in there since it was already in the
RT_Config.pm
yes, you need only first two lines. I didn’t understand does it works
for you if you delete last two lines?

The images are there and everything fine though when I press the logout
button I recieve a box that refreshes to fast and goes to the following:

http://tickets.stabletransit.com/NoAuth/<%$URL%>

This is in the browser:

Not Found

The requested URL /NoAuth/<%$URL%> was not found on this server.
Somebody posted fix for this, I’m sure.

[snip]

Best regards, Ruslan.