Web external Auth

HI I have done following changes, but still I fall back to the internal
Authentication.

Any ideas?? any other settings I suppose to do?

Thanks

RT_SiteConfig.pm
Set($WebExternalAuth , 1);
Set($WebFallbackToInternalAuth , 1);

httpd.conf
AllowOverride AuthConfig

…share/html/.htaccess
AuthName “RT access”
AuthType Basic
AuthUserFile /local/host/apps/httpdmh/passwd/passwords

require valid-user

[vinita@mulga] httpdmh [1:101] ls -l
/local/host/apps/httpdmh/passwd/passwords
-rw-r–r-- 1 vinita tech 39 Mar 17 09:17
/local/host/apps/httpdmh/passwd/passwords
[vinita@mulga] httpdmh [1:102] cat
/local/host/apps/httpdmh/passwd/passwords
vinita:ZiVGpbabcQ5Fs
vvj:Laek4rgVabcYo

warm regards
Vinita Vigine Murugiah
Email : vinita@cs.mu.oz.au Ph : (03) 8344 1273

HI I have done following changes, but still I fall back to the
internal Authentication.

RT_SiteConfig.pm

Set($WebExternalAuth , 1);
Set($WebFallbackToInternalAuth , 1);

with those settings RT should use REMOTE_USER if it’s set, otherwise
fallback. What is the problem? is apache never prompting you for a
password, are both apache and RT prompting you?

seph

seph wrote:

HI I have done following changes, but still I fall back to the
internal Authentication.

RT_SiteConfig.pm

Set($WebExternalAuth , 1);
Set($WebFallbackToInternalAuth , 1);

with those settings RT should use REMOTE_USER if it’s set, otherwise
fallback. What is the problem? is apache never prompting you for a
password,

yes, apache is never prompting for password - always fallback to RT
authentication

are both apache and RT prompting you?

seph

warm regards
Vinita Vigine Murugiah
Email : vinita@cs.mu.oz.au Ph : (03) 8344 1273

vinita vigine MURUGIAH vinita@cs.mu.OZ.AU writes:

yes, apache is never prompting for password - always fallback to RT
authentication
httpd.conf

AllowOverride AuthConfig

…share/html/.htaccess

AuthName “RT access”
AuthType Basic
AuthUserFile /local/host/apps/httpdmh/passwd/passwords

are you sure that apache is paying any attention to this file? What
happens if you move the Auth directives into the main httpd.conf, and
not the .htaccess, I’m not sure how .htaccess and mason interact,
since things aren’t served directly. I expect .htaccess is ignored.

seph

It is working!!!, it was my fault, wrong directory

fix
add
<Directory “/usr/local/apps/rt-3.0.8/share/html”>
AllowOverride AuthConfig

to httpd.conf.

Big thanks to seph :slight_smile:

seph wrote:

vinita vigine MURUGIAH vinita@cs.mu.OZ.AU writes:

yes, apache is never prompting for password - always fallback to RT
authentication
httpd.conf

AllowOverride AuthConfig

…share/html/.htaccess

AuthName “RT access”
AuthType Basic
AuthUserFile /local/host/apps/httpdmh/passwd/passwords

are you sure that apache is paying any attention to this file? What
happens if you move the Auth directives into the main httpd.conf, and
not the .htaccess, I’m not sure how .htaccess and mason interact,
since things aren’t served directly. I expect .htaccess is ignored.

seph


rt-users mailing list
rt-users@lists.bestpractical.com
The rt-users Archives

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

warm regards
Vinita Vigine Murugiah
Email : vinita@cs.mu.oz.au Ph : (03) 8344 1273