Warning - perl idiot here

How come I can’t view the documentation with RT_Config.pm using perldoc?

tracker:~ # perldoc /opt/rt3/etc/RT_Config.pm
Can’t open /opt/rt3/etc/RT_Config.pm: Permission denied at /usr/lib/perl5/5.8.8/Pod/Perldoc.pm line 1380.

Mike

The information in this message may be proprietary and/or confidential, and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify Stonebridge Bank immediately by replying to this message and deleting it from your computer.

Running SuSE Enterprise Linux 10, SP3. Executing “perldoc /opt/rt3/etc/RT_Config.pm” as root. The error occurs on line 1380 of /usr/lib/perl5/5.8.8/Pod/Perldoc.pm, which is this:

open(TEST,"<", $file) or die “Can’t open $file: $!”; # XXX 5.6ism

So, it doesn’t have permission to open a file? I don’t follow. Sorry.

Mike

“Michael James” MJames@stonebridgebank.com 7/29/2010 1:55 PM >>>
How come I can’t view the documentation with RT_Config.pm using perldoc?

tracker:~ # perldoc /opt/rt3/etc/RT_Config.pm
Can’t open /opt/rt3/etc/RT_Config.pm: Permission denied at /usr/lib/perl5/5.8.8/Pod/Perldoc.pm line 1380.

Mike

The information in this message may be proprietary and/or confidential, and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify Stonebridge Bank immediately by replying to this message and deleting it from your computer.

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

The information in this message may be proprietary and/or confidential, and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify Stonebridge Bank immediately by replying to this message and deleting it from your computer.

Try: perldoc -FOn Thu, Jul 29, 2010 at 1:55 PM, Michael James MJames@stonebridgebank.com wrote:

How come I can’t view the documentation with RT_Config.pm using perldoc?

tracker:~ # perldoc /opt/rt3/etc/RT_Config.pm
Can’t open /opt/rt3/etc/RT_Config.pm: Permission denied at /usr/lib/perl5/5.8.8/Pod/Perldoc.pm line 1380.

Mike

The information in this message may be proprietary and/or confidential, and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify Stonebridge Bank immediately by replying to this message and deleting it from your computer.

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Returns nothing. Ah well, I’ll just read the darned file and skip over the pod formatting. Thanks for the suggestion.

Mike

tracker:~ # perldoc -F /opt/rt3/etc/RT_Config.pm
tracker:~ #

Todd Chapman todd@chaka.net 7/29/2010 3:06 PM >>>
Try: perldoc -FOn Thu, Jul 29, 2010 at 1:55 PM, Michael James MJames@stonebridgebank.com wrote:
How come I can’t view the documentation with RT_Config.pm using perldoc?

tracker:~ # perldoc /opt/rt3/etc/RT_Config.pm
Can’t open /opt/rt3/etc/RT_Config.pm: Permission denied at /usr/lib/perl5/5.8.8/Pod/Perldoc.pm line 1380.

Mike

The information in this message may be proprietary and/or confidential, and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify Stonebridge Bank immediately by replying to this message and deleting it from your computer.

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

The information in this message may be proprietary and/or confidential, and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify Stonebridge Bank immediately by replying to this message and deleting it from your computer.

Hi,

My rights on /opt/rt3/etc/RT_Config.pm are 440 (should be the stock ones); now, from man perldoc :

SECURITY
Because perldoc does not run properly tainted, and is known to have security issues, when
run as the superuser it will attempt to drop privileges by setting the effective and real
IDs to nobody’s or nouser’s account, or -2 if unavailable. If it cannot relinquish its
privileges, it will not run.

If I chmod 444 /opt/rt3/etc/RT_Config.pm, then perldoc (running as root) is able to display it, whereas before it failed as yours
did.

Hope this helps

Robert GRASSO – System engineer

CEDRAT S.A.
15 Chemin de Malacher - Inovallée - 38246 MEYLAN cedex - FRANCE
Phone: +33 (0)4 76 90 50 45 - Fax: +33 (0)4 56 38 08 30
mailto:robert.grasso@cedrat.com - http://www.cedrat.com

Thanks, Robert. Permissions on RT_Config.pm were set at 550 with root as
owner. I chmod’d them to 444 per your suggestion, and it worked. I had
read the man page for perldoc, but didn’t catch on.

btw, when I now run “perldoc /opt/rt3/etc/RT_Config.pm”, I get three
syntax errors:

tracker:~ # perldoc /opt/rt3/etc/RT_Config.pm
/opt/rt3/etc/RT_Config.pm:443: Unmatched =back
/opt/rt3/etc/RT_Config.pm:459: Unmatched =back
/opt/rt3/etc/RT_Config.pm:471: Unmatched =back

Again, thanks!

Mike

“Robert Grasso” robert.grasso+nv@cedrat.com 7/30/2010 11:25 AM

Hi,

My rights on /opt/rt3/etc/RT_Config.pm are 440 (should be the stock
ones); now, from man perldoc :

SECURITY
Because perldoc does not run properly tainted, and is known to
have security issues, when
run as the superuser it will attempt to drop privileges by
setting the effective and real
IDs to nobody’s or nouser’s account, or -2 if unavailable.
If it cannot relinquish its
privileges, it will not run.

If I chmod 444 /opt/rt3/etc/RT_Config.pm, then perldoc (running as
root) is able to display it, whereas before it failed as yours
did.

Hope this helps

Robert GRASSO – System engineer

CEDRAT S.A.
15 Chemin de Malacher - Inovallée - 38246 MEYLAN cedex - FRANCE
Phone: +33 (0)4 76 90 50 45 - Fax: +33 (0)4 56 38 08 30
mailto:robert.grasso@cedrat.com - http://www.cedrat.com

-----Message d’origine-----
De : rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] De la part
de Michael James
Envoyé : 29 juillet 2010 21:26
Cc : <RT Users
Objet : Re: [rt-users] Warning - perl idiot here

Returns nothing. Ah well, I’ll just read the darned file and
skip over the pod formatting. Thanks for the suggestion.

Mike

tracker:~ # perldoc -F /opt/rt3/etc/RT_Config.pm
tracker:~ #

Todd Chapman todd@chaka.net 7/29/2010 3:06 PM >>>
Try: perldoc -F

How come I can’t view the documentation with RT_Config.pm
using perldoc?

tracker:~ # perldoc /opt/rt3/etc/RT_Config.pm
Can’t open /opt/rt3/etc/RT_Config.pm: Permission denied at
/usr/lib/perl5/5.8.8/Pod/Perldoc.pm line 1380.

Mike

The information in this message may be proprietary and/or
confidential, and protected from disclosure. If the reader of
this message is not the intended recipient, or an employee or
agent responsible for delivering this message to the intended
recipient, you are hereby notified that any dissemination,
distribution or copying of this communication is strictly
prohibited. If you have received this communication in error,
please notify Stonebridge Bank immediately by replying to
this message and deleting it from your computer.

Discover RT’s hidden secrets with RT Essentials from O’Reilly
Media.

Buy a copy at http://rtbook.bestpractical.com

The information in this message may be proprietary and/or
confidential, and protected from disclosure. If the reader of
this message is not the intended recipient, or an employee or
agent responsible for delivering this message to the intended
recipient, you are hereby notified that any dissemination,
distribution or copying of this communication is strictly
prohibited. If you have received this communication in error,
please notify Stonebridge Bank immediately by replying to
this message and deleting it from your computer.

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

The information in this message may be proprietary and/or confidential,
and protected from disclosure. If the reader of this message is not the
intended recipient, or an employee or agent responsible for delivering
this message to the intended recipient, you are hereby notified that any
dissemination, distribution or copying of this communication is strictly
prohibited. If you have received this communication in error, please
notify Stonebridge Bank immediately by replying to this message and
deleting it from your computer.

tracker:~ # perldoc /opt/rt3/etc/RT_Config.pm
/opt/rt3/etc/RT_Config.pm:443: Unmatched =back
/opt/rt3/etc/RT_Config.pm:459: Unmatched =back
/opt/rt3/etc/RT_Config.pm:471: Unmatched =back

I don’t get these errors : we must not be using the same versions :

I am running RT v3.8.7 on CentOS 5.5 and

[root@vicen02 ~]# perldoc -V
Perldoc v3.14, under perl v5.008008 for linux

Again, thanks!

You are welcome !

Robert GRASSO
System Engineer

CEDRAT
15, Chemin de Malacher - Inovallée - 38246 MEYLAN Cedex - FRANCE
Tel: +33 (0)4 76 90 50 45 Fax: +33 (0)4 76 90 16 09
mailto:Robert.Grasso@cedrat.com
Support service : mailto:support@cedrat.com
Commercial service : mailto:cedrat@cedrat.com
Web site : http://www.cedrat.com

Agreed, I don’t get those errors on 3.8.7, but I do see them in 3.8.8. I
have both versions running for different departments.

RT 3.8.8
SLES 10 SP3
tracker:~ # perldoc -V
Perldoc v3.14, under perl v5.008008 for linux

Thanks again.

“Robert Grasso” robert.grasso+nv@cedrat.com 7/30/2010 12:40 PM

tracker:~ # perldoc /opt/rt3/etc/RT_Config.pm
/opt/rt3/etc/RT_Config.pm:443: Unmatched =back
/opt/rt3/etc/RT_Config.pm:459: Unmatched =back
/opt/rt3/etc/RT_Config.pm:471: Unmatched =back

I don’t get these errors : we must not be using the same versions :

I am running RT v3.8.7 on CentOS 5.5 and

[root@vicen02 ~]# perldoc -V
Perldoc v3.14, under perl v5.008008 for linux

Again, thanks!

You are welcome !

Robert GRASSO
System Engineer

CEDRAT
15, Chemin de Malacher - Inovallée - 38246 MEYLAN Cedex - FRANCE
Tel: +33 (0)4 76 90 50 45 Fax: +33 (0)4 76 90 16 09
mailto:Robert.Grasso@cedrat.com
Support service : mailto:support@cedrat.com
Commercial service : mailto:cedrat@cedrat.com
Web site : http://www.cedrat.com

The information in this message may be proprietary and/or confidential,
and protected from disclosure. If the reader of this message is not the
intended recipient, or an employee or agent responsible for delivering
this message to the intended recipient, you are hereby notified that any
dissemination, distribution or copying of this communication is strictly
prohibited. If you have received this communication in error, please
notify Stonebridge Bank immediately by replying to this message and
deleting it from your computer.