Users showing time in GMT

RT 4.0.5 on a Debian system

I have at least one user who has timestamps showing GMT rather than local time. She had Options->About Me set to “system default” (same as me) and then set to “America/New_York” but timestamps in her tickets still show the time followed by GMT. Any ideas?

-Mark

From: “Mark F. Komarinski” mark_komarinski@hms.harvard.edu

I have at least one user who has timestamps showing GMT rather than
local time. She had Options->About Me set to “system default” (same as
me) and then set to “America/New_York” but timestamps in her tickets
still show the time followed by GMT. Any ideas?

Are they just labeled wrong? Or if she writes a ticket at 4pm EDT,
does it say 2000UTC?

Cheers,
– jra
Jay R. Ashworth Baylink jra@baylink.com
Designer The Things I Think RFC 2100
Ashworth & Associates http://baylink.pitas.com 2000 Land Rover DII
St Petersburg FL USA #natog +1 727 647 1274

----- Original Message -----

From: “Mark F. Komarinski” mark_komarinski@hms.harvard.edu

I have at least one user who has timestamps showing GMT rather than
local time. She had Options->About Me set to “system default” (same as
me) and then set to “America/New_York” but timestamps in her tickets
still show the time followed by GMT. Any ideas?

Are they just labeled wrong? Or if she writes a ticket at 4pm EDT,
does it say 2000UTC?

Yes, this is just a labeling issue for her. If I look at the same ticket, the display shows 4pm EDT

----- Original Message -----

From: “Mark F. Komarinski” mark_komarinski@hms.harvard.edu

I have at least one user who has timestamps showing GMT rather than
local time. She had Options->About Me set to “system default” (same as
me) and then set to “America/New_York” but timestamps in her tickets
still show the time followed by GMT. Any ideas?

Dates where? In dates box or somewhere else? Are you running RT under mod_perl?

Are they just labeled wrong? Or if she writes a ticket at 4pm EDT,
does it say 2000UTC?

Cheers,
– jra

Jay R. Ashworth Baylink jra@baylink.com
Designer The Things I Think RFC 2100
Ashworth & Associates http://baylink.pitas.com 2000 Land Rover DII
St Petersburg FL USA #natog +1 727 647 1274

Best regards, Ruslan.

I have at least one user who has timestamps showing GMT rather than
local time. She had Options->About Me set to “system default” (same as
me) and then set to “America/New_York” but timestamps in her tickets
still show the time followed by GMT. Any ideas?

Dates where? In dates box or somewhere else? Are you running RT under mod_perl?

Transactions and metadata in the web interface (see attached image). She’s seeing it across multiple browsers on multiple systems, and she doesn’t see it in our similarly-configured development environment.

We’re using mod_fastcgi.

[cid:9CF2D511-5432-4585-9DB5-3FBB8971AE02@med.harvard.edu]

[snip]

Transactions and metadata in the web interface (see attached image).
She’s seeing it

I asked cuz for a long time we were not changing dates in mail headers, so
they were displayed as they were in email. Dates in Dates box are totally
rendered by RT.

across multiple browsers on multiple systems, and she doesn’t see it in our

similarly-configured development environment.

Do you copy DB to dev environment.

We’re using mod_fastcgi.

I asked because of known problems with TZ handling under mod_perl that can
fixed by changing httpd config. This problem doesn’t affect FGGI.

I know what’s happened. Your user changed format of how dates are
displayed. There are a few formats that don’t take TZ into account and
always display in GMT.

Best regards, Ruslan.

I know what’s happened. Your user changed format of how dates are displayed. There are a few formats that don’t take TZ into account and always display in GMT.

Fortunately I’m in a meeting with this user right now and was able to check this. You’re right. Once I set the Date Format back to system default it started to work right. Thanks!

-Mark