Upgrading from rt2 to rt3 on the same box

Alle,

For reasons to lengthy to get into in this post, I need to do testing of

rt3 on the same machine that we are currently running rt2 on. After running
"perl sbin/rt-test-dependencies --with-mysql --with-modperl1" I get the
output below. How will updating the current version (example HTML::Mason
1.16 is required, we have 1.04) affect the running rt2 version? We it cause
problems?

Best Regards,
Camron

[cwfox@hilo rt-3-0-0]$ perl
sbin/rt-test-dependencies --with-mysql --with-modperl1
I18N-COMPAT dependencies:
Text::Iconv …MISSING
Encode::compat 0.04…MISSING
MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …MISSING
Exception::Class …MISSING
HTML::Mason 1.16…MISSING
HTML::Mason version 1.16 required–this is only version 1.04 at (eval 9)
line 2.
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 …found
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found
MYSQL dependencies:
DBD::mysql 2.0416…found
MODPERL1 dependencies:
CGI …found
Apache::Request …found
Apache::DBI …MISSING
MAILGATE dependencies:
HTML::TreeBuilder …MISSING
HTML::FormatText …MISSING
Getopt::Long …found
LWP::UserAgent …found
CLI dependencies:
Getopt::Long 2.24…found
DEV dependencies:
Regexp::Common …MISSING
Time::HiRes …found
Test::Inline …MISSING
WWW::Mechanize …MISSING
CORE dependencies:
Digest::MD5 …found
DBI 1.18…found
Test::Inline …MISSING
Class::ReturnValue 0.40…MISSING
DBIx::SearchBuilder 0.80…MISSING
DBIx::SearchBuilder version 0.8 required–this is only version 0.60 at
(eval 45) line 2.
Text::Template …found
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…found
Locale::Maketext …MISSING
Locale::Maketext::Lexicon 0.10…MISSING
Locale::Maketext::Fuzzy …MISSING
MIME::Entity 5.108…found
Mail::Mailer 1.57…MISSING
Mail::Mailer version 1.57 required–this is only version 1.44 at (eval 83)
line 2.
Net::SMTP …found
Text::Wrapper …found
Time::ParseDate …MISSING
File::Temp …found
Term::ReadKey …found
Text::Autoformat …MISSING
Text::Quoted …MISSING
[cwfox@hilo rt-3-0-0]$

Camron W. Fox
Hilo Office
High Performance Computing Group
Fujitsu America, INC.
E-mail: cwfox@fujitsu.com
Phone: (808) 934-4102
Pager: (808) 934-1290
Cell: (808) 937-5026

I recently installed RT2 (just before RT3 was released). As such, I grabbed all
the most recent stuff from CPAN. Below is a list of my current modules, which
hopefully will answer your questions.

Alle,

  For reasons to lengthy to get into in this post, I need to do testing of

rt3 on the same machine that we are currently running rt2 on. After running
"perl sbin/rt-test-dependencies --with-mysql --with-modperl1" I get the
output below. How will updating the current version (example HTML::Mason
1.16 is required, we have 1.04) affect the running rt2 version? We it cause
problems?

Best Regards,
Camron

  HTML::Mason 1.16...MISSING
          HTML::Mason version 1.16 required--this is only version 1.04 at

(eval 9) line 2.

I’m running perl-HTML-Mason-1.19-1

  DBIx::SearchBuilder 0.80...MISSING
          DBIx::SearchBuilder version 0.8 required--this is only version

0.60 at (eval 45) line 2.

I’m running perl-DBIx-SearchBuilder-0.80-1

  Mail::Mailer 1.57...MISSING
          Mail::Mailer version 1.57 required--this is only version 1.44

at (eval 83) line 2.

I’m running perl-MailTools-1.58-1

I’m not experiancing any reall issues w/ RT2 with the newer modules I’ve listed
above.

having said that, you would probably be wise to save aside the rpms (or
whatever you used to install your older perl modules) before installing newer
ones, just incase you need to back down.

-Greg

E-Mail: Gregory Hosler gregory.hosler@accessgate.com.sg
Time: 10:19:46

If each of us have one object, and we exchange them,
then each of us still has one object.
If each of us have one idea, and we exchange them,
then each of us now has two ideas.

Alle,

For reasons to lengthy to get into in this post, I need to do testing
of
rt3 on the same machine that we are currently running rt2 on. After
running
"perl sbin/rt-test-dependencies --with-mysql --with-modperl1" I get the
output below. How will updating the current version (example
HTML::Mason
1.16 is required, we have 1.04) affect the running rt2 version? We it
cause
problems?

Jesse said late last week that all the packages needed for rt3 also
work for rt2. If You cannot install a second apache instance on that
machine, don’t forget that rt2 and rt3 won’t run within the same
mod_perl nicely. Install rt3 using fastcgi, and You’ll be able to use
one apache instance.

Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg