Upgrade to 4.2 fail

Trying to get from 4.0.16 to 4.2.0rc5.

Make upgrade and make database-upgrade go fine, but when I restart Apache I
get:

root@help:/tmp/rt-4.2.0rc5# /etc/init.d/apache2 restart
Syntax error on line 44 of /etc/apache2/sites-enabled/000-default:
Can’t locate Symbol/Global/Name.pm in @INC (@INC contains:
/opt/rt4/sbin/…/local/lib /opt/rt4/sbin/…/lib /etc/perl
/usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14
/usr/local/lib/site_perl . /etc/apache2) at
/opt/rt4/sbin/…/lib/RT/Config.pm line 55.\nBEGIN failed–compilation
aborted at /opt/rt4/sbin/…/lib/RT/Config.pm line 55.\nCompilation failed
in require at /opt/rt4/sbin/…/lib/RT.pm line 156.\n
Action ‘configtest’ failed.
The Apache error log may have more information.
…fail!

Below is line 44 of 000-default…but I’m not sure where the syntax error
is. This is getting above and beyond my knowledge of linux/apache!

35 <Location /rt/>
36 Order allow,deny
37 Allow from all
38
39 SetHandler modperl
40 PerlResponseHandler Plack::Handler::Apache2
41 PerlSetVar psgi_app /opt/rt4/sbin/rt-server
42
43
44 use Plack::Handler::Apache2;
45 Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");
46
47

Any help is appreciated!

Max

Max McGrath
Network Administrator
Carthage College
262-552-5512
mmcgrath@carthage.edu

Trying to get from 4.0.16 to 4.2.0rc5.

Make upgrade and make database-upgrade go fine, but when I restart
Apache I get:

root@help:/tmp/rt-4.2.0rc5# /etc/init.d/apache2 restart
Syntax error on line 44 of /etc/apache2/sites-enabled/000-default:
Can’t locate Symbol/Global/Name.pm in @INC

RT 4.2 has additional dependencies that RT 4.0 does not. You skipped
step 3 (make testdeps) of the upgrade steps in README:

http://bestpractical.com/docs/rt/4.2.0/README

  • Alex

Nope…definitely did that step:

root@help:/tmp/rt-4.2.0rc5# make testdeps
/usr/bin/perl ./sbin/rt-test-dependencies --verbose --with-mysql
–with-fastcgi
perl:
>=5.10.1(5.14.2) …found
users:
rt group (www-data) …found
bin owner (root) …found
libs owner (root) …found
libs group (bin) …found
web owner (www-data) …found
web group (www-data) …found
CLI dependencies:
Text::ParseWords …found
Term::ReadKey …found
Getopt::Long >= 2.24 …found
HTTP::Request::Common …found
Term::ReadLine …found
LWP …found
CORE dependencies:
Storable >= 2.08 …found
Encode >= 2.39 …found
Crypt::Eksblowfish …found
Module::Versions::Report >= 1.05 …found
List::MoreUtils …found
Errno …found
DBI >= 1.37 …found
Devel::StackTrace >= 1.19 …found
HTTP::Message >= 6.0 …found
Text::Password::Pronounceable …found
Devel::GlobalDestruction …found
Time::ParseDate …found
IPC::Run3 …found
Tree::Simple >= 1.04 …found
HTML::Scrubber >= 0.08 …found
HTML::Quoted …found
Sys::Syslog >= 0.16 …found
Mail::Mailer >= 1.57 …found
Data::GUID …found
HTML::Mason >= 1.43 …found
HTML::Entities …found
LWP::Simple …found
Symbol::Global::Name >= 0.04 …found
DateTime::Format::Natural >= 0.67 …found
Plack >= 1.0002 …found
File::Glob …found
Class::Accessor >= 0.34 …found
Text::Wrapper …found
Regexp::Common::net::CIDR …found
Log::Dispatch >= 2.30 …found
HTML::FormatText::WithLinks::AndTables …found
DateTime >= 0.44 …found
CGI::Emulate::PSGI …found
Text::Quoted >= 2.07 …found
Regexp::IPv6 …found
CGI >= 3.38 …found
CSS::Squish >= 0.06 …found
DateTime::Locale >= 0.40 …found
CGI::PSGI >= 0.12 …found
Apache::Session >= 1.53 …found
Digest::SHA …found
HTML::Mason::PSGIHandler >= 0.52 …found
MIME::Entity >= 5.504 …found
Locale::Maketext::Lexicon >= 0.32 …found
Module::Refresh >= 0.03 …found
Role::Basic >= 0.12 …found
Digest::base …found
File::Temp >= 0.19 …found
Date::Manip …found
Locale::Maketext >= 1.06 …found
HTML::RewriteAttributes >= 0.05 …found
Text::Template >= 1.44 …found
CGI::Cookie >= 1.20 …found
Scalar::Util …found
XML::RSS >= 1.05 …found
Text::WikiFormat >= 0.76 …found
File::Spec >= 0.8 …found
DBIx::SearchBuilder >= 1.65 …found
File::ShareDir …found
Regexp::Common …found
Digest::MD5 >= 2.27 …found
HTML::FormatText::WithLinks >= 0.14 …found
Mail::Header >= 2.12 …found
Locale::Maketext::Fuzzy >= 0.11 …found
Time::HiRes …found
Email::Address::List …found
Net::CIDR …found
JSON …found
UNIVERSAL::require …found
Email::Address >= 1.897 …found
Plack::Handler::Starlet …found
DASHBOARDS dependencies:
URI::QueryParam …found
URI >= 1.59 …found
MIME::Types …found
FASTCGI dependencies:
FCGI::ProcManager …found
FCGI >= 0.74 …found
GD dependencies:
GD::Text …found
GD …found
GD::Graph >= 1.47 …found
GPG dependencies:
File::Which …found
PerlIO::eol …found
GnuPG::Interface …found
ICAL dependencies:
Data::ICal …found
MAILGATE dependencies:
Pod::Usage …found
LWP::UserAgent >= 6.0 …found
Crypt::SSLeay …found
Getopt::Long …found
Net::SSL …found
LWP::Protocol::https …found
Mozilla::CA …found
MYSQL dependencies:
DBD::mysql >= 2.1018 …found
SMIME dependencies:
String::ShellQuote …found
File::Which …found
Crypt::X509 …found
USERLOGO dependencies:
Convert::Color …found

All dependencies have been found.

Max McGrath
Network Administrator
Carthage College
262-552-5512
mmcgrath@carthage.eduOn Wed, Oct 2, 2013 at 9:44 PM, Alex Vandiver alexmv@bestpractical.comwrote:

On Wed, 2013-10-02 at 21:26 -0500, Max McGrath wrote:

Trying to get from 4.0.16 to 4.2.0rc5.

Make upgrade and make database-upgrade go fine, but when I restart
Apache I get:

root@help:/tmp/rt-4.2.0rc5# /etc/init.d/apache2 restart
Syntax error on line 44 of /etc/apache2/sites-enabled/000-default:
Can’t locate Symbol/Global/Name.pm in @INC

RT 4.2 has additional dependencies that RT 4.0 does not. You skipped
step 3 (make testdeps) of the upgrade steps in README:

http://bestpractical.com/docs/rt/4.2.0/README

  • Alex


RT Training in New York, October 8th and 9th:
http://bestpractical.com/training

Nope…definitely did that step: [snp]

Ah. Then the perl that your mod_perl is linked against is not the perl
that you configured RT with – did you recompile a newer perl to meet
the >= 5.10.1 dep, but not recompile mod_perl? Deploying with mod_fcgi
or mod_fastcgi is probably easier than upgrading mod_perl.

  • Alex

Thanks!

Tried moving to FastCgi and I now get:

You’re almost there!You haven’t yet configured your webserver to run RT.
You appear to have installed RT’s web interface correctly, but haven’t yet
configured your web server to “run” the RT server which powers the web
interface. The next step is to edit your webserver’s configuration file to
instruct it to use RT’s mod_perl or FastCGI handler. If you need
commercial support, please contact us at sales@bestpractical.com.

I’m definitely not a web server expert…so…any advice?

Max

Max McGrath
Network Administrator
Carthage College
262-552-5512
mmcgrath@carthage.eduOn Wed, Oct 2, 2013 at 10:53 PM, Alex Vandiver alexmv@bestpractical.comwrote:

On Wed, 2013-10-02 at 21:53 -0500, Max McGrath wrote:

Nope…definitely did that step: [snp]

Ah. Then the perl that your mod_perl is linked against is not the perl
that you configured RT with – did you recompile a newer perl to meet
the >= 5.10.1 dep, but not recompile mod_perl? Deploying with mod_fcgi
or mod_fastcgi is probably easier than upgrading mod_perl.

  • Alex

in httpd.conf ---- and this will depend on your version of apache, and how
you’ve structured your configurations files.

You need to load the fastcgi module

LoadModule fastcgi_module modules/mod_fastcgi.so

You need to declare your fastcgi service

FastCgiServer /pathto/RT/sbin/rt-server.fcgi -processes 5 -idle-timeout

30

your settings for processes and timeout will vary according to your load

Inside your virtual host definitions, tell apache how to handle fcgi
requests

 AddHandler fastcgi-script fcgi

Tell apache how to run the RT code

Alias /RT /pathto/RT/sbin/rt-server.fcgi/
<Directory /pathto/RT/sbin/*>
Options Indexes +ExecCGI FollowSymLinks
AllowOverRide None
Satisfy Any
Order allow,deny
Allow from all

and tell apache about the directory where the RT source lives

Alias /RT/NoAuth/images/ /pathto/RT/share/html/NoAuth/images/
<Directory /pathto/RT/share/html/*>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
On Fri, Oct 4, 2013 at 9:37 AM, Max McGrath mmcgrath@carthage.edu wrote:

Thanks!

Tried moving to FastCgi and I now get:

You’re almost there!You haven’t yet configured your webserver to run RT.
You appear to have installed RT’s web interface correctly, but haven’t yet
configured your web server to “run” the RT server which powers the web
interface. The next step is to edit your webserver’s configuration file to
instruct it to use RT’s mod_perl or FastCGI handler. If you need
commercial support, please contact us at sales@bestpractical.com.

I’m definitely not a web server expert…so…any advice?

Max


Max McGrath
Network Administrator
Carthage College
262-552-5512
mmcgrath@carthage.edu

On Wed, Oct 2, 2013 at 10:53 PM, Alex Vandiver alexmv@bestpractical.comwrote:

On Wed, 2013-10-02 at 21:53 -0500, Max McGrath wrote:

Nope…definitely did that step: [snp]

Ah. Then the perl that your mod_perl is linked against is not the perl
that you configured RT with – did you recompile a newer perl to meet
the >= 5.10.1 dep, but not recompile mod_perl? Deploying with mod_fcgi
or mod_fastcgi is probably easier than upgrading mod_perl.

  • Alex


RT Training in New York, October 8th and 9th:
http://bestpractical.com/training

lenjaffe@jaffesystems.com 614-404-4214 @lenjaffe
Software Engineer, Founder Volunteerable http://www.volunteerable..com/,
Host of Columbus Code Jam http://www.meetup.com/techlifecolumbus/
www.lenjaffe.com http://www.theycomewithcheese.com
Perl Advent Planet http://www.lenjaffe.com/PerlAdventPlanet/ - Advent
Calendars: Perlish and otherwise.

Anything?On Fri, Oct 4, 2013 at 10:49 AM, Len Jaffe lenjaffe@jaffesystems.comwrote:

in httpd.conf ---- and this will depend on your version of apache, and
how you’ve structured your configurations files.

You need to load the fastcgi module

LoadModule fastcgi_module modules/mod_fastcgi.so

You need to declare your fastcgi service

FastCgiServer /pathto/RT/sbin/rt-server.fcgi -processes 5

-idle-timeout 30

your settings for processes and timeout will vary according to your load

Inside your virtual host definitions, tell apache how to handle fcgi
requests

 AddHandler fastcgi-script fcgi

Tell apache how to run the RT code

Alias /RT /pathto/RT/sbin/rt-server.fcgi/
<Directory /pathto/RT/sbin/*>
Options Indexes +ExecCGI FollowSymLinks
AllowOverRide None
Satisfy Any
Order allow,deny
Allow from all

and tell apache about the directory where the RT source lives

Alias /RT/NoAuth/images/ /pathto/RT/share/html/NoAuth/images/
<Directory /pathto/RT/share/html/*>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

On Fri, Oct 4, 2013 at 9:37 AM, Max McGrath mmcgrath@carthage.edu wrote:

Thanks!

Tried moving to FastCgi and I now get:

You’re almost there!You haven’t yet configured your webserver to run RT.
You appear to have installed RT’s web interface correctly, but haven’t yet
configured your web server to “run” the RT server which powers the web
interface. The next step is to edit your webserver’s configuration file to
instruct it to use RT’s mod_perl or FastCGI handler. If you need
commercial support, please contact us at sales@bestpractical.com.

I’m definitely not a web server expert…so…any advice?

Max


Max McGrath
Network Administrator
Carthage College
262-552-5512
mmcgrath@carthage.edu

On Wed, Oct 2, 2013 at 10:53 PM, Alex Vandiver alexmv@bestpractical.comwrote:

On Wed, 2013-10-02 at 21:53 -0500, Max McGrath wrote:

Nope…definitely did that step: [snp]

Ah. Then the perl that your mod_perl is linked against is not the perl
that you configured RT with – did you recompile a newer perl to meet
the >= 5.10.1 dep, but not recompile mod_perl? Deploying with mod_fcgi
or mod_fastcgi is probably easier than upgrading mod_perl.

  • Alex


RT Training in New York, October 8th and 9th:
http://bestpractical.com/training


lenjaffe@jaffesystems.com 614-404-4214 @lenjaffe
Software Engineer, Founder Volunteerable http://www.volunteerable..com/,
Host of Columbus Code Jam http://www.meetup.com/techlifecolumbus/
www.lenjaffe.com http://www.theycomewithcheese.com
Perl Advent Planet http://www.lenjaffe.com/PerlAdventPlanet/ - Advent
Calendars: Perlish and otherwise.

lenjaffe@jaffesystems.com 614-404-4214 @lenjaffe
Software Engineer, Founder Volunteerable http://www.volunteerable..com/,
Host of Columbus Code Jam http://www.meetup.com/techlifecolumbus/
www.lenjaffe.com http://www.theycomewithcheese.com
Perl Advent Planet http://www.lenjaffe.com/PerlAdventPlanet/ - Advent
Calendars: Perlish and otherwise.

Yeah…a co-worker of mine got it working. Sorry, I can’t be more clear on
what he did. He said it was a mixture of your suggestions and some other
things. Apache configurations are above my head…

But it’s working now!

Max McGrath
Network Administrator
Carthage College
262-552-5512
mmcgrath@carthage.eduOn Mon, Oct 7, 2013 at 3:26 PM, Len Jaffe lenjaffe@jaffesystems.com wrote:

Anything?

On Fri, Oct 4, 2013 at 10:49 AM, Len Jaffe lenjaffe@jaffesystems.comwrote:

in httpd.conf ---- and this will depend on your version of apache, and
how you’ve structured your configurations files.

You need to load the fastcgi module

LoadModule fastcgi_module modules/mod_fastcgi.so

You need to declare your fastcgi service

FastCgiServer /pathto/RT/sbin/rt-server.fcgi -processes 5

-idle-timeout 30

your settings for processes and timeout will vary according to your load

Inside your virtual host definitions, tell apache how to handle fcgi
requests

 AddHandler fastcgi-script fcgi

Tell apache how to run the RT code

Alias /RT /pathto/RT/sbin/rt-server.fcgi/
<Directory /pathto/RT/sbin/*>
Options Indexes +ExecCGI FollowSymLinks
AllowOverRide None
Satisfy Any
Order allow,deny
Allow from all

and tell apache about the directory where the RT source lives

Alias /RT/NoAuth/images/ /pathto/RT/share/html/NoAuth/images/
<Directory /pathto/RT/share/html/*>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

On Fri, Oct 4, 2013 at 9:37 AM, Max McGrath mmcgrath@carthage.eduwrote:

Thanks!

Tried moving to FastCgi and I now get:

You’re almost there!You haven’t yet configured your webserver to run
RT. You appear to have installed RT’s web interface correctly, but haven’t
yet configured your web server to “run” the RT server which powers the web
interface. The next step is to edit your webserver’s configuration file to
instruct it to use RT’s mod_perl or FastCGI handler. If you need
commercial support, please contact us at sales@bestpractical.com.

I’m definitely not a web server expert…so…any advice?

Max


Max McGrath
Network Administrator
Carthage College
262-552-5512
mmcgrath@carthage.edu

On Wed, Oct 2, 2013 at 10:53 PM, Alex Vandiver <alexmv@bestpractical.com wrote:

On Wed, 2013-10-02 at 21:53 -0500, Max McGrath wrote:

Nope…definitely did that step: [snp]

Ah. Then the perl that your mod_perl is linked against is not the perl
that you configured RT with – did you recompile a newer perl to meet
the >= 5.10.1 dep, but not recompile mod_perl? Deploying with mod_fcgi
or mod_fastcgi is probably easier than upgrading mod_perl.

  • Alex


RT Training in New York, October 8th and 9th:
http://bestpractical.com/training


lenjaffe@jaffesystems.com 614-404-4214 @lenjaffe
Software Engineer, Founder Volunteerable http://www.volunteerable..com/,
Host of Columbus Code Jam http://www.meetup.com/techlifecolumbus/
www.lenjaffe.com http://www.theycomewithcheese.com
Perl Advent Planet http://www.lenjaffe.com/PerlAdventPlanet/ - Advent
Calendars: Perlish and otherwise.


lenjaffe@jaffesystems.com 614-404-4214 @lenjaffe
Software Engineer, Founder Volunteerable http://www.volunteerable..com/,
Host of Columbus Code Jam http://www.meetup.com/techlifecolumbus/
www.lenjaffe.com http://www.theycomewithcheese.com
Perl Advent Planet http://www.lenjaffe.com/PerlAdventPlanet/ - Advent
Calendars: Perlish and otherwise.