Upgrade RT, what about plugin module?

Hi,

I am wondering if plugin would have problem if I perform general minor version upgrade on 4.0.x?

Recently we intensively use more and more plugin which I am not sure if it will drive the upgrade more complicated.

We are using RT-Extension-CommandByMail, RT-Extension-RepeatTicket and RT-Extension-SLA.

Hi,****


I am wondering if plugin would have problem if I perform general minor
version upgrade on 4.0.x?

They shouldn’t. We work hard not to break backwards compatibility in minor
versions and avoid database changes as much as possible.



Recently we intensively use more and more plugin which I am not sure if it
will drive the upgrade more complicated.****


We are using RT-Extension-CommandByMail, RT-Extension-RepeatTicket and
RT-Extension-SLA.

All these should work with recent versions of 4.0.x.



RT Training in Seattle, June 19-20: Training — Best Practical Solutions

Best regards, Ruslan.

Hi, Thanks for replying.

Does it means basically no extra step should do on plugin during minor version upgrade?From: ruslan.zakirov@gmail.com [mailto:ruslan.zakirov@gmail.com] On Behalf Of Ruslan Zakirov
Sent: Thursday, May 23, 2013 1:27 PM
To: Thomas Lau
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Upgrade RT, what about plugin module?

Hi,

I am wondering if plugin would have problem if I perform general minor version upgrade on 4.0.x?

They shouldn’t. We work hard not to break backwards compatibility in minor versions and avoid database changes as much as possible.

Recently we intensively use more and more plugin which I am not sure if it will drive the upgrade more complicated.

We are using RT-Extension-CommandByMail, RT-Extension-RepeatTicket and RT-Extension-SLA.

All these should work with recent versions of 4.0.x.

RT Training in Seattle, June 19-20: Training — Best Practical Solutions

Best regards, Ruslan.

Hi, Thanks for replying.****



Does it means basically no extra step should do on plugin during minor
version upgrade?

Shouldn’t be. Create a dev environment where you can play with things and
you will be more confident.



From: ruslan.zakirov@gmail.com [mailto:ruslan.zakirov@gmail.com] On
Behalf Of Ruslan Zakirov
Sent: Thursday, May 23, 2013 1:27 PM
To: Thomas Lau
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Upgrade RT, what about plugin module?
**


wrote:****

Hi,****


I am wondering if plugin would have problem if I perform general minor
version upgrade on 4.0.x?****


They shouldn’t. We work hard not to break backwards compatibility in minor
versions and avoid database changes as much as possible.****



Recently we intensively use more and more plugin which I am not sure if it
will drive the upgrade more complicated.****


We are using RT-Extension-CommandByMail, RT-Extension-RepeatTicket and
RT-Extension-SLA.****


All these should work with recent versions of 4.0.x.****



RT Training in Seattle, June 19-20: Training — Best Practical Solutions****




Best regards, Ruslan. ****


RT Training in Seattle, June 19-20: Training — Best Practical Solutions

Best regards, Ruslan.