Upgrade Question

Hey All,

I just did an upgrade from RT3.0.4 to 3.0.6 and saw this at the end of the
make upgrade:

    Congratulations. RT has been upgraded. You should now check-over
    /usr/local/rt3/etc/RT_Config.pm for any necessary site

customization. Additionally,
you should update RT’s system database objects by running
ls etc/upgrade
For each file in that directory whose name is greater than
your previously installed RT version, run:
/usr/local/rt3/sbin/rt-setup-database --action
insert --datafile etc/upgrade/

I got the check-over RT_Config.pm part, but I don’t get the rest!! What do
I need to do here??

Thanks

Steve

At 06:15 PM 10/1/2003, Stevo wrote:

Additionally,
you should update RT’s system database objects by running
ls etc/upgrade
For each file in that directory whose name is greater than
your previously installed RT version, run:
/usr/local/rt3/sbin/rt-setup-database --action
insert --datafile etc/upgrade/

I got the check-over RT_Config.pm part, but I don’t get the rest!! What do
I need to do here??

From within the untarred 3.0.6 directory type ls etc/upgrade.

It’s going to list a file for 2.x.x (don’t have a connection to my RT box
at the moment so I don’t have the exact version). In this case you don’t
have to do anything. But, if it had listed a newer version, 3.0.5 for
example, you would run the rt-setup-database script passing in that
version’s data file.

Michael

Michael S. Liebman m-liebman@northwestern.edu
http://msl521.freeshell.org/
“I have vision and the rest of the world wears bifocals.”
-Paul Newman in “Butch Cassidy & the Sundance Kid”

Steve, there is new configuration variables went into RT_Config.pm.
You just have to look through it, and may be override with RT_SiteConfig.pm.

Stevo wrote:

Okay so I did a ls /etc/upgrade and got 2.1.71. So I don’t have to do
anything?? What’s that number mean?

StevoFrom: “Michael S. Liebman” m-liebman@northwestern.edu
To: “Stevo” checkpoint@ozbergs.com; rt-users@lists.fsck.com
Sent: Wednesday, October 01, 2003 7:49 PM
Subject: Re: [rt-users] Upgrade Question

At 06:15 PM 10/1/2003, Stevo wrote:

Additionally,
you should update RT’s system database objects by running
ls etc/upgrade
For each file in that directory whose name is greater than
your previously installed RT version, run:
/usr/local/rt3/sbin/rt-setup-database --action
insert --datafile etc/upgrade/

I got the check-over RT_Config.pm part, but I don’t get the rest!! What
do

I need to do here??

From within the untarred 3.0.6 directory type ls etc/upgrade.

It’s going to list a file for 2.x.x (don’t have a connection to my RT box
at the moment so I don’t have the exact version). In this case you don’t
have to do anything. But, if it had listed a newer version, 3.0.5 for
example, you would run the rt-setup-database script passing in that
version’s data file.

Michael


Michael S. Liebman m-liebman@northwestern.edu
http://msl521.freeshell.org/
“I have vision and the rest of the world wears bifocals.”
-Paul Newman in “Butch Cassidy & the Sundance Kid”

Okay so I did a ls /etc/upgrade and got 2.1.71. So I don’t have to do
anything?? What’s that number mean?

If you’re upgrading from before 2.1.71, it’s new database-based
configuration.

-jesse

Stevo

----- Original Message -----
From: “Michael S. Liebman” m-liebman@northwestern.edu
To: “Stevo” checkpoint@ozbergs.com; rt-users@lists.fsck.com
Sent: Wednesday, October 01, 2003 7:49 PM
Subject: Re: [rt-users] Upgrade Question

At 06:15 PM 10/1/2003, Stevo wrote:

Additionally,
you should update RT’s system database objects by running
ls etc/upgrade
For each file in that directory whose name is greater than
your previously installed RT version, run:
/usr/local/rt3/sbin/rt-setup-database --action
insert --datafile etc/upgrade/

I got the check-over RT_Config.pm part, but I don’t get the rest!! What
do

I need to do here??

From within the untarred 3.0.6 directory type ls etc/upgrade.

It’s going to list a file for 2.x.x (don’t have a connection to my RT box
at the moment so I don’t have the exact version). In this case you don’t
have to do anything. But, if it had listed a newer version, 3.0.5 for
example, you would run the rt-setup-database script passing in that
version’s data file.

Michael


Michael S. Liebman m-liebman@northwestern.edu
http://msl521.freeshell.org/
“I have vision and the rest of the world wears bifocals.”
-Paul Newman in “Butch Cassidy & the Sundance Kid”


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.