Upgrade broke RT

Let me say first, I know I was stupid and am solely at fault for this. I
should have been more careful when reading the README. But, nevertheless, I
need some help.

I had a perfectly good install of RT 3.0.5 working with the latest RTFM and
RTStats. I am using Apache2 with FastCGI.

And so, last night I decided to upgrade to 3.0.11 and failed to see the note
in the README about it requiring Perl 5.8.3. Since I am using RH 9, I only
had 5.8.0.

So…I ran the make upgrade, restarted apache and I get Error 500. I then
saw the Perl requirement, reinstalled perl from source with 5.8.4 and
reinstalled all the perl modules, successfully, or at least I thought.

Still Error 500. So I reinstalled FastCGI. Still Error 500.

When I start apache I get a couple:

[error] Can’t locate Apache.pm in @INC
[error] Can’t locate Apache.pm in @INC

I’m trying to install the Apache Bundle now from CPAN, but having problems.

When I try to go to RT I get:

[error] [client 137.218.6.19] FastCGI: comm with server
"/opt/rt3/bin/mason_handler.fcgi" aborted: idle timeout (30 sec)
[error] [client 137.218.6.19] FastCGI: incomplete headers (0 bytes) received
from server “/opt/rt3/bin/mason_handler.fcgi”

What’s going on?? I need RT back up badly.

Thanks,
Bryan

I also get a:

[notice] Apache/2.0.40 (Red Hat Linux) configured – resuming normal
operations
Can’t locate /opt/rt3/etc/RT_SiteConfig.pm in @INC (@INC contains:
/opt/rt3/local/lib /opt/rt3/lib /usr/local/lib/perl5
/5.8.4/i686-linux /usr/local/lib/perl5/5.8.4
/usr/local/lib/perl5/site_perl/5.8.4/i686-linux /usr/local/lib/perl5/site_
perl/5.8.4 /usr/local/lib/perl5/site_perl .) at /opt/rt3/lib/RT.pm line 105.
Compilation failed in require at /opt/rt3/bin/mason_handler.fcgi line 28.From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Bryan
Pennington
Sent: Wednesday, June 30, 2004 8:09 AM
To: RT-Users@lists.bestpractical.com
Subject: [rt-users] Upgrade broke RT

Let me say first, I know I was stupid and am solely at fault for this. I
should have been more careful when reading the README. But, nevertheless, I
need some help.

I had a perfectly good install of RT 3.0.5 working with the latest RTFM and
RTStats. I am using Apache2 with FastCGI.

And so, last night I decided to upgrade to 3.0.11 and failed to see the note
in the README about it requiring Perl 5.8.3. Since I am using RH 9, I only
had 5.8.0.

So…I ran the make upgrade, restarted apache and I get Error 500. I then
saw the Perl requirement, reinstalled perl from source with 5.8.4 and
reinstalled all the perl modules, successfully, or at least I thought.

Still Error 500. So I reinstalled FastCGI. Still Error 500.

When I start apache I get a couple:

[error] Can’t locate Apache.pm in @INC
[error] Can’t locate Apache.pm in @INC

I’m trying to install the Apache Bundle now from CPAN, but having problems.

When I try to go to RT I get:

[error] [client 137.218.6.19] FastCGI: comm with server
“/opt/rt3/bin/mason_handler.fcgi” aborted: idle timeout (30 sec)
[error] [client 137.218.6.19] FastCGI: incomplete headers (0 bytes) received
from server “/opt/rt3/bin/mason_handler.fcgi”

What’s going on?? I need RT back up badly.

Thanks,
Bryan

Your apache process doesn’t have rights to read RT_SiteConfig.pm
while upgrade you’ve done mistake with ‘–with-web-user’ and
’–with-web-group’ conigure options.

Bryan Pennington wrote: