Undefined subroutine &Scalar::Util::weaken breaking scrips

Hello,

Thanks to Stephen Turner, I think I uncovered the source of the
problem relating to my scrips no longer working. I thought that this
deserved a thread of its own with a more descriptive subject line
where we can delve deeper into this…

Doing a Google search on this reveals the following, but no
resolution posted at that time:

http://lists.fsck.com/pipermail/rt-users/2004-December/027776.html
http://lists.fsck.com/pipermail/rt-users/2004-December/027782.html

Here are the error messages as they appear in my logs. This was not a
problem in the past, something must have changed to cause this (still
trying to track down the source of this problem):

Thanks in advance for your help!

[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: Use of uninitialized
value in substitution (s///) at /opt/rt3/lib/RT/Interface/Web.pm line
617., referer: https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [Thu Sep 28 17:52:54
2006] [error]: Scrip Prepare 1 died. - Undefined subroutine
&Scalar::Util::weaken called at /opt/rt3/lib/RT/Action/Generic.pm
line 107., referer: https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: Stack:, referer:
https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Action/Generic.pm:107], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Action/Generic.pm:79], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
ScripAction_Overlay.pm:177], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Scrip_Overlay.pm:472], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Scrips_Overlay.pm:237], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Transaction_Overlay.pm:171], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Record.pm:1446], referer: https://my domain/rt/Ticket/Display.html?
id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Ticket_Overlay.pm:2442], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Ticket_Overlay.pm:2356], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/Ticket/Elements/PreviewScrips:82], referer: https://my domain/
rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/Ticket/Update.html:137], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/autohandler:279] (/opt/rt3/lib/RT/Scrip_Overlay.pm:480),
referer: https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [Thu Sep 28 17:52:54
2006] [error]: Scrip Prepare 5 died. - Undefined subroutine
&Scalar::Util::weaken called at /opt/rt3/lib/RT/Action/Generic.pm
line 107., referer: https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: Stack:, referer:
https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Action/Generic.pm:107], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Action/Generic.pm:79], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
ScripAction_Overlay.pm:177], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Scrip_Overlay.pm:472], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Scrips_Overlay.pm:237], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Transaction_Overlay.pm:171], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Record.pm:1446], referer: https://my domain/rt/Ticket/Display.html?
id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Ticket_Overlay.pm:2442], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Ticket_Overlay.pm:2356], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/Ticket/Elements/PreviewScrips:82], referer: https://my domain/
rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/Ticket/Update.html:137], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/autohandler:279] (/opt/rt3/lib/RT/Scrip_Overlay.pm:480),
referer: https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [Thu Sep 28 17:52:54
2006] [error]: Scrip Prepare 6 died. - Undefined subroutine
&Scalar::Util::weaken called at /opt/rt3/lib/RT/Action/Generic.pm
line 107., referer: https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: Stack:, referer:
https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Action/Generic.pm:107], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Action/Generic.pm:79], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
ScripAction_Overlay.pm:177], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Scrip_Overlay.pm:472], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Scrips_Overlay.pm:237], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Transaction_Overlay.pm:171], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:54 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Record.pm:1446], referer: https://my domain/rt/Ticket/Display.html?
id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Ticket_Overlay.pm:2442], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Ticket_Overlay.pm:2356], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/Ticket/Elements/PreviewScrips:82], referer: https://my domain/
rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/Ticket/Update.html:137], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/autohandler:279] (/opt/rt3/lib/RT/Scrip_Overlay.pm:480),
referer: https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [Thu Sep 28 17:52:55
2006] [error]: Scrip Prepare 7 died. - Undefined subroutine
&Scalar::Util::weaken called at /opt/rt3/lib/RT/Action/Generic.pm
line 107., referer: https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: Stack:, referer:
https://my domain/rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Action/Generic.pm:107], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Action/Generic.pm:79], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
ScripAction_Overlay.pm:177], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Scrip_Overlay.pm:472], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Scrips_Overlay.pm:237], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Transaction_Overlay.pm:171], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Record.pm:1446], referer: https://my domain/rt/Ticket/Display.html?
id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Ticket_Overlay.pm:2442], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/lib/RT/
Ticket_Overlay.pm:2356], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/Ticket/Elements/PreviewScrips:82], referer: https://my domain/
rt/Ticket/Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/Ticket/Update.html:137], referer: https://my domain/rt/Ticket/
Display.html?id=185
[Thu Sep 28 13:52:55 2006] [error] [client ip address] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [/opt/rt3/share/
html/autohandler:279] (/opt/rt3/lib/RT/Scrip_Overlay.pm:480),
referer: https://my domain/rt/Ticket/Display.html?id=185

Joe Auty
UITS Messaging
Indiana University
jauty@indiana.edu

PGP.sig (186 Bytes)

Hello,

Thanks to Stephen Turner, I think I uncovered the source of the
problem relating to my scrips no longer working. I thought that this
deserved a thread of its own with a more descriptive subject line
where we can delve deeper into this…

You need to install Scalar::Util and make sure it installs the version
that requires a C compiler and comes with ‘weaken’

-jesse

Hello,

Thanks to Stephen Turner, I think I uncovered the source of the
problem relating to my scrips no longer working. I thought that this
deserved a thread of its own with a more descriptive subject line
where we can delve deeper into this…

You need to install Scalar::Util and make sure it installs the version
that requires a C compiler and comes with ‘weaken’

I used the version off of CPAN via a simple “install Scalar::Util”,
make testdeps in the RT source dir says the following:

<snipped…>
Scalar::Util…found
<snipped…>

Any ideas where and how I should get the copy of Scalar::Util I need?

Much thanks in advance!

Joe Auty
UITS Messaging
Indiana University
jauty@indiana.edu

PGP.sig (186 Bytes)

Never mind… fixed it! Installed Scalar::Util by hand.

Maybe some Redhat RPM that was upgraded included a different version
of Scalar::Util?On Sep 28, 2006, at 2:30 PM, Joe Auty wrote:

On Sep 28, 2006, at 2:24 PM, Jesse Vincent wrote:

On Thu, Sep 28, 2006 at 02:21:04PM -0400, Joe Auty wrote:

Hello,

Thanks to Stephen Turner, I think I uncovered the source of the
problem relating to my scrips no longer working. I thought that this
deserved a thread of its own with a more descriptive subject line
where we can delve deeper into this…

You need to install Scalar::Util and make sure it installs the
version
that requires a C compiler and comes with ‘weaken’

I used the version off of CPAN via a simple “install Scalar::Util”,
make testdeps in the RT source dir says the following:

<snipped…>
Scalar::Util…found
<snipped…>

Any ideas where and how I should get the copy of Scalar::Util I need?

Much thanks in advance!


Joe Auty
UITS Messaging
Indiana University
jauty@indiana.edu


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Joe Auty
UITS Messaging
Indiana University
jauty@indiana.edu

PGP.sig (186 Bytes)

Thanks Joe for putting this out there, had the same issue this morning after
RHEL4 update 3 --> update 4 and 3.6.0 --> 3.6.1 patches
Made the fix quick and easy.

We use fastcgi here and I have found that I alway need to make sure
apache owns all log directories and files after any httpd update from
Red Hat.

Other then these two items upgrades have been painless, thanks again all.

Joe Auty wrote:

Never mind… fixed it! Installed Scalar::Util by hand.

Maybe some Redhat RPM that was upgraded included a different version
of Scalar::Util?

Hello,

Thanks to Stephen Turner, I think I uncovered the source of the
problem relating to my scrips no longer working. I thought that this
deserved a thread of its own with a more descriptive subject line
where we can delve deeper into this…

You need to install Scalar::Util and make sure it installs the version
that requires a C compiler and comes with ‘weaken’

I used the version off of CPAN via a simple “install Scalar::Util”,
make testdeps in the RT source dir says the following:

<snipped…>
Scalar::Util…found
<snipped…>

Any ideas where and how I should get the copy of Scalar::Util I need?

Much thanks in advance!


Joe Auty
UITS Messaging
Indiana University
jauty@indiana.edu mailto:jauty@indiana.edu


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com
mailto:sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Joe Auty
UITS Messaging
Indiana University
jauty@indiana.edu mailto:jauty@indiana.edu



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

John McCoy, Jr
Sr. Systems and Network Administrator
Enterprise Technology Services
Golden Gate University
415-442-6560

Hello all,

I’ve followed the wiki guide to install several times and finally found
the right configuration to make RT 3.6.1 work. I’ve tried adding SSL but
have not been able to. I recently read that SSL cannot be installed via
virtual hosts (which is how the installation guide installs RT). Has
anyone configured RT for SSL communications? If so, can you please
provide some guidance.

Roberto Carvajal

University of Miami

IT Security

305-986-3398

Has
anyone configured RT for SSL communications? If so, can you please
provide some guidance.

Roberto,

I took the easy way out and used apache-ssl on my Linux server. The box
is dedicated to RT so it was quite easy to set up. I’m still working on
getting non-secure URLs to redirect to the secure ones transparently.
I’ve tried several different mod_rewrite approaches without success.

-Tim

Tim Wilson, Director of Technology
Buffalo-Hanover-Montrose Schools
214 1st Ave NE Buffalo, MN 55313
ph: 763.682.8740 fax: 763.682.8743 http://www.buffalo.k12.mn.us

Has
anyone configured RT for SSL communications? If so, can you please
provide some guidance.

Roberto,

I took the easy way out and used apache-ssl on my Linux
server. The box
is dedicated to RT so it was quite easy to set up. I’m still
working on
getting non-secure URLs to redirect to the secure ones transparently.
I’ve tried several different mod_rewrite approaches without success.

-Tim

How about this?

RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [NC,R,L]

Eric Schultz
United Online, Inc.

Now the page says “You’re Almost there!”-----Original Message-----
From: Schultz, Eric [mailto:ESchultz@corp.untd.com]
Sent: Thursday, November 09, 2006 1:58 PM
To: Tim Wilson; RT-Users@lists.bestpractical.com; Carvajal, Roberto A.
Subject: RE: [rt-users] Apache SSL for RT 3.6.1

Has
anyone configured RT for SSL communications? If so, can you please
provide some guidance.

Roberto,

I took the easy way out and used apache-ssl on my Linux
server. The box
is dedicated to RT so it was quite easy to set up. I’m still
working on
getting non-secure URLs to redirect to the secure ones transparently.
I’ve tried several different mod_rewrite approaches without success.

-Tim

How about this?

RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [NC,R,L]

Eric Schultz
United Online, Inc.

I’m still
working on
getting non- secure URLs to redirect to the secure ones
transparently.

I’ve tried several different mod_rewrite approaches without
success.

  • Tim

How about this?

RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [NC,R,L]

Eric,

Thanks for the suggestion. Unfortunately that doesn’t work either.
Firefox tells me that it can’t connect when I use a URL like
http://example.com/rt/

Any other ideas?

-Tim

Tim Wilson, Director of Technology
Buffalo-Hanover-Montrose Schools
214 1st Ave NE Buffalo, MN 55313
ph: 763.682.8740 fax: 763.682.8743 http://www.buffalo.k12.mn.us

I’m still
working on
getting non- secure URLs to redirect to the secure ones
transparently.

I’ve tried several different mod_rewrite approaches without
success.

  • Tim

How about this?

RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [NC,R,L]

Eric,

Thanks for the suggestion. Unfortunately that doesn’t work either.
Firefox tells me that it can’t connect when I use a URL like
http://example.com/rt/

Any other ideas?

Sorry, the rest of your apache configuration (or RT configuration) could
be screwing things up. This is one of those things you will likely have
to plug through and figure out yourself, unless you can have someone
with a lot more free time than I have look over your configs.

Eric Schultz
United Online, Inc.

I’m still
working on
getting non- secure URLs to redirect to the secure ones
transparently.

I’ve tried several different mod_rewrite approaches without
success.

I recently set up RT with SSL. You can do SSL with virtual hosts, but
each SSL host has to have its own dedicated IP address (you can’t do
name-based virtual hosts with SSL).

Here’s how I did it:

<VirtualHost 10.41.16.118:80 >
ServerName myrt.mydomain.com
RedirectMatch permanent (/.*) https://myrt.mydomain.com$1

<VirtualHost 10.41.16.118:443>
ServerName myrt.mydomain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

	 SSLEngine on
	 SSLCertificateFile "/etc/httpd/conf/ssl.crt/rt.crt"
 SSLCertificateKeyFile "/etc/httpd/conf/ssl.key/rt.key"

    PerlModule Apache::DBI
    PerlRequire /opt/rt3/bin/webmux.pl

    <Location />
            SetHandler perl-script
            PerlHandler RT::Mason
    </Location>

Alias /NoAuth /opt/rt3/local/html/NoAuth
<Directory /opt/rt3/local/html/NoAuth>
Options +FollowSymLinks +Indexes
Order allow,deny
Allow from all

<Location /REST/1.0/NoAuth>
satisfy any
allow from all

<Location /NoAuth>
satisfy any
allow from all

<Location /NoAuth/images>
SetHandler default-handler

And then you need to make sure the stuff in RT_SiteConfig.pm isn’t
making URLs like http://myrt.mydomain.com/rt or something.

Set($WebPath , “”);
Set($WebBaseURL , “https://myrt.mydomain.com”);

Hi,

 When i did this, i was taken to another application running on apache

root.
Here is the case, i have an application running on port 80 and RT
running on 8080. In the RT’s virtual host, i tried to forward everything to
port 443 but the page is going to the other application on root. When i
tried to forward to some no standard port like 8446, it is working.

How do i solve this problem? I want the application in root to run on http
and RT on ssl.

Any ideas?

Thanks and Regards
Sujith EmmanuelOn 11/10/06, Vonnahme, Nathan nathan.vonnahme@bannerhealth.com wrote:

I recently set up RT with SSL. You can do SSL with virtual hosts, but
each SSL host has to have its own dedicated IP address (you can’t do
name-based virtual hosts with SSL).

Here’s how I did it:

<VirtualHost 10.41.16.118:80 >
ServerName myrt.mydomain.com
RedirectMatch permanent (/.*) https://myrt.mydomain.com$1

<VirtualHost 10.41.16.118:443>
ServerName myrt.mydomain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

     SSLEngine on
     SSLCertificateFile "/etc/httpd/conf/ssl.crt/rt.crt"
     SSLCertificateKeyFile "/etc/httpd/conf/ssl.key/rt.key"

    PerlModule Apache::DBI
    PerlRequire /opt/rt3/bin/webmux.pl

    <Location />
            SetHandler perl-script
            PerlHandler RT::Mason
    </Location>

Alias /NoAuth /opt/rt3/local/html/NoAuth
<Directory /opt/rt3/local/html/NoAuth>
Options +FollowSymLinks +Indexes
Order allow,deny
Allow from all

<Location /REST/1.0/NoAuth>
satisfy any
allow from all

<Location /NoAuth>
satisfy any
allow from all

<Location /NoAuth/images>
SetHandler default-handler

And then you need to make sure the stuff in RT_SiteConfig.pm isn’t
making URLs like http://myrt.mydomain.com/rt or something.

Set($WebPath , “”);
Set($WebBaseURL , “https://myrt.mydomain.com”);

You don’t want anything else running on port 443? That should be
simple then. You don’t need any rewriting or forwarding at all. Take out
RT, and get apache to respond to some “hello world” text file on port 443.
Once you get that working, then put RT back in.On Fri, 10 Nov 2006, Sujith Emmanuel wrote:

Hi,

When i did this, i was taken to another application running on apache
root.
Here is the case, i have an application running on port 80 and RT
running on 8080. In the RT’s virtual host, i tried to forward everything to
port 443 but the page is going to the other application on root. When i
tried to forward to some no standard port like 8446, it is working.

How do i solve this problem? I want the application in root to run on http
and RT on ssl.

Any ideas?

Thanks and Regards
Sujith Emmanuel

On 11/10/06, Vonnahme, Nathan nathan.vonnahme@bannerhealth.com wrote:

I recently set up RT with SSL. You can do SSL with virtual hosts, but
each SSL host has to have its own dedicated IP address (you can’t do
name-based virtual hosts with SSL).

Here’s how I did it:

<VirtualHost 10.41.16.118:80 >
ServerName myrt.mydomain.com
RedirectMatch permanent (/.*) https://myrt.mydomain.com$1

<VirtualHost 10.41.16.118:443>
ServerName myrt.mydomain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

     SSLEngine on
     SSLCertificateFile "/etc/httpd/conf/ssl.crt/rt.crt"
     SSLCertificateKeyFile "/etc/httpd/conf/ssl.key/rt.key"

    PerlModule Apache::DBI
    PerlRequire /opt/rt3/bin/webmux.pl

    <Location />
            SetHandler perl-script
            PerlHandler RT::Mason
    </Location>

Alias /NoAuth /opt/rt3/local/html/NoAuth
<Directory /opt/rt3/local/html/NoAuth>
Options +FollowSymLinks +Indexes
Order allow,deny
Allow from all

<Location /REST/1.0/NoAuth>
satisfy any
allow from all

<Location /NoAuth>
satisfy any
allow from all

<Location /NoAuth/images>
SetHandler default-handler

And then you need to make sure the stuff in RT_SiteConfig.pm isn’t
making URLs like http://myrt.mydomain.com/rt or something.

Set($WebPath , “”);
Set($WebBaseURL , “https://myrt.mydomain.com”);

Actually RT was running over http for some months, recently we made it
public and hence we need to serve it over ssl. Initial port was 8080 as the
other application was running on apache root. Then we used the rewrite rule
to shift to 443 but it was not working, hence moved to another port 8446
which was working fine. So old users typing 8080 will be taken to port 8446
now. i wanted to make the port for RT 443 so that there need not be any
extra rules in firewall, which somehow seems messed up.

Sorry for the confusion.

Thanks and Regards
Sujith EmmanuelOn 11/10/06, Jon Daley < bestpractical@jon.limedaley.com> wrote:

    You don't want anything else running on port 443?  That should be

simple then. You don’t need any rewriting or forwarding at all. Take out
RT, and get apache to respond to some “hello world” text file on port 443.
Once you get that working, then put RT back in.

On Fri, 10 Nov 2006, Sujith Emmanuel wrote:

Hi,

When i did this, i was taken to another application running on apache
root.
Here is the case, i have an application running on port 80 and RT
running on 8080. In the RT’s virtual host, i tried to forward everything
to
port 443 but the page is going to the other application on root. When i
tried to forward to some no standard port like 8446, it is working.

How do i solve this problem? I want the application in root to run on
http
and RT on ssl.

Any ideas?

Thanks and Regards
Sujith Emmanuel

BRILLIANT Nathan!

Works like a charm. I kept reading everywhere that you couldn’t do it
using virtual hosts. But this worked perfectly!

I can’t express how appreciative I am.

-RobertFrom: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Vonnahme,
Nathan
Sent: Thursday, November 09, 2006 9:40 PM
To: RT-Users@lists.bestpractical.com
Subject: RE: [rt-users] Apache SSL for RT 3.6.1

I’m still
working on
getting non- secure URLs to redirect to the secure ones
transparently.

I’ve tried several different mod_rewrite approaches without
success.

I recently set up RT with SSL. You can do SSL with virtual hosts, but
each SSL host has to have its own dedicated IP address (you can’t do
name-based virtual hosts with SSL).

Here’s how I did it:

<VirtualHost 10.41.16.118:80 >
ServerName myrt.mydomain.com
RedirectMatch permanent (/.*) https://myrt.mydomain.com$1

<VirtualHost 10.41.16.118:443>
ServerName myrt.mydomain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

	 SSLEngine on
	 SSLCertificateFile "/etc/httpd/conf/ssl.crt/rt.crt"
 SSLCertificateKeyFile "/etc/httpd/conf/ssl.key/rt.key"

    PerlModule Apache::DBI
    PerlRequire /opt/rt3/bin/webmux.pl

    <Location />
            SetHandler perl-script
            PerlHandler RT::Mason
    </Location>

Alias /NoAuth /opt/rt3/local/html/NoAuth
<Directory /opt/rt3/local/html/NoAuth>
Options +FollowSymLinks +Indexes
Order allow,deny
Allow from all

<Location /REST/1.0/NoAuth>
satisfy any
allow from all

<Location /NoAuth>
satisfy any
allow from all

<Location /NoAuth/images>
SetHandler default-handler

And then you need to make sure the stuff in RT_SiteConfig.pm isn’t
making URLs like http://myrt.mydomain.com/rt or something.

Set($WebPath , “”);
Set($WebBaseURL , “https://myrt.mydomain.com”);

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Sounds like you need to have at least three virtualHost sections,
because you have 3 hosts:

  1. server.mydomain.com (port 80) = your old app
  2. server.mydomain.com:8080 = redirects to RT
  3. https://server.mydomain.com (port 443) = RT

So,

<VirtualHost 10.41.16.118:80 >

ServerName server.mydomain.com

** your "other" app's stuff goes here

<VirtualHost 10.41.16.118:8080 >

ServerName  server.mydomain.com

RedirectMatch permanent (/.*) https://server.mydomain.com$1

https://server.mydomain.com$1

<VirtualHost 10.41.16.118:443>

ServerName server.mydomain.com

** SSL directives here

** RT stuff here

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Sujith
Emmanuel
Sent: Friday, November 10, 2006 3:55 AM
To: RT-Users@lists.bestpractical.com
Subject: Fwd: [rt-users] Apache SSL for RT 3.6.1

Actually RT was running over http for some months, recently we

made it public and hence we need to serve it over ssl. Initial port was
8080 as the other application was running on apache root. Then we used
the rewrite rule to shift to 443 but it was not working, hence moved to
another port 8446 which was working fine. So old users typing 8080 will
be taken to port 8446 now. i wanted to make the port for RT 443 so that
there need not be any extra rules in firewall, which somehow seems
messed up.

Sorry for the confusion.

Thanks and Regards
Sujith Emmanuel





	        You don't want anything else running on port

443? That should be
simple then. You don’t need any rewriting or forwarding
at all. Take out
RT, and get apache to respond to some “hello world” text
file on port 443.
Once you get that working, then put RT back in.

	> Hi,
	>
	>    When i did this, i was taken to another application

running on apache
> root.
> Here is the case, i have an application running on
port 80 and RT
> running on 8080. In the RT’s virtual host, i tried to
forward everything to
> port 443 but the page is going to the other
application on root. When i
> tried to forward to some no standard port like 8446,
it is working.
>
> How do i solve this problem? I want the application in
root to run on http
> and RT on ssl.
>
> Any ideas?
>
> Thanks and Regards
> Sujith Emmanuel

Thank you for the reply, seems like the only thing missing is the
virtualhost for port 80. Since the old app was running on server root, we
had not specified any virtualhost for that. Lets see, if this helps by
putting it in a separate container.

Thanks again.

Thanks and Regards
Sujith EmmanuelOn 11/14/06, Vonnahme, Nathan nathan.vonnahme@bannerhealth.com wrote:

Sounds like you need to have at least three virtualHost sections, because
you have 3 hosts:

  1. server.mydomain.com (port 80) = your old app
  2. server.mydomain.com:8080 = redirects to RT
  3. https://server.mydomain.com (port 443) = RT

So,

<VirtualHost 10.41.16.118:80 >

ServerName server.mydomain.com

** your “other” app’s stuff goes here

<VirtualHost 10.41.16.118:8080 >

ServerName server.mydomain.com

RedirectMatch permanent (/.*) https://server.mydomain.com$1

*https://server.mydomain.com$1

<VirtualHost 10.41.16.118:443>
*

ServerName server.mydomain.com

** SSL directives here

** RT stuff here


From: rt-users-bounces@lists.bestpractical.com [mailto:
rt-users-bounces@lists.bestpractical.com] *On Behalf Of *Sujith Emmanuel
Sent: Friday, November 10, 2006 3:55 AM
To: RT-Users@lists.bestpractical.com
Subject: Fwd: [rt-users] Apache SSL for RT 3.6.1

Actually RT was running over http for some months, recently we made it
public and hence we need to serve it over ssl. Initial port was 8080 as the
other application was running on apache root. Then we used the rewrite rule
to shift to 443 but it was not working, hence moved to another port 8446
which was working fine. So old users typing 8080 will be taken to port 8446
now. i wanted to make the port for RT 443 so that there need not be any
extra rules in firewall, which somehow seems messed up.

Sorry for the confusion.

Thanks and Regards
Sujith Emmanuel

On 11/10/06, Jon Daley < bestpractical@jon.limedaley.com> wrote:

    You don't want anything else running on port 443?  That should

be
simple then. You don’t need any rewriting or forwarding at all. Take
out
RT, and get apache to respond to some “hello world” text file on port
443.
Once you get that working, then put RT back in.

On Fri, 10 Nov 2006, Sujith Emmanuel wrote:

Hi,

When i did this, i was taken to another application running on
apache
root.
Here is the case, i have an application running on port 80 and RT
running on 8080. In the RT’s virtual host, i tried to forward
everything to
port 443 but the page is going to the other application on root. When
i
tried to forward to some no standard port like 8446, it is working.

How do i solve this problem? I want the application in root to run on
http
and RT on ssl.

Any ideas?

Thanks and Regards
Sujith Emmanuel


This message has been scanned for viruses and
dangerous content by MailScanner http://www.mailscanner.info/, and is
believed to be clean.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com