Unable to Sync AD with LDAP RT 5.0.1

I’m new here, we needed a ticketing system in the company and I came across RT.
I managed to install everything and start to understand how RT works.
One of the first things I would like to do is configure rt-ldapimport to have all users of our AD.
I don’t necessarily need to log in via ldap, since we thought we would open the staff tickets from the intranet connected via API, and only the technicians use the RT web interface.

Following the documentation I tried to run the sync test but the answer is the following:

Unable to run rt-ldapimport without dependencies.
Rerun configure with the --enable-externalauth option.

I have not found anywhere a reference to “enabling externalauth” and above all to “Rerun configure”

I also leave my RT_SiteConfig.pm file below (omitting the initail comment)

###Basic config###

Set( $rtname, 'rt.mycompany.it');

Set( $Organization, 'mycompany.it');

Set( $Timezone, 'Europe/Rome');

Set( $WebDomain, '');

Set( $MailCommand, 'sendmailpipe');

Set( $CorrespondAddress, 'noreply-rt@mycompany.it');

Set( $SetOutgoingMailFrom, 'noreplay-rt');

###LDAP import config###




    Set($LDAPBase, 'DC=company,OU=location,OU=groups');

    Set($LDAPFilter, '(&(cn = users))');

    Set($LDAPMapping, {Name         => 'sAMAccountName',

                       EmailAddress => 'mail',

                       RealName     => 'cn',

                       WorkPhone    => 'telephoneNumber',

                       Organization => 'departmentName'});

    # If you want to sync Groups from LDAP into RT

    Set($LDAPGroupBase, 'DC=company,OU=location,OU=groups');

    Set($LDAPGroupFilter, '(&(cn = Groups))');

    Set($LDAPGroupMapping, {Name               => 'cn',

                            Member_Attr        => 'member',

                            Member_Attr_Value  => 'dn' });

thanks in advance to anyone who can help me

There are additional System/Perl dependencies that are required when you want to use the external auth feature.

When you originally ran ./configure from the RT 5 source directory thats where you can include the enable external auth flag:

 ./configure --enable-externalauth

Then when you re-run make fixdeps RT will go and install/check that the external auth deps are met

Thanks knation for the reply.

I relaunched the ./configure with the correct parameters and redone the RT installation.

It would seem to work.