Unable to response from rt

Hello,

my configuration.

rt-3.0.7
qmail-sql

so i have in dotqmail table

INSERT INTO dotqmails VALUES (‘alias’, ‘pinco.pl’, ‘tech2’, ‘|
/var/qmail/bin/preline /usr/local/rt3/bin/rt-mailgate --queue tech
–action correspond --url http://pinco.pl:8080’);
INSERT INTO dotqmails VALUES (‘alias’, ‘pinco.pl’, ‘tech2-comment’, ‘|
/var/qmail/bin/preline /usr/local/rt3/bin/rt-mailgate --queue tech
–action comment --url http://pinco.pl:8080 --debug’);

i think it’s quite obvious what it’s doing

so i can create ticket when sending email to tech2@pinco.pl,
i can comment on this ticket, byt i cannot replay to its requestor
from rt

in rt.log i have.

[Wed Dec 24 09:21:38 2003] [info]:
rt-3.0.7-9-58.8.04432955988844@pinco.pl #9/58 - Scrip 9 (/usr/
local/rt3/lib/RT/Action/SendEmail.pm:92)
[Wed Dec 24 09:21:38 2003] [info]:
rt-3.0.7-9-58.8.04432955988844@pinco.pl
No recipients found. Not sending.
(/usr/local/rt3/lib/RT/Action/SendEmail.pm:257)

Scrip 9 on default install is:
On Resolve Notify Requestors with template Resolved

but if i try to simply replay to ticket it also fails.

if someone can point me in some direction i would be gratefull

regards,
mocart

�ukasz Dudek wrote:

Hello,

my configuration.

rt-3.0.7
qmail-sql

so i have in dotqmail table

INSERT INTO dotqmails VALUES (‘alias’, ‘pinco.pl’, ‘tech2’, ‘|
/var/qmail/bin/preline /usr/local/rt3/bin/rt-mailgate --queue tech
–action correspond --url http://pinco.pl:8080’);
INSERT INTO dotqmails VALUES (‘alias’, ‘pinco.pl’, ‘tech2-comment’, ‘|
/var/qmail/bin/preline /usr/local/rt3/bin/rt-mailgate --queue tech
–action comment --url http://pinco.pl:8080 --debug’);

i think it’s quite obvious what it’s doing

so i can create ticket when sending email to tech2@pinco.pl,
i can comment on this ticket, byt i cannot replay to its requestor
from rt

in rt.log i have.

[Wed Dec 24 09:21:38 2003] [info]:
rt-3.0.7-9-58.8.04432955988844@pinco.pl #9/58 - Scrip 9 (/usr/
local/rt3/lib/RT/Action/SendEmail.pm:92)
[Wed Dec 24 09:21:38 2003] [info]:
rt-3.0.7-9-58.8.04432955988844@pinco.pl
No recipients found. Not sending.
(/usr/local/rt3/lib/RT/Action/SendEmail.pm:257)

Scrip 9 on default install is:
On Resolve Notify Requestors with template Resolved
This scrip works only if you ‘Resolve’ ticket.
‘Resolve’ ne ‘Reply’.
You should add scrip that works on Correspond.

�ukasz Dudek wrote:

Dnia �ro, Gru 24, 2003 o godzinie 02:28:44 +0300, Ruslan U. Zakirov napisa� :

�ukasz Dudek wrote:

Hello,

my configuration.

rt-3.0.7
qmail-sql

in rt.log i have.

[Wed Dec 24 09:21:38 2003] [info]:
rt-3.0.7-9-58.8.04432955988844@pinco.pl #9/58 - Scrip 9 (/usr/
local/rt3/lib/RT/Action/SendEmail.pm:92)
[Wed Dec 24 09:21:38 2003] [info]:
rt-3.0.7-9-58.8.04432955988844@pinco.pl
No recipients found. Not sending.
(/usr/local/rt3/lib/RT/Action/SendEmail.pm:257)

Scrip 9 on default install is:
On Resolve Notify Requestors with template Resolved

This scrip works only if you ‘Resolve’ ticket.

and this is what i’m doing, maybe i inserted log in wrong place of my
mail, i tried to show that if im doing resolve rt should response to
requestor but it does not do that.

‘Resolve’ ne ‘Reply’.
You should add scrip that works on Correspond.

this is Scrip 5 on default install:
On Resolve Notify Requestors with template Resolved
When you change status to Resolve and ships it with Reply or Comment in
one request RT interpret this action like two different Transactions.
One for resolving and one for correspondence or comment.

Sorry, but I don’t know where problem is.
Best regards. Ruslan.