Unable to Initiate database installation for RTFM-2.2.0RC2

I compiled and installed RTFM with no problem, but when I try to run the
command “make initdb” I get the following message:

/usr/bin/perl -Ilib -I/opt/rt3/lib /opt/rt3/sbin/rt-setup-database
–action schema --datadir etc --datafile etc/initialdata --dba rt_user
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access
denied for user ‘rt_user’@‘localhost’ (using password: NO) at
/opt/rt3/sbin/rt-setup-database line 170 Failed to connect to
dbi:mysql:;host=localhost as rt_user: Access denied for user
’rt_user’@‘localhost’ (using password: NO) at
/opt/rt3/sbin/rt-setup-database line 170.
…returned with error: 65280
make: *** [initdb] Error 255

Please note that I have the correct password set in the RT_Config.pm
file for the rt_user and when I initiated the database upon RT
installation, there was no problem. It’s just that I can do it for RTFM.

Thanks

Serge

Double check your DB user’s permissions within the database. You may
also have to pass the DB credentials on the command line.

Serge Bianda wrote:

the rt_user has all the permissions for the rt3 database, so should not be an issue. What should be typed in to pass the DB credential from the command line ‘make initdb’?From: Jason Fenner [mailto:jfenner@vitamix.com]
Sent: Tue 6/27/2006 9:14 AM
To: Serge Bianda
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Unable to Initiate database installation for RTFM-2.2.0RC2

Double check your DB user’s permissions within the database. You may
also have to pass the DB credentials on the command line.

Serge Bianda wrote:

I compiled and installed RTFM with no problem, but when I try to run the
command “make initdb” I get the following message:

/usr/bin/perl -Ilib -I/opt/rt3/lib /opt/rt3/sbin/rt-setup-database
–action schema --datadir etc --datafile etc/initialdata --dba rt_user
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access
denied for user ‘rt_user’@‘localhost’ (using password: NO) at
/opt/rt3/sbin/rt-setup-database line 170 Failed to connect to
dbi:mysql:;host=localhost as rt_user: Access denied for user
’rt_user’@‘localhost’ (using password: NO) at
/opt/rt3/sbin/rt-setup-database line 170.
…returned with error: 65280
make: *** [initdb] Error 255

Please note that I have the correct password set in the RT_Config.pm
file for the rt_user and when I initiated the database upon RT
installation, there was no problem. It’s just that I can do it for RTFM.

Thanks

Serge


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html