Unable to get Reply to Requestor message sent

I am fairly new to Postfix and RT so I apologize ahead of time.

Presently my RT server receives email fine and creates tickets. It also
updates those tickets base on email replies from the requestor.

Sadly though when I attempt to reply from within the ticket to the sender no
email is sent.

Thoughts on which logs and settings I should check?

I am running 3.8.8 on CentOS

Vance Walsh
Network and Systems Administrator
Concord Academy - Concord, Mass.

Vance,

When you go to the “Reply” or “Comment” screen, what do you see at the bootm
of the page? You SHOULD see a list of Roles/Users/Groups that will get an
email based on the active Global/Queue scrips. You can accept that list or
change it by checking certain boxes to suppress that user/role/group. If you
make changes, you must click the “Save Changes” box. Once updated or if you
like the list of recipients, then you click the “Update” box.

That should do it.

Kenn
LBNLOn Wed, Jan 26, 2011 at 9:47 AM, Vance Walsh <vance_walsh@concordacademy.org wrote:

I am fairly new to Postfix and RT so I apologize ahead of time.

Presently my RT server receives email fine and creates tickets. It also
updates those tickets base on email replies from the requestor.

Sadly though when I attempt to reply from within the ticket to the sender
no email is sent.

Thoughts on which logs and settings I should check?

I am running 3.8.8 on CentOS


Vance Walsh
Network and Systems Administrator
Concord Academy - Concord, Mass.

Here is what I have listed there. There is no email for the requestor listed.
Is there a configuration step with Scrips that I may have missed?

This message will be sent to…
(Check boxes to disable notifications to the listed recipients)
On Correspond Notify AdminCcs
On Correspond Notify AdminCcs with template Admin Correspondence
On Correspond Notify Other Recipients
On Correspond Notify Other Recipients with template Correspondence
On Correspond Notify Requestors and Ccs
On Correspond Notify Requestors and Ccs with template Correspondence

Messages about this ticket will not be sent to…
(Check boxes to enable notifications to the listed recipients)

Vance Walsh
Network and Systems Administrator
Concord Academy - Concord, Mass.

Vance,

You will notice there is NO scrip for notifying Requestors on Create. This
scrip is usually delivered with RT. Check your Global Scrips and see if it
is there and see if it is Disabled or not. If it is, change the Stage to
"TransactionCreate" and save the changes. That will do it.

IF, however, you do not see such a scrip, then create one. Follow the
instructions in the RT Essentials Book.

Kenn
LBNLOn Wed, Jan 26, 2011 at 10:55 AM, Vance Walsh < vance_walsh@concordacademy.org> wrote:

Here is what I have listed there. There is no email for the requestor
listed. Is there a configuration step with Scrips that I may have missed?

This message will be sent to…
(Check boxes to disable notifications to the listed recipients)
On Correspond Notify AdminCcs
On Correspond Notify AdminCcs with template Admin Correspondence
On Correspond Notify Other Recipients
On Correspond Notify Other Recipients with template Correspondence
On Correspond Notify Requestors and Ccs
On Correspond Notify Requestors and Ccs with template Correspondence

Messages about this ticket will not be sent to…
(Check boxes to enable notifications to the listed recipients)


Vance Walsh
Network and Systems Administrator
Concord Academy - Concord, Mass.

Looks like when I login as root rather then the admin user I created the
reply works. Must be a permissions issue. Figured being super user was
enough. Now to figure out which permissions are needed.

Vance Walsh
Network and Systems Administrator
Concord Academy - Concord, Mass.