Unable to create ticket via email

Recently installed RT3.6.3 on solaris 10 x86 but I am encountering this
problem where I am unable to create a ticket via email. Nothing happens
and the rt.log shows the below error message when maunually attempting.
I am however able to create a ticket from the web page. Please any help
is appreciated. Thank you in advance.

echo “test” | /opt/csw/rt3/bin/rt-mailgate --queue ‘helpdesk’ --action

correspond --url http://helpdesk.wilshire.com/

[Fri Jul 27 01:51:44 2007] [warning]: Encode::Guess failed: ; fallback
to iso-8859-1 (/opt/csw/rt3/lib/RT/I18N.pm:414)
[Fri Jul 27 01:51:44 2007] [error]: Could not record email: Could not
load a valid user
(/opt/csw/rt3/share/html/REST/1.0/NoAuth/mail-gateway:73)

/etc/mail/aliases

Local aliases below

helpdesk: "|/opt/csw/rt3/bin/rt-mailgate --queue ‘helpdesk’ --action
correspond
–url http://helpdesk.wilshire.com/"
helpdesk-comment: “|/opt/csw/rt3/bin/rt-mailgate --queue ‘helpdesk’
–action com
ment --url http://helpdesk.wilshire.com/

it-projects: "|/opt/csw/rt3/bin/rt-mailgate --queue ‘it-projects’
–action corre
spond --url http://helpdesk.wilshire.com/"
it-projects-comment: “|/opt/csw/rt3/bin/rt-mailgate --queue
’it-projects’ --acti
on comment --url http://helpdesk.wilshire.com/

change: "|/opt/csw/rt3/bin/rt-mailgate --queue ‘ChangeRequests’ --action
corresp
ond – url http://helpdesk.wilshire.com/"
change-comment: “|/opt/csw/rt3/bin/rt-mailgate --queue ‘ChangeRequests’
–action
comment --url http://helpdesk.wilshire.com/

This message is intended only for the use of the person(s) listed above as the intended recipient(s), and may contain information that is PRIVILEGED and CONFIDENTIAL. If you are not an intended recipient, you may not read, copy, or distribute this message or any attachment. If you received this communication in error, please notify us immediately by e-mail and then delete all copies of this message and any attachments.

In addition you should be aware that ordinary (unencrypted) e-mail sent through the Internet is not secure. Do not send confidential or sensitive information, such as social security numbers, account numbers, personal identification numbers and passwords, to us via ordinary (unencrypted) e-mail.

Hi List

I am trying to setup RT 4.4.1 so that tickets can be created via an email handled by rt-mailgate.
So fare I can only get RT to create a ticket if the sender is already created as a user in RT.

If I try to create a ticket from an, to RT unknown email address, I get a message back saying:
“You do not have permission to communicate with RT”.

The RT installation is running with $ExternalAuth = 1 and $ExternalSettings set to use Pg_Auth to authenticate the users from a Postgresql.
@MailPlugins is not set, so it must be using the default values.

Any help in figuring out why RT won’t allow ticket creation via email will be greatly appreciated.

Yours
Rune Henssel

Hi,

At either the queue level or globally, you need to give the “Everyone” group the “CreateTicket” permission. Then un-known e-mail addresses will be able to create new tickets and will get set up as new un-privileged users automatically.

Christopher Manly
Coordinator, Library Systems
Cornell University Library Information Technologies
cam2@cornell.edu
607-255-3344On 10/17/16, 7:19 PM, “rt-users on behalf of Rune Henssel” <rt-users-bounces@lists.bestpractical.com on behalf of rune.rt@henssel.dk> wrote:

Hi List

I am trying to setup RT 4.4.1 so that tickets can be created via an email handled by rt-mailgate.
So fare I can only get RT to create a ticket if the sender is already created as a user in RT.

If I try to create a ticket from an, to RT unknown email address, I get a message back saying:
"You do not have permission to communicate with RT".

The RT installation is running with $ExternalAuth = 1 and $ExternalSettings set to use Pg_Auth to authenticate the users from a Postgresql.
@MailPlugins is not set, so it must be using the default values.

Any help in figuring out why RT won't allow ticket creation via email will be greatly appreciated.


Yours
Rune Henssel
RT 4.4 and RTIR training sessions, and a new workshop day! https://bestpractical.com/training
* Boston - October 24-26
* Los Angeles - Q1 2017

Hi,

At either the queue level or globally, you need to give the “Everyone” group the “CreateTicket” permission. Then un-known e-mail addresses
will be able to create new tickets and will get set up as new un-privileged users automatically.

That unfortunately didn’t work,I still get the “You do not have permission to communicate with RT” message.

I also tried with Set($AutoCreateNonExternalUsers, 1); but that doesn’t change anything

This what I get with Set($LogToFile, ‘debug’);

[25116] [Tue Oct 18 13:30:46 2016] [debug]: RT::User::CanonicalizeUserInfoFromExternalAuth called by RT::User /opt/rt4/sbin/…/lib/RT/User.pm
701 with: Comments: Autocreated on ticket submission, Disabled: , EmailAddress: PROTECTED@PROTECTED, Name: PROTECTED@PROTECTED, Privileged: ,
RealName: Rune Henssel (/opt/rt4/sbin/…/lib/RT/User.pm:735)
[25116] [Tue Oct 18 13:30:46 2016] [debug]: Attempting to get user info using this external service: Pg_Auth (/opt/rt4/sbin/…/lib/RT/User.pm:743)
[25116] [Tue Oct 18 13:30:46 2016] [debug]: Attempting to use this canonicalization key: EmailAddress (/opt/rt4/sbin/…/lib/RT/User.pm:752)
[25116] [Tue Oct 18 13:30:46 2016] [info]: RT::Authen::ExternalAuth::DBI::CanonicalizeUserInfo INFO CHECK FAILED Key: email Value:
PROTECTED@PROTECTED No User Found in External Database! (/opt/rt4/sbin/…/lib/RT/Authen/ExternalAuth/DBI.pm:400)
[25116] [Tue Oct 18 13:30:46 2016] [debug]: Attempting to use this canonicalization key: RealName (/opt/rt4/sbin/…/lib/RT/User.pm:752)
[25116] [Tue Oct 18 13:30:46 2016] [info]: RT::User::CanonicalizeUserInfoFromExternalAuth returning Comments: Autocreated on ticket submission,
Disabled: , EmailAddress: rune.rt@henssel.dk, Name: rune.rt@henssel.dk, Privileged: , RealName: Rune Henssel (/opt/rt4/sbin/…/lib/RT/User.pm:811)
[25116] [Tue Oct 18 13:30:51 2016] [critical]: Failed to create user PROTECTED@PROTECTED: Name in use (/opt/rt4/sbin/…/lib/RT/User.pm:546)
[25116] [Tue Oct 18 13:30:51 2016] [crit]: Permission Denied: You do not have permission to communicate with RT
(/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:701)
[25120] [Tue Oct 18 13:51:24 2016] [debug]: Attempting to use external auth service: Pg_Auth (/opt/rt4/sbin/…/lib/RT/Authen/ExternalAuth.pm:288)
[25120] [Tue Oct 18 13:51:24 2016] [debug]: SSO Failed and no user to test with. Nexting (/opt/rt4/sbin/…/lib/RT/Authen/ExternalAuth.pm:316)
[25120] [Tue Oct 18 13:51:24 2016] [debug]: Autohandler called ExternalAuth. Response: (0, No User) (/opt/rt4/share/html/Elements/DoAuth:58)

Yours
Rune Henssel

Hi,

At either the queue level or globally, you need to give the “Everyone” group the “CreateTicket” permission. Then un-known e-mail addresses
will be able to create new tickets and will get set up as new un-privileged users automatically.

That unfortunately didn’t work,I still get the “You do not have permission to communicate with RT” message.

I found the error, it was an overzealous ‘attr_match_list’ in the external authentication settings, once it was changed everything worked.

Yours
Rune Henssel