Unable to configure "open" queue

Hi.

We are a small company that got recommended this nice piece of software,
but have stranded on a small issue: We are unable to configure a "open"
queue, that allows everyone to create a ticket through incoming email.

Whatever we try we get the following two lines in syslog:
Ticket creation failed: Test 20: No permission to create tickets in the
queue ‘Testing’ (/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:248)
Could not record email: Ticket creation failed: No permission to create
tickets in the queue ‘Testing’
(/opt/rt4/share/html/REST/1.0/NoAuth/mail-gateway
:75)

Tried this on both the stock “Support” queue, and now with a brand new
"Testing" queue.

The setting I would suspect should change this, is queues->group
rights->All, and then allowing “Create tickets” under “General rights”, but
I have also tried allowing this a dozen other places without luck :frowning:

Any help is appreciated.

Regards
Christian B. Wiik

Christian B. Wiik wrote:

Hi.

We are a small company that got recommended this nice piece of
software, but have stranded on a small issue: We are unable to
configure a “open” queue, that allows everyone to create a ticket
through incoming email.

Whatever we try we get the following two lines in syslog:
Ticket creation failed: Test 20: No permission to create tickets in
the queue ‘Testing’ (/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:248)
Could not record email: Ticket creation failed: No permission to
create tickets in the queue ‘Testing’
(/opt/rt4/share/html/REST/1.0/NoAuth/mail-gateway
:75)

Tried this on both the stock “Support” queue, and now with a brand new
“Testing” queue.

The setting I would suspect should change this, is queues->group
rights->All, and then allowing “Create tickets” under “General
rights”, but I have also tried allowing this a dozen other places
without luck :frowning:

As a test could you add Create Tickets to the global Everyone group and
then try. RT Essentials (the book) has an example of that and for me it
has worked several times in the past. Restricting Create Ticket to only
certain queues will work but try to get the general one working first.
Thinking about general, what does your /etc/aliases look like, or
how/where does you mail end up in RT?
My setup is that mail send to support@domain.nl will go to the General
queue which is created as part of initdb and things like
support-app1@domain.nl will go directly to the app1 queue. I’m
suspecting that you have added Create Ticket to your Testing queue but
that by default your mta is trying to use the General queue to create
tickets which doesn’t have Create Ticket.

Regards,

Joop

As a test could you add Create Tickets to the global Everyone group and
then try. RT Essentials (the book) has an example of that and for me it has
worked several times in the past. Restricting Create Ticket to only certain
queues will work but try to get the general one working first.
Thinking about general, what does your /etc/aliases look like, or
how/where does you mail end up in RT?
My setup is that mail send to support@domain.nl will go to the General
queue which is created as part of initdb and things like
support-app1@domain.nl will go directly to the app1 queue. I’m suspecting
that you have added Create Ticket to your Testing queue but that by default
your mta is trying to use the General queue to create tickets which doesn’t
have Create Ticket.

Hi and thanks for reply Joop.

I already have “Create tickets” enabled under global group rights →
Everyone → General rights.

My /etc/aliases is currently set to:
support: “|/opt/rt4/bin/rt-mailgate --queue Testing --action
correspond --url http://localhost/rt/

My RT was set up running 4.0.10, but I have now upgraded to 4.0.13 and get
the same results.

Regards
Christian

Christian B. Wiik wrote:> On Thu, Jun 20, 2013 at 9:45 AM, Joop <jvdwege@xs4all.nl mailto:jvdwege@xs4all.nl> wrote:

As a test could you add Create Tickets to the global Everyone
group and then try. RT Essentials (the book) has an example of
that and for me it has worked several times in the past.
Restricting Create Ticket to only certain queues will work but try
to get the general one working first.
Thinking about general, what does your /etc/aliases look like, or
how/where does you mail end up in RT?
My setup is that mail send to support@domain.nl
<mailto:support@domain.nl> will go to the General queue which is
created as part of initdb and things like support-app1@domain.nl
<mailto:support-app1@domain.nl> will go directly to the app1
queue. I'm suspecting that you have added Create Ticket to your
Testing queue but that by default your mta is trying to use the
General queue to create tickets which doesn't have Create Ticket.

Hi and thanks for reply Joop.

I already have “Create tickets” enabled under global group rights →
Everyone → General rights.

My /etc/aliases is currently set to:
support: “|/opt/rt4/bin/rt-mailgate --queue Testing
–action correspond --url http://localhost/rt/

My RT was set up running 4.0.10, but I have now upgraded to 4.0.13 and
get the same results.

Those settings should work. There are no other errors/info in the rt.log
or apache error.log just above the permission denied?
You could feed rt-mailgate a mail message from the commandline and see
what error it spits out. Wild guess, why use localhost/rt instead of
fqdn/rt ?

Joop

Those settings should work. There are no other errors/info in the rt.log
or apache error.log just above the permission denied?
You could feed rt-mailgate a mail message from the commandline and see
what error it spits out. Wild guess, why use localhost/rt instead of
fqdn/rt ?

Dead on Joop!

I used the localhost version because the server is only accessible through
https from the outside. This gave me a certificate error using the fqdn
version.

I now found the “–no-verify-ssl” switch to rt-mailgate, and this solved my
problem. Thanks a lot!

Regards
Christian