Ubuntu pkgs: passwd problem in rt-setup-fulltext-index

Using Ubuntu 11.10 beta, installed the request-tracker4 packages (Thank
you, Dominic!).
Apparently a whole bunch of magic happens behind the scenes during
database setup thanks to Debian’s dbconfig-common, which I utterly fail to
understand at this time.

After everything gets automagically configured, I wanted to add fulltext
searching support to the database, and ran rt-setup-fulltext-index. It
detects I’m running postgres, asks me what table and which index type I
want, and then promptly fails with this:

  [Sat Oct  1 20:57:43 2011] [crit]: DBI 

connect(‘dbname=rtdb;host=localhost’,‘postgres’,…) failed: fe_sendauth:
no password supplied at /usr/sbin/rt-setup-fulltext-index line 600
(/usr/share/request-tracker4/lib/RT.pm:350)
DBI connect(‘dbname=rtdb;host=localhost’,‘postgres’,…) failed:
fe_sendauth: no password supplied at /usr/sbin/rt-setup-fulltext-index
line 600

Given that Postgres-9.1 in Ubuntu uses “peer” as the local authtype, no
password exists to supply in the first place. If I su(1) to “postgres”
first, I can’t run the tool because the postgres user can’t read the
various RT config files.

Ultimately, this probably won’t matter because I intend to migrate a
production database from an old server onto this server eventually, and it
already has the fulltext searching bits in its schema.

However, in the meantime, what am I missing here? How can I use this tool
instead of manually adding the necessary schema bits?

Suggestion: for dbconfig-based scripts, upon detecting postgres,
automatically set up fulltext searching?

-Adam Thompson
athompso@athompso.net

Using Ubuntu 11.10 beta, installed the request-tracker4 packages
(Thank you, Dominic!).
Apparently a whole bunch of magic happens behind the scenes during
database setup thanks to Debian’s dbconfig-common, which I utterly
fail to understand at this time.

After everything gets automagically configured, I wanted to add
fulltext searching support to the database, and ran rt-setup-
fulltext-index. It detects I’m running postgres, asks me what
table and which index type I want, and then promptly fails with
this:

  [Sat Oct  1 20:57:43 2011] [crit]: DBI

connect(‘dbname=rtdb;host=localhost’,‘postgres’,…) failed:
fe_sendauth:
no password supplied at /usr/sbin/rt-setup-fulltext-index line 600
(/usr/share/request-tracker4/lib/RT.pm:350)
DBI connect(‘dbname=rtdb;host=localhost’,‘postgres’,…)
failed:
fe_sendauth: no password supplied at /usr/sbin/rt-setup-fulltext-
index line 600

[…]

Of course, I figured it out about 30 seconds after hitting ‘send’.

The “rtuser” postgresql user has sufficient rights to alter the schema on
‘rtdb’.
Therefore, /usr/sbin/rt-setup-fulltext-index can be run with “–dba
rtuser” and “–dba-password XXXX” options, where the password is whatever
you either A) selected during the initial debconf run, or b) whatever’s
now contained in /etc/request-tracker4/RT_SiteConfig.d/51-dbconfig-common.

-Adam Thompson
athompso@athompso.net