Troubles upgrading to 3.6.4 from 3.4.4

Running on Ubuntu 6.10
Postgres 7.4.13
Apache 2.0.55

I’m trying to update my database per the README instructions:

/opt/rt3/sbin/rt-setup-database --action schema \ --datadir
etc/upgrade/3.5.1

results in an error of:
Can’t locate UNIVERSAL/require.pm in @INC (@INC contains: /opt/rt3/lib
/opt/rt3/local/lib /etc/perl /usr/local/lib/perl/5.8.8
/usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at
/opt/rt3/lib/RT/Interface/Email.pm line 55.

followed by multiple “BEGIN failed–compilation aborted at…” messages.

I can’t find a require.pm anywhere on my system.

View this message in context: http://www.nabble.com/Troubles-upgrading-to-3.6.4-from-3.4.4-tf4325109.html#a12317710

Looks like you need to find the perl module package require.pm belongs to
and install it.

James Moseley

         davidturnau                                                   
         <daveturnau@hotma                                             
         il.com>                                                    To 
         Sent by:                  rt-users@lists.bestpractical.com    
         rt-users-bounces@                                          cc 
         lists.bestpractic                                             
         al.com                                                Subject 
                                   [rt-users] Troubles upgrading to    
                                   3.6.4 from 3.4.4                    
         08/24/2007 01:30                                              
         PM                                                            

Running on Ubuntu 6.10
Postgres 7.4.13
Apache 2.0.55

I’m trying to update my database per the README instructions:

/opt/rt3/sbin/rt-setup-database --action schema \ --datadir
etc/upgrade/3.5.1

results in an error of:
Can’t locate UNIVERSAL/require.pm in @INC (@INC contains: /opt/rt3/lib
/opt/rt3/local/lib /etc/perl /usr/local/lib/perl/5.8.8
/usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at
/opt/rt3/lib/RT/Interface/Email.pm line 55.

followed by multiple “BEGIN failed–compilation aborted at…” messages.

I can’t find a require.pm anywhere on my system.

View this message in context:
http://www.nabble.com/Troubles-upgrading-to-3.6.4-from-3.4.4-tf4325109.html#a12317710

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com