TransactionBatch problem

Hi,

I am seeing a strange problem with 3.2.3 and postgresql. We are using all sorts of scrips to manipulate the transaction contents (e.g. SetTicketPropertiesViaMail from the Wiki). Since you cannot predict the order in which scrips are run I tried the following: I moved all scips that created communication (e-mail etc.) into the TransactionBatch stage. I only left the more “administrative” scrips in the TransactionCreate stage (like AutoSetOwner, Reopen Ticket on Correspondance etc.).

At first it looked like everything was working. Using the E-Mail interface worked like a charm. Once we started using the Web-Interface again we recognized all sorts of mails with emtpy transaction contents. It took me some time to figure it out. I traced it down to the following: The moment I hit “Reply” or “Comment” in the web interface, all sorts of scrips were running. And the ones in “TransactionBatch” stage all produced output in the form of E-Mails. The moment I put those scrips back to TransactionCreate stage everything is back to normal.

This is a bug, is it not? Any ideas?

Regards,
JP

Hi,

I am seeing a strange problem with 3.2.3. We are using all sorts of scrips to manipulate the transaction contents (e.g. SetTicketPropertiesViaMail from the Wiki). Since you cannot predict the order in which scrips are run I tried the following: I moved all scips that created communication (e-mail etc.) into the TransactionBatch stage. I only left the more “administrative” scrips in the TransactionCreate stage (like AutoSetOwner, Reopen Ticket on Correspondance etc.).

At first it looked like everything was working. Using the E-Mail interface worked like a charm. Once we started using the Web-Interface again we recognized all sorts of mails with emtpy transaction contents. It took me some time to figure it out. I traced it down to the following: The moment I hit “Reply” or “Comment” in the web interface, all sorts of scrips were running. And the ones in “TransactionBatch” stage all produced output in the form of E-Mails.

This is a bug, is it not?

BTW: I would have loved to put this into the devel-list but all my tries to subscribe to that list failed for an unknown reason (no reply from the list server). I hope someone can help me here!

Regards,
JP

Are you using MySQL with MyISAM tables? You should upgrade
your tables to InnoDB or switch to another database.

No postgresql-7.3.5_1.

What does the database have to do with the fact that a scrip is run if you press the “comment” button in the web interface?

Regards,
JP

If you press “Comment” in the web browser RT will perform a
transaction but tell the database to not commit it, it’ll
roll it back later.

I see.

Scrips firing then could be a bug…

And now what? Whom to contact? How can I investigate this further? I would very much like to use TransactionBatch.

Kind regards,
JP

To all,

We wanted to have TransactionBatch as a scrip "stage" option so we made 

the change as:

RT::TransactionBatch 1

in the configuration. When we go to a scrip, we still do not see it in
the “stage” drop-down. Anyone have this experience and resolve it? Thanks.

Kenn
LBNL

Have you restarted httpd?

Keep up with me and what I’m up to: http://theillien.blogspot.com

Kenneth Crocker wrote:

At Thursday 10/4/2007 02:50 PM, you wrote:

To all,

    We wanted to have TransactionBatch as a scrip "stage" 

option so we made the change as:

RT::TransactionBatch 1

in the configuration. When we go to a scrip, we still do not see it
in the “stage” drop-down. Anyone have this experience and resolve it? Thanks.

Kenn,

I think the correct syntax for RT_SiteConfig.pm is:

Set($UseTransactionBatch , 1);

Steve

Mathew,

Yes we did.

Kenn
LBNLOn 10/4/2007 12:20 PM, Mathew Snyder wrote:

Have you restarted httpd?

Keep up with me and what I’m up to: http://theillien.blogspot.com

Kenneth Crocker wrote:

To all,

We wanted to have TransactionBatch as a scrip "stage" option so we

made the change as:

RT::TransactionBatch 1

in the configuration. When we go to a scrip, we still do not see it in
the “stage” drop-down. Anyone have this experience and resolve it? Thanks.

Kenn
LBNL


The rt-users Archives

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media. Buy
a copy at http://rtbook.bestpractical.com

Stephen,

Yep. That did it. Thanks.

Kenn
LBNLOn 10/4/2007 12:46 PM, Stephen Turner wrote:

At Thursday 10/4/2007 02:50 PM, you wrote:

To all,

    We wanted to have TransactionBatch as a scrip "stage" option 

so we made the change as:

RT::TransactionBatch 1

in the configuration. When we go to a scrip, we still do not see it in
the “stage” drop-down. Anyone have this experience and resolve it?
Thanks.

Kenn,

I think the correct syntax for RT_SiteConfig.pm is:

Set($UseTransactionBatch , 1);

Steve


The rt-users Archives

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media. Buy
a copy at http://rtbook.bestpractical.com