Timezones

I think the “location based” zones are preferred over zone US/Eastern
style ones. Also FreeBSD doesn’t know about the US/* stuff (and a lot
of other things that Linux generally has in its zoneinfo.) Solaris
knows about the US/*…

-R

— config.pm.orig Tue Apr 2 22:07:21 2002
+++ config.pm Tue Apr 2 22:07:55 2002
@@ -25,7 +25,7 @@

$Timezone is used to convert times entered by users into GMT and

back again

It should be set to a timezone recognized by your local unix box.

-$Timezone = ‘US/Eastern’;
+$Timezone = ‘America/New_York’;

LogDir is where RT writes its logfiles.

This directory should be writable by your rt group

I think the “location based” zones are preferred over zone US/Eastern
style ones. Also FreeBSD doesn’t know about the US/* stuff (and a lot
of other things that Linux generally has in its zoneinfo.) Solaris
knows about the US/*…

I think you’ve missed the point of the comment-as-distributed regarding
the define:

It should be set to a timezone recognized by your local unix box.

Regards,

                         Bruce Campbell                            RIPE
               Systems/Network Engineer                             NCC
             www.ripe.net - PGP562C8B1B                      Operations

I think you’ve missed the point of the comment-as-distributed regarding
the define:

It should be set to a timezone recognized by your local unix box.

The patch was in the vein of Least Common Denominator defaults. The TZ
value “looks ok” - but as I found, not all systems support that format.
Especially as the fall through for an invalid TZ is GMT.

-R

Hello all,

Times are required to be GMT in RT::Tickets::LimitDate() calls,

but that assumption doesn’t exist in _DateLimit(), where they’ll be
evaluated as local times, ultimately, by Time::ParseDate::parsedate().

I can't get a usable database query.  In the meanwhile I've added

GMT => 1 to the parsedate() call.

I'm using 3.4.1.

Thanks,

Nuno Rodrigues

Hello all,

Times are required to be GMT in RT::Tickets::LimitDate() calls,

but that assumption doesn’t exist in _DateLimit(), where they’ll be
evaluated as local times, ultimately, by Time::ParseDate::parsedate().

I can't get a usable database query.  In the meanwhile I've added

GMT => 1 to the parsedate() call.

I'm using 3.4.1.

Thanks,

Nuno Rodrigues

Hello all,

Times are required to be GMT in RT::Tickets::LimitDate() calls,

but that assumption doesn’t exist in _DateLimit(), where they’ll be
evaluated as local times, ultimately, by Time::ParseDate::parsedate().

I can't get a usable database query.  In the meanwhile I've added

GMT => 1 to the parsedate() call.

I'm using 3.4.1.

Thanks,

Nuno Rodrigues

We’ve implemented some changes in this area in RT-3.4.6rc1. Could you
check with that version. Also please don’t spam lists with the same
letter especially when you are not using latest stable version of RT.On 8/4/06, Nuno Miguel Rodrigues nmrodrigues@gmail.com wrote:

Hello all,

Times are required to be GMT in RT::Tickets::LimitDate() calls,

but that assumption doesn’t exist in _DateLimit(), where they’ll be
evaluated as local times, ultimately, by Time::ParseDate::parsedate().

I can't get a usable database query.  In the meanwhile I've added

GMT => 1 to the parsedate() call.

I'm using 3.4.1.

Thanks,


Nuno Rodrigues


List info: http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-devel

Best regards, Ruslan.

Hello,

I did check latest stable code, same behaviour, apparently.  I'll

try 3.4.6rc1.

I'm not seeing my own list messages, irrespective of what my

Mailman profile says, hence the spam.

Thanks.

Nuno RodriguesOn 8/7/06, Ruslan Zakirov ruslan.zakirov@gmail.com wrote:

We’ve implemented some changes in this area in RT-3.4.6rc1. Could you
check with that version. Also please don’t spam lists with the same
letter especially when you are not using latest stable version of RT.

Hi, I have rt 3.4.1 installed on FC3 and I am trying to edit the
RT_Siteconfig to fit the ‘Europe/Dublin’ timezone. When I use
’Europe/Dublin’ in the RT_SiteConfig file, it still does not make a
difference to the created field in the mysql database. When a new ticket is
created, it is GMT time but the clock on the server is ‘GMT+1’. I have even
tried ‘GMT+1’ and the created value is still one hour behind the time now.

Is there a specific setting that has to be used instead of 'Europe/Dublin’
to get this working?

Any help would be appreciated.

Thanks in advance for the help.

Best Regards,
Ravin Mathoora

Ravin Mathoora wrote:

Hi, I have rt 3.4.1 installed on FC3 and I am trying to edit the
RT_Siteconfig to fit the ‘Europe/Dublin’ timezone. When I use
’Europe/Dublin’ in the RT_SiteConfig file, it still does not make a
difference to the created field in the mysql database. When a new ticket is
created, it is GMT time but the clock on the server is ‘GMT+1’. I have even
tried ‘GMT+1’ and the created value is still one hour behind the time now.

Is there a specific setting that has to be used instead of 'Europe/Dublin’
to get this working?
WebUI should show local time, but RT stores GMT in its DB. Also RT use
GMT for log entries. What’s wrong with that?