Time in logs not matching system time

All,

I am seeing a time in the rt log file that is 4 hours in advance of the system time  (system time is EDT).

IE

root@MyHelpDesk:/opt/rt3/var/log# date
Fri Sep 25 11:38:41 EDT 2009
root@MyHelpDesk:/opt/rt3/var/log# tail -f rt.log

[Fri Sep 25 15:39:58 2009] [info]: RT::Authen::ExternalAuth::LDAP::GetAuth External Auth OK ( HSCIDM_LDAP ): slander (/opt/rt3/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:139)
[Fri Sep 25 15:39:58 2009] [warning]: disable (/opt/rt3/bin/…/lib/RT/User_Overlay.pm:1142)

So, the system time is 11:38, while the log time is 15:38 (ok, 15:39…)

My Rt_SiteConfig.pm has Set($Timezone , ‘US/Eastern’);

Any one have any idea how to sync these up?

Thanks

This e-mail message is intended only for the personal use of the recipient(s) named above. If you are not an intended recipient, you may not review, copy or distribute this message. If you have received this communication in error, please notify the Hearst Service Center (cadmin@hearstsc.com) immediately by email and delete the original message.

I have basically the same problem with the log 5 hours ahead. (I am CDT)
I have a RHE Linux 5 system.
I have tried both of these in the RT_SiteConfig.pm without any change:

Set($Timezone, ‘US/Central’);
and
Set($Timezone , ‘America/Chicago’);

Interestingly, when httpd first starts up the log has the correct time,
but as soon as it uses RT, the
timestamp changes ahead 5 hours.
The name change occurs right after the last Apache 2.2.3 info notice
about when the server was
built.

Susie

All,

I am seeing a time in the rt log file that is 4 hours in advance of the system time  (system time is EDT).

IE

root@MyHelpDesk:/opt/rt3/var/log# date
Fri Sep 25 11:38:41 EDT 2009
root@MyHelpDesk:/opt/rt3/var/log# tail -f rt.log

[Fri Sep 25 15:39:58 2009] [info]: RT::Authen::ExternalAuth::LDAP::GetAuth External Auth OK ( HSCIDM_LDAP ): slander (/opt/rt3/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:139)
[Fri Sep 25 15:39:58 2009] [warning]: disable (/opt/rt3/bin/…/lib/RT/User_Overlay.pm:1142)

So, the system time is 11:38, while the log time is 15:38 (ok, 15:39…)

My Rt_SiteConfig.pm has Set($Timezone , ‘US/Eastern’);

Any one have any idea how to sync these up?

Thanks

RT-Users mailing list
RT-Users@lists.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

End of RT-Users Digest, Vol 66, Issue 88

!DSPAM:8,4abce92498521108712277!

smcclure.vcf (276 Bytes)

Isn’t Chicago GMT -5? RT will always log in UTC no matter what you do, but setting the timezone effects the user interface.-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Susan McClure
Sent: Friday, September 25, 2009 9:29 AM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Time in logs not matching system time

I have basically the same problem with the log 5 hours ahead. (I am CDT)
I have a RHE Linux 5 system.
I have tried both of these in the RT_SiteConfig.pm without any change:

Set($Timezone, ‘US/Central’);
and
Set($Timezone , ‘America/Chicago’);

Interestingly, when httpd first starts up the log has the correct time,
but as soon as it uses RT, the
timestamp changes ahead 5 hours.
The name change occurs right after the last Apache 2.2.3 info notice
about when the server was
built.

Susie

All,

I am seeing a time in the rt log file that is 4 hours in advance of the system time  (system time is EDT).

IE

root@MyHelpDesk:/opt/rt3/var/log# date
Fri Sep 25 11:38:41 EDT 2009
root@MyHelpDesk:/opt/rt3/var/log# tail -f rt.log

[Fri Sep 25 15:39:58 2009] [info]: RT::Authen::ExternalAuth::LDAP::GetAuth External Auth OK ( HSCIDM_LDAP ): slander (/opt/rt3/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:139)
[Fri Sep 25 15:39:58 2009] [warning]: disable (/opt/rt3/bin/…/lib/RT/User_Overlay.pm:1142)

So, the system time is 11:38, while the log time is 15:38 (ok, 15:39…)

My Rt_SiteConfig.pm has Set($Timezone , ‘US/Eastern’);

Any one have any idea how to sync these up?

Thanks

RT-Users mailing list
RT-Users@lists.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

End of RT-Users Digest, Vol 66, Issue 88

!DSPAM:8,4abce92498521108712277!

Kimberly McKinnis wrote:

Isn’t Chicago GMT -5? RT will always log in UTC no matter what you
do, but setting the timezone effects the user interface.

Interesting. I have TimeZone in RT_SiteConfig.pm set to 'US/Pacific’
and get the local time in the log files. I am also using syslog which
may explain the date/time beig correct. (CentOS 5 in a Linux-Vserver guest)

\||
Rod

That seems to be as designed. At least, that’s what I was told when I asked this same question last year. Slightly annoying but you get used to it.-----Original Message-----
From: Lander, Scott [mailto:slander@hearstsc.com]
Sent: Monday, September 28, 2009 11:54 AM
To: Kimberly McKinnis; ‘smcclure@rice.edu’; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Time in logs not matching system time

Hmm in syslog, it logs the correct time:

Sep 28 14:46:18 MyHelpDesk RT: Ticket 327 created in queue ‘Monitoring’ by root (/opt/rt3/bin/…/lib/RT/Ticket_Overlay.pm:667)

While in the rt.log file it logs in UTC:

[Mon Sep 28 18:46:18 2009] [info]: Ticket 327 created in queue ‘Monitoring’ by root (/opt/rt3/bin/…/lib/RT/Ticket_Overlay.pm:667)

Logging is currently set as:

Logging

Set($LogToSyslog , ‘info’);
Set($LogToScreen , ‘info’);
Set($LogToFile , 1);
Set($LogDir, ‘var/log’);
Set($LogToFileNamed , “rt.log”); #log to rt.log
Set($LogStackTraces, ‘’);
Set(@LogToSyslogConf, ());
Set($StatementLog, ‘’);

End logging

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Kimberly McKinnis
Sent: Friday, September 25, 2009 6:48 PM
To: ‘smcclure@rice.edu’; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Time in logs not matching system time

Isn’t Chicago GMT -5? RT will always log in UTC no matter what you do, but setting the timezone effects the user interface.

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Susan McClure
Sent: Friday, September 25, 2009 9:29 AM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Time in logs not matching system time

I have basically the same problem with the log 5 hours ahead. (I am CDT) I have a RHE Linux 5 system.
I have tried both of these in the RT_SiteConfig.pm without any change:

Set($Timezone, ‘US/Central’);
and
Set($Timezone , ‘America/Chicago’);

Interestingly, when httpd first starts up the log has the correct time, but as soon as it uses RT, the timestamp changes ahead 5 hours.
The name change occurs right after the last Apache 2.2.3 info notice about when the server was built.

Susie

All,

I am seeing a time in the rt log file that is 4 hours in advance of the system time  (system time is EDT).

IE

root@MyHelpDesk:/opt/rt3/var/log# date
Fri Sep 25 11:38:41 EDT 2009
root@MyHelpDesk:/opt/rt3/var/log# tail -f rt.log

[Fri Sep 25 15:39:58 2009] [info]: RT::Authen::ExternalAuth::LDAP::GetAuth External Auth OK ( HSCIDM_LDAP ): slander (/opt/rt3/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:139)
[Fri Sep 25 15:39:58 2009] [warning]: disable (/opt/rt3/bin/…/lib/RT/User_Overlay.pm:1142)

So, the system time is 11:38, while the log time is 15:38 (ok, 15:39…)

My Rt_SiteConfig.pm has Set($Timezone , ‘US/Eastern’);

Any one have any idea how to sync these up?

Thanks

RT-Users mailing list
RT-Users@lists.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

End of RT-Users Digest, Vol 66, Issue 88

!DSPAM:8,4abce92498521108712277!

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com
This e-mail message is intended only for the personal use of the recipient(s) named above. If you are not an intended recipient, you may not review, copy or distribute this message. If you have received this communication in error, please notify the Hearst Service Center (cadmin@hearstsc.com) immediately by email and delete the original message.

Hmm in syslog, it logs the correct time:

Sep 28 14:46:18 MyHelpDesk RT: Ticket 327 created in queue ‘Monitoring’ by root (/opt/rt3/bin/…/lib/RT/Ticket_Overlay.pm:667)

While in the rt.log file it logs in UTC:

[Mon Sep 28 18:46:18 2009] [info]: Ticket 327 created in queue ‘Monitoring’ by root (/opt/rt3/bin/…/lib/RT/Ticket_Overlay.pm:667)

Logging is currently set as:

Logging

Set($LogToSyslog , ‘info’);
Set($LogToScreen , ‘info’);
Set($LogToFile , 1);
Set($LogDir, ‘var/log’);
Set($LogToFileNamed , “rt.log”); #log to rt.log
Set($LogStackTraces, ‘’);
Set(@LogToSyslogConf, ());
Set($StatementLog, ‘’);

End logging-----Original Message-----

From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Kimberly McKinnis
Sent: Friday, September 25, 2009 6:48 PM
To: ‘smcclure@rice.edu’; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Time in logs not matching system time

Isn’t Chicago GMT -5? RT will always log in UTC no matter what you do, but setting the timezone effects the user interface.

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Susan McClure
Sent: Friday, September 25, 2009 9:29 AM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Time in logs not matching system time

I have basically the same problem with the log 5 hours ahead. (I am CDT) I have a RHE Linux 5 system.
I have tried both of these in the RT_SiteConfig.pm without any change:

Set($Timezone, ‘US/Central’);
and
Set($Timezone , ‘America/Chicago’);

Interestingly, when httpd first starts up the log has the correct time, but as soon as it uses RT, the timestamp changes ahead 5 hours.
The name change occurs right after the last Apache 2.2.3 info notice about when the server was built.

Susie

All,

I am seeing a time in the rt log file that is 4 hours in advance of the system time  (system time is EDT).

IE

root@MyHelpDesk:/opt/rt3/var/log# date
Fri Sep 25 11:38:41 EDT 2009
root@MyHelpDesk:/opt/rt3/var/log# tail -f rt.log

[Fri Sep 25 15:39:58 2009] [info]: RT::Authen::ExternalAuth::LDAP::GetAuth External Auth OK ( HSCIDM_LDAP ): slander (/opt/rt3/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:139)
[Fri Sep 25 15:39:58 2009] [warning]: disable (/opt/rt3/bin/…/lib/RT/User_Overlay.pm:1142)

So, the system time is 11:38, while the log time is 15:38 (ok, 15:39…)

My Rt_SiteConfig.pm has Set($Timezone , ‘US/Eastern’);

Any one have any idea how to sync these up?

Thanks

RT-Users mailing list
RT-Users@lists.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

End of RT-Users Digest, Vol 66, Issue 88

!DSPAM:8,4abce92498521108712277!

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com
This e-mail message is intended only for the personal use of the recipient(s) named above. If you are not an intended recipient, you may not review, copy or distribute this message. If you have received this communication in error, please notify the Hearst Service Center (cadmin@hearstsc.com) immediately by email and delete the original message.