Tickets keep being created in general queue

I think I have done enough to get tickets created in a queue called
webblocker but they end up in general.

I have;
create q and configged the addresses.
added appropriate alias (postfix & rt-mailgate) in /etc/aliases, newaliases,
restart.
global|group|everyone create-ticket created.

But they end in general, and the autoreply comes from general also.

Any ideas?

Send and receive Hotmail on your mobile device: http://mobile.msn.com

I think I have done enough to get tickets created in a queue called
webblocker but they end up in general.

I have;
create q and configged the addresses.
added appropriate alias (postfix & rt-mailgate) in /etc/aliases, newaliases,
restart.
global|group|everyone create-ticket created.

But they end in general, and the autoreply comes from general also.

Could you quote (to the list) the aliases for both your ‘general’ and
’weblocker’ queues? I suspect that you’ve copied and pasted the
rt-mailgate line for general, but neglected to change the argument to
–queue to point to the right queue.

                         Bruce Campbell                            RIPE
               Systems/Network Engineer                             NCC
             www.ripe.net - PGP562C8B1B             Operations/Security

webblocker: |"/opt/rt2/bin/rt-mailgate webblocker correspond"
webblocker-action: |"/opt/rt2/bin/rt-mailgate webblocker action"
webblocker-correspond: “/opt/rt2/bin/rt-mailgate webblocker correspond"
webblocker-comment: |”/opt/rt2/bin/rt-mailgate webblocker comment"

rt: |"/opt/rt2/bin/rt-mailgate general correspond"
rt-action: |"/opt/rt2/bin/rt-mailgate general action"
rt-correspond: |"/opt/rt2/bin/rt-mailgate general correspond"
rt-comment: |"/opt/rt2/bin/rt-mailgate general comment"

Seems okay to me, although is it because I don’t have any dashes?

Could you quote (to the list) the aliases for both your ‘general’ and
’weblocker’ queues? I suspect that you’ve copied and pasted the
rt-mailgate line for general, but neglected to change the argument to
–queue to point to the right queue.

Chat with friends online, try MSN Messenger: http://messenger.msn.com

Thanks very much, that has cured it. It seems that my ‘incorrect’ general
line was working despite not being correctly written, and this confused me.

As to why it didn’t have the switches…

According to the instructions I read it should be

webblocker: “|/opt/rt2/bin/rt-mailgate --queue webblocker --action
correspond”

Note the placement of the first double quote and the two option switches.

-q and -a are also usable.

Reading the rt-mailgate source I’m pretty sure these are required.

MSN Photos is the easiest way to share and print your photos:
http://photos.msn.com/support/worldwide.aspx