Tickets created in RT don't line-wrap?

Most of our tickets are created through e-mail so I didn’t notice this.

I just created a ticket inside RT 3.8.2 using the "New Ticket In"
button at the top of the page and the text is unreadable when viewing
the ticket because my paragraphs simply aren’t line wrapping. There
is a scrollbar in the view and you can scroll back and forth but this
is obnoxiously difficult.

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

Jo Rhett wrote:

Most of our tickets are created through e-mail so I didn’t notice this.

I just created a ticket inside RT 3.8.2 using the "New Ticket In"
button at the top of the page and the text is unreadable when viewing
the ticket because my paragraphs simply aren’t line wrapping. There
is a scrollbar in the view and you can scroll back and forth but this
is obnoxiously difficult.

in RT_Site_Config change

Set($MessageBoxWrap, “SOFT”);

Set($MessageBoxWrap, “HARD”);

Jo Rhett wrote:

Most of our tickets are created through e-mail so I didn’t notice
this.
I just created a ticket inside RT 3.8.2 using the "New Ticket In"
button at the top of the page and the text is unreadable when
viewing the ticket because my paragraphs simply aren’t line
wrapping. There is a scrollbar in the view and you can scroll
back and forth but this is obnoxiously difficult.

in RT_Site_Config change

Set($MessageBoxWrap, “SOFT”);

Set($MessageBoxWrap, “HARD”);

I certainly can do – but why is this an option? Is there any reason
for Soft mode, ever?

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

Set($MessageBoxWrap, “SOFT”);

Set($MessageBoxWrap, “HARD”);

I certainly can do – but why is this an option? Is there any reason
for Soft mode, ever?

Different people and different organizations have different preferences
for line wrap. When you’re free of 80 column terminals, (either because
you have a phone which displays 30-50 characters per line or a client
which displays 90ish columns as you make your window wider, you might be
less thrilled with someone hard-wrapping at 72 characters.

Different people and different organizations have different
preferences
for line wrap. When you’re free of 80 column terminals, (either
because
you have a phone which displays 30-50 characters per line or a client
which displays 90ish columns as you make your window wider, you
might be
less thrilled with someone hard-wrapping at 72 characters.

I understand that, but I don’t understand “no wrap at all”. The
ticket I created has a few lines with 3000+ characters. That’s
never useful.

In theory, the input should be soft wrap, and the client should wrap
text at whatever is appropriate for the viewer, yah?

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

I understand that, but I don’t understand “no wrap at all”. The ticket I
created has a few lines with 3000+ characters. That’s never useful.

It sure can be. My mail clients all autowrap long lines. As a
personal preference, I generally find myself happier having my client
rewrap incoming mail than accepting someone else’s default.

In theory, the input should be soft wrap, and the client should wrap
text at whatever is appropriate for the viewer, yah?

That’s what soft wrapping is. “Wrap on display, not in the actual text”

It sure can be. My mail clients all autowrap long lines. As a
personal preference, I generally find myself happier having my
client
rewrap incoming mail than accepting someone else’s default.

This bug report was about the web interface.

In theory, the input should be soft wrap, and the client should wrap
text at whatever is appropriate for the viewer, yah?

That’s what soft wrapping is. “Wrap on display, not in the actual
text”

And back to my original report. When I create a ticket inside the RT
web interface, the paragraphs of text DO NOT WRAP when I view them
inside the very same RT web interface.

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

And back to my original report. When I create a ticket inside the RT
web interface, the paragraphs of text DO NOT WRAP when I view them
inside the very same RT web interface.

That’s very different. But with RT’s “Web 2” style, I can’t replicate it
on Firefox (Mac), Safari (Mac), Opera (Mac) or IE6 (WINE).

And back to my original report. When I create a ticket inside the RT
web interface, the paragraphs of text DO NOT WRAP when I view them
inside the very same RT web interface.

That’s very different. But with RT’s “Web 2” style, I can’t
replicate it
on Firefox (Mac), Safari (Mac), Opera (Mac) or IE6 (WINE).

I originally observed this in Camino(Mac) but replicated it on Firefox
Windows.

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

Jo Rhett wrote:> On Feb 10, 2009, at 1:43 PM, Jesse Vincent wrote:

And back to my original report. When I create a ticket inside the RT
web interface, the paragraphs of text DO NOT WRAP when I view them
inside the very same RT web interface.

That’s very different. But with RT’s “Web 2” style, I can’t replicate it
on Firefox (Mac), Safari (Mac), Opera (Mac) or IE6 (WINE).

I originally observed this in Camino(Mac) but replicated it on Firefox
Windows.

I see this occasionally with specific inbound emails. Suspect it has
more to do with the format/content of that specific email than with
general RT behavior.

Bill Davis

I just replicated it on every brower for both Mac and Windows, so it’s
definitely a “feature” in 3.8.2.On Feb 10, 2009, at 4:32 PM, Bill Davis wrote:

Jo Rhett wrote:

On Feb 10, 2009, at 1:43 PM, Jesse Vincent wrote:

And back to my original report. When I create a ticket inside
the RT web interface, the paragraphs of text DO NOT WRAP when I
view them inside the very same RT web interface.

That’s very different. But with RT’s “Web 2” style, I can’t
replicate it
on Firefox (Mac), Safari (Mac), Opera (Mac) or IE6 (WINE).

I originally observed this in Camino(Mac) but replicated it on
Firefox Windows.

I see this occasionally with specific inbound emails. Suspect it
has more to do with the format/content of that specific email than
with general RT behavior.

Bill Davis

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

I just replicated it on every brower for both Mac and Windows, so it’s
definitely a “feature” in 3.8.2.

Can you provide a screenshot of a whole ticket (with history) that
exhibits this?

And back to my original report. When I create a ticket inside the RT
web interface, the paragraphs of text DO NOT WRAP when I view them
inside the very same RT web interface.

That’s very different. But with RT’s “Web 2” style, I can’t
replicate it
on Firefox (Mac), Safari (Mac), Opera (Mac) or IE6 (WINE).

I just replicated it identically on

Camino 2.0b1 (Max)
Firefox 3.0.5 (Mac)
Firefox 3.0.6 (Windows)

This is using 3.8.2 on Freebsd, no extensions enabled. (I originally
found it when we had no extensions, and I disabled them again for this
test to be sure)

To replicate:

  1. Click “New Ticket In” on the top bar, or change the queue name to a
    different queue
  2. Type something in the subject line.
  3. Type a forever long paragraph in the body of the mail.
  4. Click “Create”
  5. View the ticket text under History and observe that the text is a
    single very long line with no wrapping

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

Can you provide a screenshot of a whole ticket (with history) that
exhibits this?

Attached.

Can you resend that after clicking ‘full headers’?

Also, have you customized RT’s ticket display to show message content
as a

?

Ok,

If I:

- Turn off the HTML composer
- Turn off hard wrapping in the plain-text composition window
- Go into my preferences and set RT to show plain text mail in a
  monospace font (inside a <pre>, essentially)

Then yes, RT will not wrap the content of your message.

I’m not really sure how much of a bug I consider that.

I’d be happy to see a css patch which improves the wrapping of plain
text mail when you’ve told it to use a monospace font.

If I:

  • Turn off the HTML composer
  • Turn off hard wrapping in the plain-text composition window
  • Go into my preferences and set RT to show plain text mail in a
    monospace font (inside a
    , essentially)

Then yes, RT will not wrap the content of your message.

I’m not really sure how much of a bug I consider that.

Perhaps a documentation bug? There actually isn’t much RT
documentation saying “these are the settings we expect to work best
for most people”

You haven’t even told me what this setting is…

  • Go into my preferences and set RT to show plain text mail in a
    monospace font (inside a
    , essentially)

I’d be fine to disable this if it’s not what you expect/test for/etc.
Just tell me what setting this is.

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

The only thing I can find in the configuration is $PlainTextPre which
was set to 1. I changed it to 0 and restarted apache and this has not
changed anything. I even created another test ticket to be certain.On Feb 10, 2009, at 6:08 PM, Jo Rhett wrote:

On Feb 10, 2009, at 5:33 PM, Jesse Vincent wrote:

If I:

  • Turn off the HTML composer
  • Turn off hard wrapping in the plain-text composition window
  • Go into my preferences and set RT to show plain text mail in a
    monospace font (inside a
    , essentially)

Then yes, RT will not wrap the content of your message.

I’m not really sure how much of a bug I consider that.

Perhaps a documentation bug? There actually isn’t much RT
documentation saying “these are the settings we expect to work best
for most people”

You haven’t even told me what this setting is…

  • Go into my preferences and set RT to show plain text mail in a
    monospace font (inside a
    , essentially)

I’d be fine to disable this if it’s not what you expect/test for/etc.
Just tell me what setting this is.


Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

FWIW, this setting is now 0 and there are still

 tags in the
output.
Go into my preferences and

$ grep TextPre /usr/local/etc/rt38/*
/usr/local/etc/rt38/RT_Config.pm:=item C<$PlainTextPre>
/usr/local/etc/rt38/RT_Config.pm:to be displayed correctly. By
setting $PlainTextPre they’ll be
/usr/local/etc/rt38/RT_Config.pm:Set($PlainTextPre, 0);
/usr/local/etc/rt38/RT_SiteConfig.pm:Set( $PlainTextPre, 0 );

Apache has been fully stopped and started and this behavior continues.On Feb 10, 2009, at 6:16 PM, Jo Rhett wrote:

The only thing I can find in the configuration is $PlainTextPre which
was set to 1. I changed it to 0 and restarted apache and this has not
changed anything. I even created another test ticket to be certain.

On Feb 10, 2009, at 6:08 PM, Jo Rhett wrote:

On Feb 10, 2009, at 5:33 PM, Jesse Vincent wrote:

If I:

  • Turn off the HTML composer
  • Turn off hard wrapping in the plain-text composition window
  • Go into my preferences and set RT to show plain text mail in a
    monospace font (inside a
    , essentially)

Then yes, RT will not wrap the content of your message.

I’m not really sure how much of a bug I consider that.

Perhaps a documentation bug? There actually isn’t much RT
documentation saying “these are the settings we expect to work best
for most people”

You haven’t even told me what this setting is…

  • Go into my preferences and set RT to show plain text mail in a
    monospace font (inside a
    , essentially)

I’d be fine to disable this if it’s not what you expect/test for/etc.
Just tell me what setting this is.


Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness

Perhaps deleting the mason cache before restarting apache may fix it?

Gordon

Jo Rhett wrote:

No change. Full apache stop. rm -rf /var/run/rt38/mason_data/obj.
Apache start.On Feb 10, 2009, at 6:48 PM, gordon@cryologic.com wrote:

Perhaps deleting the mason cache before restarting apache may fix it?

Gordon

Jo Rhett wrote:

FWIW, this setting is now 0 and there are still

 tags in the
output.
Go into my preferences and $ grep TextPre /usr/local/etc/rt38/* /usr/local/etc/rt38/RT_Config.pm:=item C<$PlainTextPre> /usr/local/etc/rt38/RT_Config.pm:to be displayed correctly. By setting $PlainTextPre they'll be /usr/local/etc/rt38/RT_Config.pm:Set($PlainTextPre, 0); /usr/local/etc/rt38/RT_SiteConfig.pm:Set( $PlainTextPre, 0 ); Apache has been fully stopped and started and this behavior continues.

Jo Rhett
Net Consonance : consonant endings by net philanthropy, open source
and other randomness