Ticket will not accept comments or replys

We found a single ticket where comments/replies are not getting appended
to the ticket, but they get sent out via email just fine.

This is not a permissions issue as other tickets in the same queue are
fine, plus the comments/replies get emailed out correctly. Just nothing
further happens to this one ticket.

Anyone ever seen this?

Whats in the database for this ticket (Transactions and Attachments
tables), it maybe an ugly character in an early attachment stopping the
history of being displayed??

Regards;
Roy

John Arends wrote:

I did some poking around in the database and couldn’t find anything
obvious, but what you suggest is my theory. It’s probably something in
the Attachments table since there isn’t a whole lot of data stored in
the Transactions table as best as I can tell.

I looked at the HTML of the page (view source in FireFox) and nothing
jumps out at me as incorrectly rendered. The page is not cut off halfway
or anything. The footer, and other parts of the page are rendered fine.
It just loses the ability to display any new transactions.

Raed El-Hames wrote:

Whats in the database for this ticket (Transactions and Attachments
tables), it maybe an ugly character in an early attachment stopping the
history of being displayed??

Regards;
Roy

John Arends wrote:

We found a single ticket where comments/replies are not getting appended
to the ticket, but they get sent out via email just fine.

This is not a permissions issue as other tickets in the same queue are
fine, plus the comments/replies get emailed out correctly. Just nothing
further happens to this one ticket.

Anyone ever seen this?


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

John Arends jarends@illinois.edu
Network Analyst
College of ACES - ITCS
University of Illinois at Urbana-Champaign

John Arends wrote:

I did some poking around in the database and couldn’t find anything
obvious, but what you suggest is my theory. It’s probably something in
the Attachments table since there isn’t a whole lot of data stored in
the Transactions table as best as I can tell.

I looked at the HTML of the page (view source in FireFox) and nothing
jumps out at me as incorrectly rendered. The page is not cut off halfway
or anything. The footer, and other parts of the page are rendered fine.
It just loses the ability to display any new transactions.

Another long shot. Is the ticket part of a merged ticket or do you merge
tickets on a regular basis?

We have an RT instance which has been upgraded multiple times starting
from 2.x and we don’t merge tickets that often (~20 total). About 4
months back we had two tickets which wouldn’t display history beyond a
certain point BUT if you displayed history newest to oldest instead of
oldest to newest you could see beyond that point but lost the older
transactions. The only thing I could find was that there was quite a bit
of logging about a merged ticket. I just ‘unmerged’ the tickets and if I
remember correctly I could show the whole history of this ticket.

Hope this helps you with your problem.

Regards,

Joop

RT 3.8 seems to handle HTML a lot better, as the issue we were having
went away after updating. The update to 3.8.2 from 3.6.5 had been
planning for several months, so we went ahead and were pleasantly
surprised that the update resolved the problem.

We did a little more troubleshooting, and it looks like some character
that was inserted as part of chat sessions with Dell was causing the
problem. I couldn’t find the character to figure out what it was, but in
any event, the problem does not occur in newer versions of RT.

John Arends wrote:

I did some poking around in the database and couldn’t find anything
obvious, but what you suggest is my theory. It’s probably something in
the Attachments table since there isn’t a whole lot of data stored in
the Transactions table as best as I can tell.

I looked at the HTML of the page (view source in FireFox) and nothing
jumps out at me as incorrectly rendered. The page is not cut off halfway
or anything. The footer, and other parts of the page are rendered fine.
It just loses the ability to display any new transactions.

Raed El-Hames wrote:

Whats in the database for this ticket (Transactions and Attachments
tables), it maybe an ugly character in an early attachment stopping the
history of being displayed??

Regards;
Roy

John Arends wrote:

We found a single ticket where comments/replies are not getting appended
to the ticket, but they get sent out via email just fine.

This is not a permissions issue as other tickets in the same queue are
fine, plus the comments/replies get emailed out correctly. Just nothing
further happens to this one ticket.

Anyone ever seen this?


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

John Arends jarends@illinois.edu
Network Analyst
College of ACES - ITCS
University of Illinois at Urbana-Champaign