Ticket updates/creates via SSL redirect to https://rt.domain.tld:80/


#1

Hi,

I have RT running on a sub-domain of https://rt.domain.tld. $WebPort
is set to 443 and $WebBaseURL is set to https://rt.domain.tld.

When I create or update a ticket, the changes are posted to the
ticket but then I’m redirected to this URL:

https://rt.domain.tld:80/Ticket/Display.html?id=#

The problem is the “:80” in the URL–this breaks the link and doesn’t
display the ticket after applying the updates to it. If I delete the
":80", the ticket displays fine.

The only log entry I see that indicates a problem is in Apache’s
access_log

[23/May/2008:14:54:04 -0700] "\x16\x03\x01" 200 238 "-" "-"

This, or a similar entry, displays each time I have this problem.

If I disable SSL on the subdomain, everything works fine and this log
entry doesn’t display.

I’ve googled for issues relating to RT and Apache but haven’t found
anything that has led to a solution.

Can anyone offer me any input for resolving this problem?

~ Tom


#2

Hi Tom

I haven’t dig apache for a while, the problem seems because of the
wrong $ENV{‘SERVER_PORT’}

If you can set “SERVER_PORT” correctly( which is 443 for your
instance ) in apache,
then the problem will be gone, If not, here’s a ad hoc fixing:
find the string “$ENV{‘SERVER_PORT’}” in sub Redirect in lib/RT/
Interface/Web.pm, replace it by “$RT::WebPort”

wish this help :)On May 25, 2008, at 2:47 AM, Tom Smith wrote:

Hi,

I have RT running on a sub-domain of https://rt.domain.tld. $WebPort
is set to 443 and $WebBaseURL is set to https://rt.domain.tld.

When I create or update a ticket, the changes are posted to the
ticket but then I’m redirected to this URL:

https://rt.domain.tld:80/Ticket/Display.html?id=#

The problem is the “:80” in the URL–this breaks the link and doesn’t
display the ticket after applying the updates to it. If I delete the
":80", the ticket displays fine.

The only log entry I see that indicates a problem is in Apache’s
access_log

[23/May/2008:14:54:04 -0700] “\x16\x03\x01” 200 238 “-” “-”

This, or a similar entry, displays each time I have this problem.

If I disable SSL on the subdomain, everything works fine and this log
entry doesn’t display.

I’ve googled for issues relating to RT and Apache but haven’t found
anything that has led to a solution.

Can anyone offer me any input for resolving this problem?

~ Tom


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

best wishes
sunnavy


#3

Hi sunnavy,

That change did resolve the problem. Thank you very much for you
input–I really appreciate it.

Initially, I wasn’t sure if this was an RT issue or an Apache issue.
After your reply, I looked further into Apache issues that may cause
this and found the problem…

The problem was caused by an SSL misconfiguration. After correcting
the misconfiguration, everything works great!

Thanks again for you help!

~ TomOn May 24, 2008, at 8:40 PM, sunnavy wrote:

Hi Tom

I haven’t dig apache for a while, the problem seems because of the
wrong $ENV{‘SERVER_PORT’}

If you can set “SERVER_PORT” correctly( which is 443 for your
instance ) in apache,
then the problem will be gone, If not, here’s a ad hoc fixing:
find the string “$ENV{‘SERVER_PORT’}” in sub Redirect in lib/RT/
Interface/Web.pm, replace it by “$RT::WebPort”

wish this help :slight_smile:

On May 25, 2008, at 2:47 AM, Tom Smith wrote:

Hi,

I have RT running on a sub-domain of https://rt.domain.tld. $WebPort
is set to 443 and $WebBaseURL is set to https://rt.domain.tld.

When I create or update a ticket, the changes are posted to the
ticket but then I’m redirected to this URL:

https://rt.domain.tld:80/Ticket/Display.html?id=#

The problem is the “:80” in the URL–this breaks the link and doesn’t
display the ticket after applying the updates to it. If I delete the
":80", the ticket displays fine.

The only log entry I see that indicates a problem is in Apache’s
access_log

[23/May/2008:14:54:04 -0700] “\x16\x03\x01” 200 238 “-” “-”

This, or a similar entry, displays each time I have this problem.

If I disable SSL on the subdomain, everything works fine and this log
entry doesn’t display.

I’ve googled for issues relating to RT and Apache but haven’t found
anything that has led to a solution.

Can anyone offer me any input for resolving this problem?

~ Tom


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

best wishes
sunnavy