Ticket Custom Fields Not Visible

Okay after reading through old posts on various lists and google I am
still having problems.

My problem is that I have created a custom field for use in RT:IR tickets
(blocks, incidents, incident reports, investigations) and it will not show
up in the create ticket screen.

The custom field is enabled. It is assigned to the queues. It has correct
permission’s.

I’ve tried creating tickets as root and another user with the correct
permission’s and nothing works.

Most of the responses I’ve read involved permission’s. I have already set
ShowCustomField ModifyCustomField on every user, group, system group, etc
to no avail.

I have also tried setting it up globally, no luck.

I have tried adding it to the display columns in the advanced tab as one
user suggested and nothing.

I have looked at the tables in MySQL to see if there were any errors in
the table or fields, no luck.

I am running RT 3.8.5 with RT:IR and RT:FM.

Any suggestions would be appreciated.

Thanks,
Paul J

pjarmillo,

You actually granted the rights at both the user AND group level? Hmm,
if all users are in some sort of group, you shouldn’t do that because
you might lose track of what maintenance you do. I recommend leaving
users alone and just grant at the group level. You might run into a
problem removing a permission from a group but the user retains it and
then you’ll have a debug problem.
Now, as to your problem, I’m not sure how 3.8.x does it, but in 3.6.4,
which I have has Custom Field rights in two areas; 1) when you navigate
to Configuration->Global->Group Rights and 2) Configuration->Custom
Fields->"Select Field->Group Rights. If you did the first (in 3.6) set,
then that won’t get the job done. You HAVE to grant “SeeCustomField"
using the second navigation in order to “See” them and
"ModifyCustomField” if you want them to enter/select values. Hope this
helps.

Kenn
LBNLOn 10/20/2009 5:56 AM, pjaramillo@kcp.com wrote:

Okay after reading through old posts on various lists and google I am
still having problems.

My problem is that I have created a custom field for use in RT:IR tickets
(blocks, incidents, incident reports, investigations) and it will not show
up in the create ticket screen.

The custom field is enabled. It is assigned to the queues. It has correct
permission’s.

I’ve tried creating tickets as root and another user with the correct
permission’s and nothing works.

Most of the responses I’ve read involved permission’s. I have already set
ShowCustomField ModifyCustomField on every user, group, system group, etc
to no avail.

I have also tried setting it up globally, no luck.

I have tried adding it to the display columns in the advanced tab as one
user suggested and nothing.

I have looked at the tables in MySQL to see if there were any errors in
the table or fields, no luck.

I am running RT 3.8.5 with RT:IR and RT:FM.

Any suggestions would be appreciated.

Thanks,
Paul J


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Ken,
I actually work for the DoE at KCP. Good to see others are using RT
successfully. Me on the other hand, not so successful and I’m getting to
the point of looking at another product.

My initial configuration was strictly group based, however due to this
problem I experimented with every permutation of permission possible. I
have since rolled back to just group based permissions.

Both SeeCustomField and ModifyCustomField are already granted to the
correct user-defined groups.
The custom field itself is already applied to the correct Queues.

Does 3.8.5 just not work? Below is the actual custom field information.
Yes I know the regex is lame, its a starting point.

Custom Field

Name: _RTIR_Domain
Description: Domains for RTIR queues
Type: Enter multiple values
Applies to: Tickets
Validation: (?#DOMAIN)^.*.[a-z]{2,3}$
Link values to:
Include page:
Enabled Checked

Thanks,
Paul J

From:
Ken Crocker kfcrocker@lbl.gov
To:
pjaramillo@kcp.com
Cc:
rt-users@lists.bestpractical.com
Date:
10/20/2009 11:53 AM
Subject:
Re: [rt-users] Ticket Custom Fields Not Visible

pjarmillo,

You actually granted the rights at both the user AND group level? Hmm,
if all users are in some sort of group, you shouldn’t do that because
you might lose track of what maintenance you do. I recommend leaving
users alone and just grant at the group level. You might run into a
problem removing a permission from a group but the user retains it and
then you’ll have a debug problem.
Now, as to your problem, I’m not sure how 3.8.x does it, but in 3.6.4,
which I have has Custom Field rights in two areas; 1) when you navigate
to Configuration->Global->Group Rights and 2) Configuration->Custom
Fields->"Select Field->Group Rights. If you did the first (in 3.6) set,
then that won’t get the job done. You HAVE to grant “SeeCustomField"
using the second navigation in order to “See” them and
"ModifyCustomField” if you want them to enter/select values. Hope this
helps.

Kenn
LBNL

Okay after reading through old posts on various lists and google I am
still having problems.

My problem is that I have created a custom field for use in RT:IR
tickets
(blocks, incidents, incident reports, investigations) and it will not
show
up in the create ticket screen.

The custom field is enabled. It is assigned to the queues. It has
correct
permission’s.

I’ve tried creating tickets as root and another user with the correct
permission’s and nothing works.

Most of the responses I’ve read involved permission’s. I have already
set
ShowCustomField ModifyCustomField on every user, group, system group,
etc

Ken,
I actually work for the DoE at KCP. Good to see others are using RT
successfully. Me on the other hand, not so successful and I’m getting to
the point of looking at another product.

My initial configuration was strictly group based, however due to this
problem I experimented with every permutation of permission possible. I
have since rolled back to just group based permissions.

Both SeeCustomField and ModifyCustomField are already granted to the
correct user-defined groups.
The custom field itself is already applied to the correct Queues.

Does 3.8.5 just not work? Below is the actual custom field information.
Yes I know the regex is lame, its a starting point.

Custom Field

Name: _RTIR_Domain

Paul

Don’t do that. RTIR is a prefix that RTIR uses for internal custom
fields. Try just calling it Domain.

-kevin

Paul,

I was having problems finding the permissions I needed awhile aback.  I finally went to configuration  -> Global -> User Rights, and just selected everything for a single user.    If that user still can't see what it is you are looking fro, then it probably isn't a permission problem!    If the user can, then start removing rights.    For me, I found I needed ModifySelf, when I REALLY didn't want to grant that right....From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of pjaramillo@kcp.com

Sent: Tuesday, October 20, 2009 1:50 PM
To: Ken Crocker
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Ticket Custom Fields Not Visible

Ken,
I actually work for the DoE at KCP. Good to see others are using RT successfully. Me on the other hand, not so successful and I’m getting to the point of looking at another product.

My initial configuration was strictly group based, however due to this problem I experimented with every permutation of permission possible. I have since rolled back to just group based permissions.

Both SeeCustomField and ModifyCustomField are already granted to the correct user-defined groups.
The custom field itself is already applied to the correct Queues.

Does 3.8.5 just not work? Below is the actual custom field information.
Yes I know the regex is lame, its a starting point.

Custom Field

Name: _RTIR_Domain
Description: Domains for RTIR queues
Type: Enter multiple values
Applies to: Tickets
Validation: (?#DOMAIN)^.*.[a-z]{2,3}$
Link values to:
Include page:
Enabled Checked

Thanks,
Paul J

From:
Ken Crocker kfcrocker@lbl.gov
To:
pjaramillo@kcp.com
Cc:
rt-users@lists.bestpractical.com
Date:
10/20/2009 11:53 AM
Subject:
Re: [rt-users] Ticket Custom Fields Not Visible

pjarmillo,

You actually granted the rights at both the user AND group level? Hmm, if all users are in some sort of group, you shouldn’t do that because you might lose track of what maintenance you do. I recommend leaving users alone and just grant at the group level. You might run into a problem removing a permission from a group but the user retains it and then you’ll have a debug problem.
Now, as to your problem, I’m not sure how 3.8.x does it, but in 3.6.4, which I have has Custom Field rights in two areas; 1) when you navigate
to Configuration->Global->Group Rights and 2) Configuration->Custom
Fields->"Select Field->Group Rights. If you did the first (in 3.6) set,
then that won’t get the job done. You HAVE to grant "SeeCustomField"
using the second navigation in order to “See” them and “ModifyCustomField” if you want them to enter/select values. Hope this helps.

Kenn
LBNL

Okay after reading through old posts on various lists and google I am
still having problems.

My problem is that I have created a custom field for use in RT:IR
tickets
(blocks, incidents, incident reports, investigations) and it will not
show
up in the create ticket screen.

The custom field is enabled. It is assigned to the queues. It has
correct
permission’s.

I’ve tried creating tickets as root and another user with the correct
permission’s and nothing works.

Most of the responses I’ve read involved permission’s. I have already
set
ShowCustomField ModifyCustomField on every user, group, system group,
etc
to no avail.

I have also tried setting it up globally, no luck.

I have tried adding it to the display columns in the advanced tab as
one

user suggested and nothing.

I have looked at the tables in MySQL to see if there were any errors
in the table or fields, no luck.

I am running RT 3.8.5 with RT:IR and RT:FM.

Any suggestions would be appreciated.

Thanks,
Paul J


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com Commercial support:
sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com
This e-mail message is intended only for the personal use of the recipient(s) named above. If you are not an intended recipient, you may not review, copy or distribute this message. If you have received this communication in error, please notify the Hearst Service Center (cadmin@hearstsc.com) immediately by email and delete the original message.

pjaramillo,

I have created several sets of documentation for us here, from a User
guide to a Queue manager guide, glossary, permissions guide, perl scrips
to automatically update Custom Fields when a ticket undergoes certain
changes, etc. We can take this offline if you’d like and I’ll be glad to
show you how we work it. RT works great for us. We have a Review &
Approval flow as well as a QA workFlow ( we like our own better than the
RT one). Let me know.

Kenn
LBNLOn 10/20/2009 10:50 AM, pjaramillo@kcp.com wrote:

Ken,
I actually work for the DoE at KCP. Good to see others are using RT
successfully. Me on the other hand, not so successful and I’m getting to
the point of looking at another product.

My initial configuration was strictly group based, however due to this
problem I experimented with every permutation of permission possible. I
have since rolled back to just group based permissions.

Both SeeCustomField and ModifyCustomField are already granted to the
correct user-defined groups.
The custom field itself is already applied to the correct Queues.

Does 3.8.5 just not work? Below is the actual custom field information.
Yes I know the regex is lame, its a starting point.

Custom Field

Name: _RTIR_Domain
Description: Domains for RTIR queues
Type: Enter multiple values
Applies to: Tickets
Validation: (?#DOMAIN)^.*.[a-z]{2,3}$
Link values to:
Include page:
Enabled Checked

Thanks,
Paul J

From:
Ken Crocker kfcrocker@lbl.gov
To:
pjaramillo@kcp.com
Cc:
rt-users@lists.bestpractical.com
Date:
10/20/2009 11:53 AM
Subject:
Re: [rt-users] Ticket Custom Fields Not Visible

pjarmillo,

You actually granted the rights at both the user AND group level? Hmm,
if all users are in some sort of group, you shouldn’t do that because
you might lose track of what maintenance you do. I recommend leaving
users alone and just grant at the group level. You might run into a
problem removing a permission from a group but the user retains it and
then you’ll have a debug problem.
Now, as to your problem, I’m not sure how 3.8.x does it, but in 3.6.4,
which I have has Custom Field rights in two areas; 1) when you navigate
to Configuration->Global->Group Rights and 2) Configuration->Custom
Fields->"Select Field->Group Rights. If you did the first (in 3.6) set,
then that won’t get the job done. You HAVE to grant “SeeCustomField"
using the second navigation in order to “See” them and
"ModifyCustomField” if you want them to enter/select values. Hope this
helps.

Kenn
LBNL

On 10/20/2009 5:56 AM, pjaramillo@kcp.com wrote:

Okay after reading through old posts on various lists and google I am
still having problems.

My problem is that I have created a custom field for use in RT:IR

tickets

(blocks, incidents, incident reports, investigations) and it will not

show

up in the create ticket screen.

The custom field is enabled. It is assigned to the queues. It has

correct

permission’s.

I’ve tried creating tickets as root and another user with the correct
permission’s and nothing works.

Most of the responses I’ve read involved permission’s. I have already

set

ShowCustomField ModifyCustomField on every user, group, system group,

etc

to no avail.

I have also tried setting it up globally, no luck.

I have tried adding it to the display columns in the advanced tab as one

user suggested and nothing.

I have looked at the tables in MySQL to see if there were any errors in
the table or fields, no luck.

I am running RT 3.8.5 with RT:IR and RT:FM.

Any suggestions would be appreciated.

Thanks,
Paul J


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Hi all

i want to use RT with our Ldap central directory, install seems OK, i can
log user with this plugin, but those users have no right within RT.

I can log myself with root/password, but i can’t see other user (create by
Ldap Plugin, in configuration/user) ?

what i miss ??

i hope this list can help me to test RT.

Regards

On Tue, 20 Oct 2009 22:33:58 +0200, "Jean-Noel HAYART"
jnhayart@nordnet.Fr said:

i want to use RT with our Ldap central directory, install seems OK, i can
log user with this plugin, but those users have no right within RT.

I can log myself with root/password, but i can’t see other user (create
by Ldap Plugin, in configuration/user) ?

The ExternalAuth plugin creates unprivileged users by default when they
first log in, you will have to set each of them to privileged and assign
them rights or a group with rights.
To search for unprivileged users in Configuration/Users, search for all
users who match “%” (without quotes) and it will show all privileged as
well as unprivileged users (by default it only shows privileged).