This is my first attempt to install RT on Ubuntu 8.10desktop with fastcgi and nginx 0.6.32

Good point John. rt is installed in /usr/local/rt

This area has permissions as in the attached screenshot. Since the
webserver runs as daemon:daemon - would I be best to do this:

chown -R root:daemon /usr/local/rt or chown -R daemon:daemon /usr/local/rtFrom: “John” nimbius@sdf.lonestar.org
Sent: Tue, November 11, 2008 9:12
Subject:Re: [rt-users] This is my first attempt to install RT on Ubuntu
8.10desktop with fastcgi and nginx 0.6.32.

out of curiousity, is your webserver running as a user with permissions to
access the data in /opt/rt3/ ?

the RT wiki outlines permissions, but since youre running your http
server sans suid, you can use the latter (daemon:daemon)

beware: your webserver now has access to your DB config…so id suggest
hosting this on a linux with execshield or selinux extensions.On Tue, 11 Nov 2008, Jim Neundorf wrote:

Date: Tue, 11 Nov 2008 08:54:07 -0600 (CST)
From: Jim Neundorf jneundorf@wwsys.net
To: John nimbius@sdf.lonestar.org
Cc: RT-Users@lists.bestpractical.com
Subject: Re: [rt-users] This is my first attempt to install RT on Ubuntu
8.10desktop with fastcgi and nginx 0.6.32.

Good point John. rt is installed in /usr/local/rt

This area has permissions as in the attached screenshot. Since the
webserver runs as daemon:daemon - would I be best to do this:

chown -R root:daemon /usr/local/rt or chown -R daemon:daemon /usr/local/rt

----- Original Message -----
From: “John” nimbius@sdf.lonestar.org
Sent: Tue, November 11, 2008 9:12
Subject:Re: [rt-users] This is my first attempt to install RT on Ubuntu
8.10desktop with fastcgi and nginx 0.6.32.

out of curiousity, is your webserver running as a user with permissions to
access the data in /opt/rt3/ ?

On Tue, 11 Nov 2008, Jim Neundorf wrote:

Date: Tue, 11 Nov 2008 07:08:00 -0500
From: Jim Neundorf jneundorf@wwsys.net
To: RT-Users@lists.bestpractical.com
Subject: [rt-users] This is my first attempt to install RT on Ubuntu 8.10
desktop with fastcgi and nginx 0.6.32.

Here are the steps I’ve taken:

STEP 1 RT configure script:

./configure --prefix=/usr/local/rt
–enable-graphviz
–enable-gd
–with-web-handler=fastcgi
–with-db-type=Pg
–with-db-host=localhost
–with-db-port=5432
–with-db-rt-host=localhost
–with-db-dba=postgres
–with-db-database=rt
–with-db-rt-user=ldc
–with-db-rt-pass=ldc4ever
–with-web-user=daemon
–with-web-group=daemon
–with-rt-group=daemon

  • Note nginx runs as user daemon, group daemon

STEP 2 ran:

make testdeps (ran without issues)
make intitialize-database (ran without issues)

  • Note at this point I assume rt is installed correctly

STEP 3 /etc/init.d/rt script:

#!/bin/sh

RTPATH=/usr/local/rt
RTUSER=daemon
FCGI_SOCKET_PATH=$RTPATH/var/session_data

case $1 in
start)
echo -n "Starting RT: mason_handler.fcgi"
cd $RTPATH
export FCGI_SOCKET_PATH
su $RTUSER -c perl bin/mason_handler.fcgi &
echo
;;

stop)
echo -n "Stopping RT: "
PIDS=ps axww | awk '/[m]ason_handler.fcgi/ { print $1}'
if [ -n “$PIDS” ]
then
echo -n kill -TERM $PIDS
kill $PIDS
echo
else
echo RT not running
fi
;;

restart|force-reload)
$0 stop
$0 start
;;

*)
echo "Usage: /etc/init.d/rt { stop | start | restart }"
exit 1
;;
esac

chown -R daemon:daemon /usr/local/rt/var/log
chown -R daemon:daemon /usr/local/rt/var/session_data
chmod -R 775 /usr/local/rt/var/log
chmod -R 775 /usr/local/rt/var/session_data

STEP 4 Ran the /etc/init.d/rt script

/etc/init.d/rt start -> Starting RT: mason_handler.fcgi
/etc/init.d/rt stop -> Stopping RT: RT not running

This is where I’m stuck - I can’t seem to get the mason_handler to run
and I don’t see any output in the /usr/local/rt/var/log directory.

I would really appreciate any insights on what I can do to move past
this point to get RT up and running. Thanks.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

----- End of original message -----

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

Thank you for the quick response and early warning John.

I’ve made the changes and the mason_handler will not run (see attached).
I will review the rt wiki permissions for other ideas.

If you have any more thoughts - I’m all ears! One day I’ll send a picture
as proof.

JimFrom: “John” nimbius@sdf.lonestar.org
Sent: Tue, November 11, 2008 9:57
Subject:Re: [rt-users] This is my first attempt to install RT on Ubuntu
8.10desktop with fastcgi and nginx 0.6.32.

the RT wiki outlines permissions, but since youre running your http
server sans suid, you can use the latter (daemon:daemon)

beware: your webserver now has access to your DB config…so id suggest
hosting this on a linux with execshield or selinux extensions.