Test Failure on Install of Business::Hours

I am having problems getting the required Perl module Business::Hours to install. I created a ticket using the CPAN bug tracking system. Here is a link to the ticket for anyone interested:

http://rt.cpan.org/NoAuth/Bug.html?id=13374

Basically the tests are failing while being built on FreeBSD 5.4 and the also didn’t work on 5.3. Any help would be appreciated.

Thanks,
Mike

I am having problems getting the required Perl module Business::Hours to install. I created a ticket using the CPAN bug tracking system. Here is a link to the ticket for anyone interested:

http://rt.cpan.org/NoAuth/Bug.html?id=13374

Basically the tests are failing while being built on FreeBSD 5.4 and the also didn’t work on 5.3. Any help would be appreciated.
I had the same problem on debian, and I doubt it is OS-specific. I’ve
included a patch (that’s about a month old - meant to send it sooner but
forgot) that seems to fix the problem for me. See the cpan ticket for
the patch itself.

hth.

signature.asc (189 Bytes)

Dave Glasser has fixed the module on CPAN and it installed successfully for me.

Thanks to everyone that responded or worked to fixe the problem.

MikeOn Fri, Jul 08, 2005 at 09:13:58AM +1000, Rudolph Pereira wrote:

On Thu, Jul 07, 2005 at 03:03:35PM -0600, Mike Forrester wrote:

I am having problems getting the required Perl module Business::Hours to install. I created a ticket using the CPAN bug tracking system. Here is a link to the ticket for anyone interested:

http://rt.cpan.org/NoAuth/Bug.html?id=13374

Basically the tests are failing while being built on FreeBSD 5.4 and the also didn’t work on 5.3. Any help would be appreciated.
I had the same problem on debian, and I doubt it is OS-specific. I’ve
included a patch (that’s about a month old - meant to send it sooner but
forgot) that seems to fix the problem for me. See the cpan ticket for
the patch itself.

hth.