Strange localization problem

Hi,

Just encountered a strange localization problem.

Just installed rt3 on a second Solaris system ( beta production test )
(same perl ( except threading) same apache 1.3.27, same mod_perl,…)

copied and modded httpd.conf from the first system ( only the virtual
host section )
Installed rt3, init database,…

Ok, but in the client browser ( the same ), on the second system the
login page shows up in, I’m guessing Katakana,… Go figure…

Works fine on the first system with the same browser

Any pointers where to check for the localization ?

TIA

Brussels University
Pleinlaan 2
Computer Center VUB/ULB (VUBnet)
Ing. Robert Jansen
B-1050 Brussels
Belgium (Europe)

email: rjansen@vub.ac.be
Tel: +32-2-650.36.94
Secr: +32-2-650.37.38
Fax: +32-2-650.37.40

The second browser is the beta release of Apple’s Safari, right?
The author of Locale::Maketext, which we’re using for our localization
substrate has identified the problem and will be releasing a fixed
version within the next several days.On Wed, Apr 02, 2003 at 07:43:56PM +0200, Jansen Robert wrote:

Hi,

Just encountered a strange localization problem.

Just installed rt3 on a second Solaris system ( beta production test )
(same perl ( except threading) same apache 1.3.27, same mod_perl,…)

copied and modded httpd.conf from the first system ( only the virtual
host section )
Installed rt3, init database,…

Ok, but in the client browser ( the same ), on the second system the
login page shows up in, I’m guessing Katakana,… Go figure…

Works fine on the first system with the same browser

Any pointers where to check for the localization ?

TIA


Brussels University
Pleinlaan 2
Computer Center VUB/ULB (VUBnet)
Ing. Robert Jansen
B-1050 Brussels
Belgium (Europe)

email: rjansen@vub.ac.be
Tel: +32-2-650.36.94
Secr: +32-2-650.37.38
Fax: +32-2-650.37.40


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

At 12:46 PM -0500 4/2/03, Jesse Vincent wrote:

The second browser is the beta release of Apple’s Safari, right?
The author of Locale::Maketext, which we’re using for our localization
substrate has identified the problem and will be releasing a fixed
version within the next several days.

Hi,

Just encountered a strange localization problem.

Just installed rt3 on a second Solaris system ( beta production test )
(same perl ( except threading) same apache 1.3.27, same mod_perl,…)

copied and modded httpd.conf from the first system ( only the virtual
host section )
Installed rt3, init database,…

Ok, but in the client browser ( the same ), on the second system the
login page shows up in, I’m guessing Katakana,… Go figure…

Works fine on the first system with the same browser

Any pointers where to check for the localization ?

TIA

Yes, I’m using Apple Safari as the client browser.
Works fine (and still is) when using the first Solaris system with rt3.

Simply genius ! I’m impressed.

Yep, that’s the case. Thanks for the help.

Brussels University
Pleinlaan 2
Computer Center VUB/ULB (VUBnet)
Ing. Robert Jansen
B-1050 Brussels
Belgium (Europe)

email: rjansen@vub.ac.be
Tel: +32-2-650.36.94
Secr: +32-2-650.37.38
Fax: +32-2-650.37.40

Yes, I’m using Apple Safari as the client browser.
Works fine (and still is) when using the first Solaris system with rt3.

Simply genius ! I’m impressed.

Yep, that’s the case. Thanks for the help.

Locale::Maketext 1.04 is being uploaded as we speak and should correct
this problem.

-j

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Yes, I’m using Apple Safari as the client browser.
Works fine (and still is) when using the first Solaris system with rt3.

Simply genius ! I’m impressed.

Yep, that’s the case. Thanks for the help.

Locale::Maketext 1.04 is being uploaded as we speak and should correct
this problem.

-j

Mhhh,…

This is getting weird.

Just installed Locale::Maketext version 1.04 that Sean Burke send me as a tarball.
and updated Locale::Maketext::Fuzzy and Locale::Maketext::Lexicon from the main CPAN site.
(Just to make shure…)

Safari still display katakana when using the “default” Text Encoding setting in the browser
(which is probably UTF-8, because choosing this Text Enconding yields the same result in the browser)

Any ideas

Thanks to Sean Burke for sending me the tarball. I appreciate.

Any ideas ?

Safari still display katakana when using the “default” Text Encoding setting in the browser
(which is probably UTF-8, because choosing this Text Enconding yields the same result in the browser)

Any ideas

Do you get the same issues when displaying rt3.bestpractical.com?

Thanks to Sean Burke for sending me the tarball. I appreciate.

Any ideas ?


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Safari still display katakana when using the “default” Text Encoding setting in the browser
(which is probably UTF-8, because choosing this Text Enconding yields the same result in the browser)

Any ideas

Do you get the same issues when displaying rt3.bestpractical.com?

No. Even stranger,… when I change the Text Encoding in the browser, The rt3.bestpractical.com page REMAINS in english !

With my setup, my page is redrawn trying to render the Text Encoding which I choose.
(BTW: Japanese(MacOS) looks good, other give gibberish)

I can try to update perl modules, maybe an old module from a local European mirror.
I reconfigured my perl CPAN to use the main perl CPAN site only.

How do you update in bulk all the installed module in perl ?
(searched CPAN and perl, but no clear pointers on this matter).

Any pointers appreciated.

TIA

Jansen Robert

At 12:18 AM 3/04/2003 +0200, Robert Jansen wrote:

Do you get the same issues when displaying rt3.bestpractical.com?

No. Even stranger,… when I change the Text Encoding in the browser, The
rt3.bestpractical.com page REMAINS in english !

With my setup, my page is redrawn trying to render the Text Encoding which
I choose.
(BTW: Japanese(MacOS) looks good, other give gibberish)

I can try to update perl modules, maybe an old module from a local
European mirror.
I reconfigured my perl CPAN to use the main perl CPAN site only.

How do you update in bulk all the installed module in perl ?
(searched CPAN and perl, but no clear pointers on this matter).

Any pointers appreciated.

Robert,
I had the same problem - but after installing
Locale::Maketext-1.04, 1.03 was still installed - and included earlier by
Perl! What does:
perl -e 'use Locale::Maketext; print $Locale::Maketext::VERSION;'
tell you?

perl -V will tell you the layout of your @INC module search path:

@INC:
/usr/local/lib/perl5/5.8.0/sun4-solaris
/usr/local/lib/perl5/5.8.0
/usr/local/lib/perl5/site_perl/5.8.0/sun4-solaris
/usr/local/lib/perl5/site_perl/5.8.0
/usr/local/lib/perl5/site_perl

I had to:

cd /usr/local/perl5
find . -name ‘Maketext*’
./5.8.0/Locale/Maketext.pm
./5.8.0/Locale/Maketext.pod
./5.8.0/Locale/Maketext
./site_perl/5.8.0/sun4-solaris/auto/Locale/Maketext
./site_perl/5.8.0/Locale/Maketext
./site_perl/5.8.0/Locale/Maketext.pod
./site_perl/5.8.0/Locale/Maketext.pm

and then remove the 5.8.0/Locale/Maketext files (where version 1.03 lived).
This fixed my problem. And then the restart of Apache to ensure it didn’t
have Locale::Maketext cached.

-Brook

= /// /// /// /// _/ _/ Brook Schofield =
= _/ _/ _/ _/ _/ _/ _/ _/ _/ / B.Schofield@griffith.edu.au =
= // //
/ _/ _/ _/ _/ // Ph: +61 7 387 53779 - WCN 0.28 =
= _/ _/ _/ _/ _/ _/ _/ _/ _/ / Directory Services Integration =
= //
/ / / /// /// _/ _/ Griffith University QLD 4111 =

Do you get the same issues when displaying rt3.bestpractical.com?

No. Even stranger,… when I change the Text Encoding in the browser,
The rt3.bestpractical.com page REMAINS in english !

For safari, You have to change the language settings in the
System Preferences/International Preference Pane. Text Encoding does
not change the way the browser asks for languages, only the way
incoming characters are interpreted.

Regards,
Harald
Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg