Still struggling with truncated attachments

I’m running RT-3.6.1, and I’m having problems with attachments. The
problem started when I switched from mysql on the local machine to a
central mysql service. I have this sinking feeling that the cause of
the problem is that the new database server has a default character set
of UTF8. I’ve tried ALTER-ing the Attachments table to be binary and
latin1, neither of which seem to make the right thing happen.

What does happen is that the attachment is saved into the database, but
it’s truncated at (I think) the first NULL character. There may be
other characters that trigger this, but it’s clear that, for instance,
PDFs are saved as 10 bytes (basically, just the file magic). Images
mostly end up being just file magic.

So, any ideas? Is there a specific character set that should be used
for RT tables? Are there specific settings for the my.cnf that are
required to move the data around?