Statistics don't show graphs

Hello,

i just installed the Statistics package which is in the contrib code
directory. But now the statistics don’t show any graphs. I installed
GD::Graph and it’s dependencies (libgd). IMHO the versions should be
correct. Any hints?

Thanx,
Daniel

From time to time i get an error message when calling on of the
statistics pages in the rt.log:
[Sun Nov 30 20:59:59 2003] [warning]: Trying to check RT::Queue rights
for an unspecified RT::Queue at
/usr/local/rt3/lib/RT/Principal_Overlay.pm line 354

RT::Principal::HasRight(‘RT::Principal=HASH(0x945eba8)’,‘Object’,‘RT::
Queue=HASH(0x9459a40)’,‘Right’,‘SeeQueue’) called at
/usr/local/rt3/lib/RT/User_Overlay.pm line 1450

RT::User::HasRight(‘RT::User=HASH(0x945edbc)’,‘Object’,‘RT::
Queue=HASH(0x9459a40)’,‘Right’,‘SeeQueue’) called at
/usr/local/rt3/lib/RT/CurrentUser.pm line 300

RT::CurrentUser::HasRight(‘RT::
CurrentUser=HASH(0x946b9b0)’,‘Object’,‘RT::
Queue=HASH(0x9459a40)’,‘Right’,‘SeeQueue’) called at
/usr/local/rt3/lib/RT/Queue_Overlay.pm line 1004

RT::Queue::HasRight(‘RT::Queue=HASH(0x9459a40)’,‘Principal’,‘RT::
CurrentUser=HASH(0x946b9b0)’,‘Right’,‘SeeQueue’) called at
/usr/local/rt3/lib/RT/Queue_Overlay.pm line 970

RT::Queue::CurrentUserHasRight(‘RT::Queue=HASH(0x9459a40)’,‘SeeQueue’)
called at /usr/local/rt3/lib/RT/Queue_Overlay.pm line 946
RT::Queue::_Value(‘RT::Queue=HASH(0x9459a40)’,‘Name’) called at
/usr/local/lib/perl5/site_perl/5.8.0/DBIx/SearchBuilder/Record.pm line
409

DBIx::SearchBuilder::Record::ANON(‘RT::Queue=HASH(0x9459a40)’)
called at /usr/local/rt3/local/html/Statistics/Resolution/index.html
line 4
HTML::Mason::Commands::ANON() called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Component.pm line 134

HTML::Mason::Component::run(‘HTML::Mason::Component::
FileBased=HASH(0x946b76c)’) called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm line 1074
eval {…} called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm line 1068
HTML::Mason::Request::comp(‘undef’,‘undef’) called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm line 760

HTML::Mason::Request::call_next(‘HTML::Mason::Request::
ApacheHandler=HASH(0x9090bcc)’) called at
/usr/local/rt3/share/html/autohandler line 189
HTML::Mason::Commands::ANON() called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Component.pm line 134

HTML::Mason::Component::run(‘HTML::Mason::Component::
FileBased=HASH(0x92a7604)’) called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm line 1069
eval {…} called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm line 1068
HTML::Mason::Request::comp(‘undef’,‘undef’,‘undef’) called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm line 338
eval {…} called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm line 338
eval {…} called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm line 297

HTML::Mason::Request::exec(‘HTML::Mason::Request::
ApacheHandler=HASH(0x9090bcc)’) called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/ApacheHandler.pm line
134
eval {…} called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/ApacheHandler.pm line
134

HTML::Mason::Request::ApacheHandler::exec(‘HTML::Mason::Request::
ApacheHandler=HASH(0x9090bcc)’) called at
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason/ApacheHandler.pm line
792

HTML::Mason::ApacheHandler::handle_request(‘HTML::Mason::
ApacheHandler=HASH(0x90e72b8)’,‘Apache=SCALAR(0x9310d8c)’) called at
/usr/local/rt3/bin/webmux.pl line 134
eval {…} called at /usr/local/rt3/bin/webmux.pl line 134
RT::Mason::handler(‘Apache=SCALAR(0x9310d8c)’) called at
/dev/null line 0
eval {…} called at /dev/null line 0
(/usr/local/rt3/lib/RT.pm:247)

PGP.sig (186 Bytes)

Hello,

i just installed the Statistics package which is in the contrib code
directory. But now the statistics don’t show any graphs. I installed
GD::Graph and it’s dependencies (libgd). IMHO the versions should be
correct. Any hints?

Thanx,
Daniel

There is a bug in RTFM that breaks the Statistics package. A new
release of Statistics is in the works. See the mailing list archive for
a fix, or wait some more…
Regards,
Harald